[Testing Update] 2018-02-08 - Kernels, Browsers, Plasma, GCC, Nvidia, Systemd

update
testing

#1

Hi community,

it took us a while to prepare this update-pack. Mostly it is due my busy work life at the moment. However managed to squeze the best new open source software for you into this one:

  • Plasma got updated to v5.12 LTS
  • We updated most of our kernels and rebuild some against the new GCC
  • Ryzen CPUs should now be fully protected when AGESA v1.1.0.1 or higher got applied to your BIOS (also disable PSP)
  • Latest Systemd added
  • Latest Browsers
  • Lates Nvidia Drivers

Our effort and all the needed information about the new security risk can be found here.

So please report back and give us feedback for given changes made to our repositories. Users of our 32-bit Distro should read this.


Current supported Kernels

  • linux316 3.16.53
  • linux318 3.18.94 [EOL]
  • linux41 4.1.48
  • linux44 4.4.116
  • linux49 4.9.89
  • linux414 4.14.18
  • linux415 4.15.2
  • linux-RT-LTS 4.14.15_rt13
  • linux-RT 4.14.15_rt13

Package Updates (Thu Feb 8 14:14:01 CET 2018)

  • testing community x86_64: 584 new and 533 removed package(s)
  • testing core x86_64: 33 new and 34 removed package(s)
  • testing extra x86_64: 339 new and 367 removed package(s)
  • testing multilib x86_64: 11 new and 11 removed package(s)

A detailed list of changes can be found here.


  • No issues, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself. (Please post your solution)
  • Yes I am currently experiencing an issue due to the update. (Please post about it)

0 voters


Check if your mirror has already synced:



Plasma tips
#2

Known issues and solutions

This is a wiki post; please edit as necessary.


My system won’t boot anymore after this update

Most likely you are using a freetype2 package from the AUR. Due the harfbuzz update, your system is broken. So either install the official supported freetype2 package from our repositories or downgrade to harfbuzz v1.7.4: sudo pacman -U https://archive.archlinux.org/packages/h/harfbuzz/harfbuzz-1.7.4-1-x86_64.pkg.tar.xz

You might try also try Freetype2-ultimate5 — fonts like in Infinality's ultimate5 which is a maintained package.


I get “error: command failed to execute correctly” during a GRUB update

Run sudo update-grub once more to ensure the command has worked correctly.


GNOME shell crashes

It’s probably an issue with an extension which needs to be updated. Disable them in turn until you find the one responsible.

If it’s when inserting USB drives, disable “Places Status Indicator”.


Font-Shadow issue within XFCE

Switch to another theme (e.g. Arc Maia), or execute the following cmd to fix the issue:

xfconf-query -c xfce4-desktop -p /desktop-icons/center-text -n -t bool -s false

This fixes the issue properly. (Can follow the links from Ask-Ubuntu #801478 to what exists for the xfce documentation.)

After the command is run the entry <property name="center-text" type="bool" value="false"/> is created under “desktop-icons” in /home/[user]/.config/xfce4/xfconf/xfce-perchannel-xml/xfce4-desktop.xml.


Firefox 58 won’t open

Please check this thread:


I don’t see any updates

That’s because your mirror is out of date. It can take several hours before a mirror get updated. If you want updates right now, run these commands :

sudo pacman-mirrors -f 3
sudo pacman -Syyu

You can always check the state of every mirrors here.


I get a black screen on boot or something doesn’t work

That’s probably because you have a partial set of updated packages. Switch to a text console using CTRL+ALT+F2, log in, then run the commands above.


An AUR package is stopping the update because of a conflict

Remove the AUR package, update, then reinstall the AUR package.


An AUR package says a key is invalid

You need to add the key to your keychain. Do a search of the forum, the answer has already been posted (several times :wink:).



#3

Updated without any issues on kde plasma. :+1::+1:


#4

:point_right: Manjaro team rocks ! All fine here :slight_smile:

Summary

[manjaro@manjaro-pc ~]$ inxi -FxxN
System: Host: manjaro-pc Kernel: 4.14.18-1-MANJARO x86_64 bits: 64 gcc: 7.3.0
Desktop: KDE Plasma 5.12.0 (Qt 5.10.0) dm: sddm,sddm Distro: Manjaro Linux
Machine: Device: laptop System: Dell product: Inspiron 5459 serial: N/A Chassis: type: 9 serial: N/A
Mobo: Dell model: 0TNRDT v: A00 serial: N/A UEFI [Legacy]: Dell v: 1.2.5 date: 10/06/2016
Battery BAT0: charge: 39.0 Wh 100.0% condition: 39.0/37.3 Wh (104%) volts: 16.6/14.8
model: Panasonic DELL 78V9D6A serial: 3572 status: Full
CPU: Dual core Intel Core i5-6200U (-MT-MCP-) arch: Skylake rev.3 cache: 3072 KB
flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 9602
clock speeds: min/max: 400/2800 MHz 1: 817 MHz 2: 806 MHz 3: 727 MHz 4: 827 MHz
Graphics: Card: Intel HD Graphics 520 bus-ID: 00:02.0 chip-ID: 8086:1916
Display Server: x11 (X.Org 1.19.6 ) drivers: intel (unloaded: modesetting)
Resolution: 1366x768@60.00hz
OpenGL: renderer: Mesa DRI Intel HD Graphics 520 (Skylake GT2)
version: 4.5 Mesa 17.3.3 (compat-v: 3.0) Direct Render: Yes
Audio: Card Intel Sunrise Point-LP HD Audio driver: snd_hda_intel bus-ID: 00:1f.3 chip-ID: 8086:9d70
Sound: Advanced Linux Sound Architecture v: k4.14.18-1-MANJARO
Network: Card-1: Intel Wireless 3160 driver: iwlwifi bus-ID: 01:00.0 chip-ID: 8086:08b3
IF: wlp1s0 state: up mac: f4:06:69:ac:99:73
Card-2: Realtek RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller
driver: r8169 v: 2.3LK-NAPI port: e000 bus-ID: 02:00.0 chip-ID: 10ec:8136
IF: enp2s0 state: down mac: 18:db:f2:4f:b3:b5
Drives: HDD Total Size: 480.1GB (4.9% used)
ID-1: /dev/sda model: SanDisk_Ultra_II size: 480.1GB serial: 173040421585
Partition: ID-1: / size: 431G used: 14G (4%) fs: ext4 dev: /dev/sda1
ID-2: swap-1 size: 9.07GB used: 0.00GB (0%) fs: swap dev: /dev/sda2
Sensors: System Temperatures: cpu: 48.0C mobo: 27.8C
Fan Speeds (in rpm): cpu: N/A
Info: Processes: 161 Uptime: 11 min Memory: 1342.5/3650.6MB Init: systemd v: 237 Gcc sys: 7.3.0
Client: Shell (bash 4.4.181 running in yakuake) inxi: 2.3.56
[manjaro@manjaro-pc ~]$


#5

Thank you @philm and the team! Awesome work as we know it <3 Thanks!


#6

Updated without any issues on Xfce. Thank you, Team.


#7

good :slight_smile: work fine
So fresh KDE 5.12.
CPU has not yet cooled down after compilation.


#8

This is the issue I was having on unstable repo , now the issue moved to testing and I moved to stable repo…


#9

Great job getting 5.12 so fast in Testing. Only 1.5G of RAM when booting. This is caused by Kontact and millions of e-mails. But things run great, no problems so far.
Just noticed, also a new Nvidia driver, very nice.


#10

At the begin of boot process I get since the kernel 4.15.2-1 the screen message:

EDAC pnd2: failed to register device with error -22

With kernel 4.14 there is no error message and first release version of 4.15 was fine too.

Found on research, that it seems related to non ECC capable RAM and could be avoided with kernel option oder BIOS setting. But found no more (for me) understandable information and no setting possibility in BIOS. And why no problems in 4.14 and initial 4.15?

The system makes no problems after booting and login, as I can see in the first minutes.


#11

Annoying window/theming changeup for breeze after update on KDE :frowning:

But luckily it is just a new setting in breeze.

System Settings>Application Style>Window Decorations>Breeze>Settings Icon

image

Untick “Draw seperator between Title Bar and Window”

Yay
image

Also, I must say how stoked I am that they finally got rid of the down-and-off-to-the-left shadows in breeze and centered them. Sheesh.


[Stable Update] 2018-02-17 - Kernels, KDE, MATE, Firefox, LibreOffice, Mesa, Systemd
#12

It’s:
System Settings>Application Style>Window Decorations>Breeze>Settings Icon


#13

Oops skipped one, thanks. :wink:


#14

Firefox 58 wouldn’t start on me, but I was able to resolve it from following through with the suggestions from the very helpful thread: Firefox 58 won’t start

Edited to add link, thanks for pointing that out, @cscs


#15

Please point a link or something to what thread you are referring.
(no issues here, but for info purposes)


#16

Which kernels were rebuilt with GCC?


#17

About my error I went back to unstable but this time I compiled f2fs from AUR and it said that I was missing some dependencies so I install them as well and also I was getting an error about:

libtool: warning: ‘…/lib/libf2fs.la’ has not been installed in ‘/usr/lib’

Anyway after installing the missing dependencies I shutdown the pc and started again and everything seems to work ok. I have also installed manjaro f2fs-tools and is working fine now as well.

At the end I dont know if Manjaro fix it or is fixed by installing the missing dependencies that have been installed from Aur?


#18

nice to see plasma update already here. Wayland on kde still sucks though.


#19

Everything great here on KDE. Update with no issues.

I also had the line added between the window border and top toolbar, but this is a KDE item and not a Manjaro item. Several people are also posting about it on the KDE subreddit and KDE Neon forums. May be something Manjaro wants to change the default for the Manjaro theme so it retains the original look-and-feel, but some people like the line. :slight_smile:


#20

Yeah, its just a new setting, not locked :wink:
I wonder how much anyone thinks that is more desirable than without … but what do I know?