[Testing Update] 2018-01-27 - Adapta, Firefox-Dev, Firmwares, Haskell

update
testing

#1

Hi community,

with this we updated our adapta theme, firefox-dev, downgraded the Intel microcode as needed puls reworked our firmwares a little in regard of iwlwifi. As usual we have some Haskell rebuilds/updates.

Our effort and all the needed information about the new security risk can be found here.

So please report back and give us feedback for given changes made to our repositories. Users of our 32-bit Distro should read this.


Current supported Kernels

  • linux316 3.16.52
  • linux318 3.18.92 [EOL]
  • linux41 4.1.48
  • linux44 4.4.113
  • linux49 4.9.78
  • linux412 4.12.14 [EOL]
  • linux413 4.13.16 [EOL]
  • linux414 4.14.14
  • linux415 4.15-rc9
  • linux-RT-LTS 4.9.76_rt61
  • linux-RT 4.11.12_rt16

Package Updates (Sat Jan 27 08:23:56 CET 2018)

  • testing community x86_64: 221 new and 215 removed package(s)
  • testing core x86_64: 1 new and 0 removed package(s)
  • testing extra x86_64: 14 new and 15 removed package(s)
  • testing multilib x86_64: 5 new and 5 removed package(s)
:: Different overlay package(s) in repository community x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-01-26           2018-01-27
-------------------------------------------------------------------------------
           adapta-black-breath-theme          3.93.0.43-1          3.93.0.72-1
             adapta-black-maia-theme          3.93.0.43-1          3.93.0.72-1
                 adapta-breath-theme          3.93.0.43-1          3.93.0.72-1
                   adapta-maia-theme          3.93.0.43-1          3.93.0.72-1


:: Different sync package(s) in repository community x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-01-26           2018-01-27
-------------------------------------------------------------------------------
               aarch64-linux-gnu-gcc              7.2.0-2              7.3.0-1
                   arm-none-eabi-gcc              7.2.0-2              7.3.0-1
                              astyle              3.0.1-1                3.1-1
                                atom             1.23.3-1             1.23.3-2
                             avr-gcc              7.2.0-3              7.3.0-1
                            bfgminer              5.4.2-2              5.5.0-1
                               cacti             1.1.29-1             1.1.30-1
                             calibre             3.15.0-1             3.16.0-1
                               darcs   2.12.5.20170909-27   2.12.5.20170909-28
                         deepin-menu              3.2.0-2              3.2.0-3
                           duplicity             0.7.15-1             0.7.16-1
                            electron             1.6.15-1             1.7.11-1
           firefox-developer-edition             59.0b3-2             59.0b4-1
  firefox-developer-edition-i18n-ach             59.0b3-1             59.0b4-1
   firefox-developer-edition-i18n-af             59.0b3-1             59.0b4-1
   firefox-developer-edition-i18n-an             59.0b3-1             59.0b4-1
   firefox-developer-edition-i18n-ar             59.0b3-1             59.0b4-1
   firefox-developer-edition-i18n-as             59.0b3-1             59.0b4-1
  firefox-developer-edition-i18n-ast             59.0b3-1             59.0b4-1
   firefox-developer-edition-i18n-az             59.0b3-1             59.0b4-1
   firefox-developer-edition-i18n-be             59.0b3-1             59.0b4-1
   firefox-developer-edition-i18n-bg             59.0b3-1             59.0b4-1
firefox-developer-edition-i18n-bn-bd             59.0b3-1             59.0b4-1
firefox-developer-edition-i18n-bn-in             59.0b3-1             59.0b4-1
   firefox-developer-edition-i18n-br             59.0b3-1             59.0b4-1
   firefox-developer-edition-i18n-bs             59.0b3-1             59.0b4-1
   firefox-developer-edition-i18n-ca             59.0b3-1             59.0b4-1
  firefox-developer-edition-i18n-cak             59.0b3-1             59.0b4-1
   firefox-developer-edition-i18n-cs             59.0b3-1             59.0b4-1
   firefox-developer-edition-i18n-cy             59.0b3-1             59.0b4-1
   firefox-developer-edition-i18n-da             59.0b3-1             59.0b4-1
   firefox-developer-edition-i18n-de             59.0b3-1             59.0b4-1
  firefox-developer-edition-i18n-dsb             59.0b3-1             59.0b4-1
   firefox-developer-edition-i18n-el             59.0b3-1             59.0b4-1
firefox-developer-edition-i18n-en-gb             59.0b3-1             59.0b4-1
firefox-developer-edition-i18n-en-us             59.0b3-1             59.0b4-1
firefox-developer-edition-i18n-en-za             59.0b3-1             59.0b4-1
   firefox-developer-edition-i18n-eo             59.0b3-1             59.0b4-1
firefox-developer-edition-i18n-es-ar             59.0b3-1             59.0b4-1
firefox-developer-edition-i18n-es-cl             59.0b3-1             59.0b4-1
firefox-developer-edition-i18n-es-es             59.0b3-1             59.0b4-1
firefox-developer-edition-i18n-es-mx             59.0b3-1             59.0b4-1
   firefox-developer-edition-i18n-et             59.0b3-1             59.0b4-1
   firefox-developer-edition-i18n-eu             59.0b3-1             59.0b4-1
   firefox-developer-edition-i18n-fa             59.0b3-1             59.0b4-1
   firefox-developer-edition-i18n-ff             59.0b3-1             59.0b4-1
   firefox-developer-edition-i18n-fi             59.0b3-1             59.0b4-1
   firefox-developer-edition-i18n-fr             59.0b3-1             59.0b4-1
firefox-developer-edition-i18n-fy-nl             59.0b3-1             59.0b4-1
firefox-developer-edition-i18n-ga-ie             59.0b3-1             59.0b4-1
   firefox-developer-edition-i18n-gd             59.0b3-1             59.0b4-1
   firefox-developer-edition-i18n-gl             59.0b3-1             59.0b4-1
   firefox-developer-edition-i18n-gn             59.0b3-1             59.0b4-1
firefox-developer-edition-i18n-gu-in             59.0b3-1             59.0b4-1
   firefox-developer-edition-i18n-he             59.0b3-1             59.0b4-1
firefox-developer-edition-i18n-hi-in             59.0b3-1             59.0b4-1
   firefox-developer-edition-i18n-hr             59.0b3-1             59.0b4-1
  firefox-developer-edition-i18n-hsb             59.0b3-1             59.0b4-1
   firefox-developer-edition-i18n-hu             59.0b3-1             59.0b4-1
firefox-developer-edition-i18n-hy-am             59.0b3-1             59.0b4-1
   firefox-developer-edition-i18n-id             59.0b3-1             59.0b4-1
   firefox-developer-edition-i18n-is             59.0b3-1             59.0b4-1
   firefox-developer-edition-i18n-it             59.0b3-1             59.0b4-1
   firefox-developer-edition-i18n-ja             59.0b3-1             59.0b4-1
   firefox-developer-edition-i18n-ka             59.0b3-1             59.0b4-1
  firefox-developer-edition-i18n-kab             59.0b3-1             59.0b4-1
   firefox-developer-edition-i18n-kk             59.0b3-1             59.0b4-1
   firefox-developer-edition-i18n-km             59.0b3-1             59.0b4-1
   firefox-developer-edition-i18n-kn             59.0b3-1             59.0b4-1
   firefox-developer-edition-i18n-ko             59.0b3-1             59.0b4-1
  firefox-developer-edition-i18n-lij             59.0b3-1             59.0b4-1
   firefox-developer-edition-i18n-lt             59.0b3-1             59.0b4-1
   firefox-developer-edition-i18n-lv             59.0b3-1             59.0b4-1
  firefox-developer-edition-i18n-mai             59.0b3-1             59.0b4-1
   firefox-developer-edition-i18n-mk             59.0b3-1             59.0b4-1
   firefox-developer-edition-i18n-ml             59.0b3-1             59.0b4-1
   firefox-developer-edition-i18n-mr             59.0b3-1             59.0b4-1
   firefox-developer-edition-i18n-ms             59.0b3-1             59.0b4-1
   firefox-developer-edition-i18n-my             59.0b3-1             59.0b4-1
firefox-developer-edition-i18n-nb-no             59.0b3-1             59.0b4-1
   firefox-developer-edition-i18n-nl             59.0b3-1             59.0b4-1
firefox-developer-edition-i18n-nn-no             59.0b3-1             59.0b4-1
   firefox-developer-edition-i18n-or             59.0b3-1             59.0b4-1
firefox-developer-edition-i18n-pa-in             59.0b3-1             59.0b4-1
   firefox-developer-edition-i18n-pl             59.0b3-1             59.0b4-1
firefox-developer-edition-i18n-pt-br             59.0b3-1             59.0b4-1
firefox-developer-edition-i18n-pt-pt             59.0b3-1             59.0b4-1
   firefox-developer-edition-i18n-rm             59.0b3-1             59.0b4-1
   firefox-developer-edition-i18n-ro             59.0b3-1             59.0b4-1
   firefox-developer-edition-i18n-ru             59.0b3-1             59.0b4-1
   firefox-developer-edition-i18n-si             59.0b3-1             59.0b4-1
   firefox-developer-edition-i18n-sk             59.0b3-1             59.0b4-1
   firefox-developer-edition-i18n-sl             59.0b3-1             59.0b4-1
  firefox-developer-edition-i18n-son             59.0b3-1             59.0b4-1
   firefox-developer-edition-i18n-sq             59.0b3-1             59.0b4-1
   firefox-developer-edition-i18n-sr             59.0b3-1             59.0b4-1
firefox-developer-edition-i18n-sv-se             59.0b3-1             59.0b4-1
   firefox-developer-edition-i18n-ta             59.0b3-1             59.0b4-1
   firefox-developer-edition-i18n-te             59.0b3-1             59.0b4-1
   firefox-developer-edition-i18n-th             59.0b3-1             59.0b4-1
   firefox-developer-edition-i18n-tr             59.0b3-1             59.0b4-1
   firefox-developer-edition-i18n-uk             59.0b3-1             59.0b4-1
   firefox-developer-edition-i18n-ur             59.0b3-1             59.0b4-1
   firefox-developer-edition-i18n-uz             59.0b3-1             59.0b4-1
   firefox-developer-edition-i18n-vi             59.0b3-1             59.0b4-1
   firefox-developer-edition-i18n-xh             59.0b3-1             59.0b4-1
firefox-developer-edition-i18n-zh-cn             59.0b3-1             59.0b4-1
firefox-developer-edition-i18n-zh-tw             59.0b3-1             59.0b4-1
                                fltk              1.3.4-2            1.3.4.2-2
                           fltk-docs              1.3.4-2            1.3.4.2-2
                          fltk-games              1.3.4-2            1.3.4.2-2
                           git-annex        6.20180112-32        6.20180112-33
                      gnome-software             3.26.5-1             3.26.5-2
                                gqrx                2.9-2               2.10-1
               haskell-asn1-encoding             0.9.5-28             0.9.5-29
                  haskell-asn1-parse             0.9.4-39             0.9.4-40
                  haskell-asn1-types             0.3.2-35             0.3.2-36
                haskell-authenticate             1.3.4-22             1.3.4-23
                         haskell-aws              0.18-27              0.18-28
                  haskell-cipher-aes            0.2.11-33            0.2.11-34
               haskell-clientsession           0.9.1.2-38           0.9.1.2-39
                  haskell-connection             0.2.8-40             0.2.8-41
                   haskell-cprng-aes             0.6.1-36             0.6.1-37
         haskell-crypto-cipher-types             0.0.9-33             0.0.9-34
              haskell-crypto-numbers             0.2.7-34             0.2.7-35
               haskell-crypto-pubkey             0.2.8-40             0.2.8-41
         haskell-crypto-pubkey-types             0.4.3-32             0.4.3-33
               haskell-crypto-random             0.0.9-36             0.0.9-37
                  haskell-cryptohash            0.11.9-43            0.11.9-44
          haskell-cryptohash-conduit            0.1.1-128            0.1.1-129
                  haskell-cryptonite              0.24-16              0.24-17
          haskell-cryptonite-conduit             0.2.2-21             0.2.2-22
                         haskell-dav            1.3.1-202            1.3.1-203
                         haskell-dns              3.0.1-1              3.0.1-2
                      haskell-hakyll          4.10.0.0-47          4.10.0.0-48
                         haskell-hit             0.6.3-65             0.6.3-66
                    haskell-hopenpgp            2.5.5-151            2.5.5-152
                       haskell-hpack            0.21.2-18            0.21.2-19
             haskell-http-client-tls           0.3.5.1-33           0.3.5.1-34
                haskell-http-conduit             2.2.4-20             2.2.4-21
                        haskell-jose           0.6.0.3-19           0.6.0.3-20
                         haskell-jwt             0.7.2-26             0.7.2-27
                      haskell-memory            0.14.13-2            0.14.14-1
                      haskell-nettle             0.2.0-31             0.2.0-32
                  haskell-pipes-http             1.0.5-78             1.0.5-79
                      haskell-rebase              1.2.2-8              1.2.3-2
                    haskell-rerebase              1.2.1-8             1.2.1-10
             haskell-safe-exceptions            0.1.6.0-4            0.1.7.0-1
                   haskell-securemem             0.1.9-33             0.1.9-34
              haskell-servant-server              0.12-34              0.12-35
                       haskell-store           0.4.3.2-44           0.4.3.2-45
                         haskell-tls             1.4.0-18             1.4.0-19
         haskell-tls-session-manager            0.0.0.2-9           0.0.0.2-10
              haskell-wai-app-static          3.1.6.1-130          3.1.6.1-131
       haskell-wai-middleware-static             0.8.1-18             0.8.1-19
                    haskell-warp-tls             3.2.4-40             3.2.4-41
                        haskell-x509             1.7.2-16             1.7.2-17
                  haskell-x509-store             1.6.5-16             1.6.5-17
                 haskell-x509-system             1.6.6-16             1.6.6-17
             haskell-x509-validation             1.6.9-16             1.6.9-17
                       haskell-yesod            1.4.5-166            1.4.5-167
                  haskell-yesod-auth            1.4.21-44            1.4.21-45
                  haskell-yesod-core          1.4.37.2-33          1.4.37.2-34
               haskell-yesod-default            1.2.0-236            1.2.0-237
                  haskell-yesod-form            1.4.16-61            1.4.16-62
            haskell-yesod-persistent             1.4.3-42             1.4.3-43
                haskell-yesod-static           1.5.3.1-68           1.5.3.1-69
                  haskell-yesod-test           1.5.9.1-25           1.5.9.1-26
                         hledger-api               1.5-33               1.5-34
                         hledger-web               1.5-30               1.5-31
                              hoogle            5.0.14-40            5.0.14-41
                      hopenpgp-tools            0.19.5-55            0.19.5-56
                                jmol            14.28.4-1            14.29.1-1
                             libvirt             3.10.0-1              4.0.0-1
                 messengerfordesktop  2.0.9+42+g4e4d6f1-3  2.0.9+42+g4e4d6f1-4
                           metapixel              1.0.2-8              1.0.2-9
                                 min              1.6.3-1              1.7.0-1
                            mod_wsgi             4.5.20-1             4.5.24-1
                           mod_wsgi2             4.5.20-1             4.5.24-1
                  nextcloud-app-mail              0.7.8-1              0.7.9-1
                              nickle               2.70-5               2.80-1
                           nltk-data              3.2.1-1              3.2.5-1
                          obs-studio             21.0.1-1             21.0.2-1
                          packagekit              1.1.8-1              1.1.8-2
                              pandoc             2.0.6-26             2.0.6-27
                     pandoc-citeproc          0.12.2.5-27          0.12.2.5-28
                     pandoc-crossref           0.3.0.1-14           0.3.0.1-15
                           postgrest           0.4.4.0-19           0.4.4.0-20
                    python-ansi2html              1.2.0-1              1.3.0-1
                        python-boto3             1.5.20-1             1.5.21-1
                        python-d2to1       0.2.12.post1-2       0.2.12.post1-3
                      python-dropbox              8.5.0-1              8.6.0-1
                       python-llfuse              1.3.2-1              1.3.2-2
                      python-pexpect              4.3.0-1              4.3.1-1
                        python-sybil              1.0.6-1              1.0.7-1
                       python2-d2to1       0.2.12.post1-2       0.2.12.post1-3
                     python2-dropbox              8.5.0-1              8.6.0-1
                      python2-llfuse              1.3.2-1              1.3.2-2
                     python2-pexpect              4.3.0-1              4.3.1-1
                       python2-sybil              1.0.6-1              1.0.7-1
                            redshift               1.11-4               1.11-5
                            rubinius               3.93-1               3.95-1
                       rubinius-ruby               3.93-1               3.95-1
                               stack             1.6.3-47             1.6.3-48
                            startdde             3.1.23-1             3.1.24-1
                       syncthing-gtk          1:0.9.2.7-3          1:0.9.2.7-4
                             sysstat             11.4.6-1             11.6.2-1
                      tamarin-prover             1.2.2-68             1.2.2-69
                                 tor            0.3.1.9-2            0.3.2.9-1
                            wxpython            3.0.2.0-5            3.0.2.0-6
                                xdot                0.9-1                0.9-2
   firefox-developer-edition-i18n-ia                    -             59.0b4-1
firefox-developer-edition-i18n-ne-np                    -             59.0b4-1
               gedit-code-assistance                    -  3.16.0+4+gd19b879-1
               gnome-code-assistance                    - 3.16.1+12+g5418ece-1
    gnome-software-packagekit-plugin                    -             3.26.5-2
                  libpackagekit-glib                    -              1.1.8-2


:: Different overlay package(s) in repository core x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-01-26           2018-01-27
-------------------------------------------------------------------------------
                      linux-firmware   20180119.2a713be-1   20180119.2a713be-2


:: Different overlay package(s) in repository extra x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-01-26           2018-01-27
-------------------------------------------------------------------------------
                         intel-ucode                    -           20171117-1


:: Different sync package(s) in repository extra x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-01-26           2018-01-27
-------------------------------------------------------------------------------
                              clamav             0.99.2-7             0.99.3-1
               gedit-code-assistance  3.16.0+4+gd19b879-1                    -
               gnome-code-assistance  3.16.1+6+ga46522a-1                    -
                        pyqt5-common              5.9.2-2               5.10-1
                      python-astroid              1.6.0-1              1.6.1-1
                       python-pylint              1.8.1-1              1.8.2-1
                        python-pyqt5              5.9.2-2               5.10-1
                          python-sip             4.19.6-1             4.19.7-1
                     python2-astroid              1.6.0-1              1.6.1-1
                      python2-pylint              1.8.1-1              1.8.2-1
                       python2-pyqt5              5.9.2-2               5.10-1
                         python2-sip             4.19.6-1             4.19.7-1
                                 sip             4.19.6-1             4.19.7-1
                                 w3m  0.5.3.git20171120-1  0.5.3.git20180125-1
                  xfce4-timer-plugin              1.6.0-4              1.7.0-1


:: Different sync package(s) in repository multilib x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-01-26           2018-01-27
-------------------------------------------------------------------------------
             lib32-libva-mesa-driver             17.3.2-2             17.3.3-1
                          lib32-mesa             17.3.2-2             17.3.3-1
                    lib32-mesa-vdpau             17.3.2-2             17.3.3-1
                  lib32-vulkan-intel             17.3.2-2             17.3.3-1
                 lib32-vulkan-radeon             17.3.2-2             17.3.3-1

  • No issues, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself. (Please post your solution)
  • Yes I am currently experiencing an issue due to the update. (Please post about it)

0 voters


Check if your mirror has already synced:


#2

Ok, I went to https://reposcope.com/package/intel-ucode and got the 22.11.2017 intel-ucode to downgrade. But, what was the actual reason why it was downgraded? I read what Linus said about it but didn’t understand the full details.


#3

Because the patch from Intel cause some instability on some system…


#4

No need to, just use pacman.

sudo pacman -Syyuu

You should be prompted to downgrade intel-ucode.

warning: intel-ucode: downgrading from version 20180108-1 to version 20171117-1

#5

I did, but I had to get the old package online because my /var/cache/pacman folder is on tmpfs. And I had rebooted since upgrading testing last time and it had cleared.


#6

Why remove your locale cache? You can Lost Manjaro specific pkgs… We don’t provide an ALA service for our pkgs…


#7

You mistake using the downgrade tool with pacman downgrade option.

Pacman downgrade is used when a repo package version is less than your installed version. This happens when maintainers replace a package with an earlier version due to issues, or when changing branches.

This is the current version in the repos, you do not need to retrieve it externally and install it manually.

$ pacman -Qi intel-ucode
Name            : intel-ucode
Version         : 20171117-1
Description     : Microcode update files for Intel CPUs

#8

Reposcope.com provides the manjaro packages if I need to rollback. I keep the cache on tmpfs to save on disk space. Although, maybe it isn’t the best course of action.

@sueridgepipe
I see. I’ll remember that for next time.


#10

Is there a possibility to load the microcode on a running machine?

Or is a reboot essential?


#12

I have this warning:

:: Starte vollständige Systemaktualisierung…
Warnung: intel-ucode: Lokale Version (20180108-1) ist neuer als extra (20171117-1)

Downgrade or not?

$ pacman -Qi intel-ucode
Name : intel-ucode
Version : 20180108-1


#13

If you have no issues you can leave the newer firmware in place. If you have issues (e.g. spurious reboots as reported across the web) you can downgrade it.

You could also read the thread as the majority of the posts covered this already.


#14

Have no issues. Thank you for this answer.


#15

@LAZA Since microcode updates are applied by the kernel during boot (according to Arch wiki), a reboot is necessary in order to use the new version.

Nothing to report for now. I updated from most recent Stable updates on an almost fresh install of Manjaro Cinnamon with kernel 4.14 (with kernel-alive).


#16

Thanks for your answer, i suspected that. (but wasn’t sure)


#17

Thanks a lot. everything running cool :slight_smile:


#18

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.