[Testing Update] 2018-01-15 - Vertex, Systemd, Haskell, Python, Linux v4.15

update
testing

#1

Hi community,

Codruț worked on the vertex-maia-icons, we had another systemd update plus the usual haskell and python rebuilds. Additionally we released linux v4.15-rc8 including the new Retpoline patches against Spectre.

Our effort and all the needed information about the new security risk can be found here.

So please report back and give us feedback for given changes made to our repositories. Users of our 32-bit Distro should read this.


Current supported Kernels

  • linux316 3.16.52
  • linux318 3.18.91 [EOL]
  • linux41 4.1.48
  • linux44 4.4.111
  • linux49 4.9.76
  • linux412 4.12.14 [EOL]
  • linux413 4.13.16 [EOL]
  • linux414 4.14.13
  • linux415 4.15-rc8
  • linux-RT-LTS 4.9.68_rt60
  • linux-RT 4.11.12_rt16

Package Updates (Mon Jan 15 07:47:31 CET 2018)

  • testing community x86_64: 158 new and 157 removed package(s)
  • testing core x86_64: 6 new and 6 removed package(s)
  • testing extra x86_64: 20 new and 20 removed package(s)
  • testing multilib x86_64: 1 new and 0 removed package(s)
:: Different overlay package(s) in repository community x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-01-14           2018-01-15
-------------------------------------------------------------------------------
                          i3-scripts           20161003-1           20180114-1
            spectre-meltdown-checker               0.28-1               0.31-1
              vertex-maia-icon-theme           20180114-1           20180115-1
               deepin-control-center                    -            4.3.7-1.1


:: Different sync package(s) in repository community x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-01-14           2018-01-15
-------------------------------------------------------------------------------
                             cblrepo            0.24.0-49            0.24.0-50
                               darcs   2.12.5.20170909-19   2.12.5.20170909-20
                              docker          1:17.12.0-1          1:18.01.0-1
                             driconf             0.9.1-11             0.9.1-12
                             dtkcore          1:2.0.5.3-1            1:2.0.6-1
                           dtkwidget            2.0.5.3-1              2.0.6-1
                               dtkwm              2.0.5-3              2.0.6-1
                                fish              2.7.0-1              2.7.1-1
                                gist              4.6.1-1              4.6.2-1
                           git-annex         6.20180112-2         6.20180112-3
                              gradle                4.4-1              4.4.1-1
                          gradle-doc                4.4-1              4.4.1-1
                          gradle-src                4.4-1              4.4.1-1
                       haskell-aeson            1.2.3.0-3            1.2.3.0-4
         haskell-aeson-better-errors           0.9.1.0-33           0.9.1.0-34
                haskell-aeson-compat            0.3.7.1-9           0.3.7.1-10
                haskell-aeson-pretty             0.8.5-17             0.8.5-18
                    haskell-aeson-qq              0.8.2-3              0.8.2-4
                  haskell-attoparsec           0.13.2.0-6           0.13.2.2-1
          haskell-attoparsec-iso8601           1.0.0.0-16           1.0.0.0-17
                haskell-authenticate             1.3.4-11             1.3.4-12
                         haskell-aws              0.18-16              0.18-17
              haskell-binary-orphans            0.1.8.0-5            0.1.8.0-6
               haskell-binary-tagged           0.1.4.2-37           0.1.4.2-38
                  haskell-bower-json           1.0.0.1-31           1.0.0.1-32
                     haskell-cassava            0.5.1.0-7            0.5.1.0-8
                  haskell-cheapskate             0.1.1-20             0.1.1-21
         haskell-conduit-combinators              1.1.2-9             1.1.2-10
               haskell-conduit-extra            1.2.3.2-3            1.2.3.2-4
                haskell-configurator           0.3.0.0-21           0.3.0.0-22
             haskell-configurator-ng            0.0.0.1-8            0.0.0.1-9
                   haskell-criterion            1.3.0.0-1            1.3.0.0-2
          haskell-cryptohash-conduit            0.1.1-122            0.1.1-123
          haskell-cryptonite-conduit             0.2.2-15             0.2.2-16
                    haskell-css-text           0.1.2.2-23           0.1.2.2-24
             haskell-data-serializer              0.3.2-3              0.3.2-4
                haskell-data-textual           0.3.0.2-27           0.3.0.2-28
                         haskell-dav            1.3.1-187            1.3.1-188
                 haskell-descriptive             0.9.4-69             0.9.4-70
                         haskell-dns             3.0.0-14             3.0.0-15
                haskell-doctemplates              0.2.1-3              0.2.1-4
              haskell-email-validate              2.3.2-3              2.3.2-4
                   haskell-esqueleto             2.5.3-38             2.5.3-39
                        haskell-feed           1.0.0.0-14           1.0.0.0-15
             haskell-haddock-library              1.4.5-5              1.4.5-6
                      haskell-hakyll          4.10.0.0-23          4.10.0.0-24
                       haskell-hasql              1.1.1-6              1.1.1-7
                  haskell-hasql-pool              0.4.3-6              0.4.3-7
           haskell-hasql-transaction              0.5.2-6              0.5.2-7
                         haskell-hit             0.6.3-60             0.6.3-61
                haskell-hjsonpointer              1.3.0-2              1.3.0-3
                 haskell-hjsonschema              1.7.1-3              1.7.1-4
                    haskell-hopenpgp            2.5.5-139            2.5.5-140
                       haskell-hpack             0.21.2-8             0.21.2-9
                   haskell-hspec-wai              0.9.0-9             0.9.0-10
              haskell-hspec-wai-json             0.9.0-10             0.9.0-11
                haskell-html-conduit            1.2.1.2-3            1.2.1.2-4
               haskell-http-api-data           0.3.7.1-22           0.3.7.1-23
                haskell-http-conduit             2.2.4-12             2.2.4-13
                   haskell-http-date           0.0.6.1-32           0.0.6.1-33
                         haskell-ini              0.3.5-2              0.3.5-3
   haskell-insert-ordered-containers           0.2.1.0-37           0.2.1.0-38
                        haskell-jose           0.6.0.3-10           0.6.0.3-11
                         haskell-jwt             0.7.2-21             0.7.2-22
                  haskell-lens-aeson             1.0.2-18             1.0.2-19
                      haskell-libmpd            0.9.0.7-3            0.9.0.7-4
             haskell-microlens-aeson            2.2.0.2-4            2.2.0.2-5
                 haskell-microstache            1.0.1.1-9           1.0.1.1-10
                haskell-monad-logger             0.3.26-9            0.3.26-10
                  haskell-network-ip           0.3.0.2-11           0.3.0.2-12
          haskell-openpgp-asciiarmor               0.1-24               0.1-25
                haskell-pandoc-types             1.17.3-3             1.17.3-4
                     haskell-parsers             0.12.8-1             0.12.8-2
                        haskell-path             0.6.1-13             0.6.1-14
                     haskell-path-io              1.3.3-9             1.3.3-10
                  haskell-persistent              2.7.3-9             2.7.3-10
           haskell-persistent-sqlite             2.6.4-15             2.6.4-16
         haskell-persistent-template             2.5.3-18             2.5.3-19
           haskell-postgresql-binary            0.12.1-39            0.12.1-40
            haskell-project-template             0.2.0-87             0.2.0-88
                     haskell-servant             0.12.1-4             0.12.1-5
              haskell-servant-server              0.12-21              0.12-22
             haskell-servant-swagger             1.1.4-14             1.1.4-15
                 haskell-shakespeare           2.0.14.1-2           2.0.14.1-3
                 haskell-skylighting            0.5.0.1-2            0.5.0.1-3
                   haskell-sourcemap             0.1.6-41             0.1.6-42
                  haskell-statistics          0.14.0.2-15          0.14.0.2-16
                    haskell-swagger2                2.2-5                2.2-6
           haskell-tagstream-conduit          0.5.5.3-107          0.5.5.3-108
         haskell-tamarin-prover-term              1.2.2-6              1.2.2-7
       haskell-tamarin-prover-theory             1.2.2-10             1.2.2-11
                     haskell-texmath             0.10.1-2             0.10.1-3
                    haskell-trifecta           1.7.1.1-19           1.7.1.1-20
              haskell-uri-bytestring            0.3.1.0-1            0.3.1.0-2
              haskell-wai-app-static          3.1.6.1-119          3.1.6.1-120
                    haskell-wai-cors              0.2.6-2              0.2.6-3
                   haskell-wai-extra           3.0.21.0-4           3.0.21.0-5
          haskell-wai-handler-launch            3.0.2.3-6            3.0.2.3-7
              haskell-wai-websockets           3.0.1.1-36           3.0.1.1-37
                        haskell-warp            3.2.13-12            3.2.13-13
                    haskell-warp-tls             3.2.4-33             3.2.4-34
                  haskell-websockets           0.12.3.1-1           0.12.3.1-2
                      haskell-xcffib             0.5.1-50             0.5.1-51
                 haskell-xml-conduit            1.7.0.1-4            1.7.0.1-5
                  haskell-xml-hamlet           0.4.1.1-15           0.4.1.1-16
                haskell-xss-sanitize           0.3.5.7-31           0.3.5.7-32
                        haskell-yaml           0.8.25.1-3           0.8.25.1-4
                       haskell-yesod            1.4.5-149            1.4.5-150
                  haskell-yesod-auth            1.4.21-26            1.4.21-27
                  haskell-yesod-core          1.4.37.2-20          1.4.37.2-21
               haskell-yesod-default            1.2.0-223            1.2.0-224
                  haskell-yesod-form            1.4.16-46            1.4.16-47
            haskell-yesod-persistent             1.4.3-28             1.4.3-29
                haskell-yesod-static           1.5.3.1-55           1.5.3.1-56
                  haskell-yesod-test            1.5.9.1-9           1.5.9.1-10
                             hindent           5.2.4.1-10           5.2.4.1-11
                             hledger                1.5-4                1.5-5
                         hledger-api               1.5-13               1.5-14
                          hledger-ui                1.5-7                1.5-8
                         hledger-web               1.5-10               1.5-11
                               hlint            2.0.11-11            2.0.11-12
                              hoogle            5.0.14-26            5.0.14-27
                      hopenpgp-tools            0.19.5-40            0.19.5-41
                            hyperion            1.03.2-13            1.03.2-14
                               idris              1.2.0-2              1.2.0-3
                             jenkins              2.101-1              2.102-1
                               lynis              2.5.7-1              2.5.9-1
                               medit              1.2.0-3              1.2.0-4
                            moserial             3.0.11-2             3.0.12-1
                                nrpe              3.2.1-1              3.2.1-2
                              pandoc              2.0.6-9             2.0.6-10
                     pandoc-citeproc           0.12.2.5-8           0.12.2.5-9
                     pandoc-crossref           0.3.0.0-16           0.3.0.0-17
                               ponyc             0.21.2-1             0.21.3-1
                           postgrest            0.4.4.0-1            0.4.4.0-2
                       python-distro              1.1.0-1              1.2.0-2
                     python-nautilus              1.2.1-3              1.2.2-1
                        python-pyicu              2.0.1-1              2.0.2-1
                         python-yarl             0.16.0-1             0.18.0-1
                      python2-distro              1.1.0-1              1.2.0-2
                    python2-nautilus              1.2.1-3              1.2.2-1
                       python2-pyicu              2.0.1-1              2.0.2-1
                             radare2              2.1.0-1              2.2.0-1
                     simutrans-pak64              120.2-1              120.3-1
                            smplayer            17.11.2-2             18.1.0-1
                              sqlmap             1.1.12-1                1.2-1
                               stack             1.6.3-22             1.6.3-23
                     stylish-haskell           0.8.1.0-31           0.8.1.0-32
                      tamarin-prover             1.2.2-54             1.2.2-55
                       wireshark-cli              2.4.3-2              2.4.4-1
                    wireshark-common              2.4.3-2              2.4.4-1
                       wireshark-gtk              2.4.3-2              2.4.4-1
                        wireshark-qt              2.4.3-2              2.4.4-1
                              xmobar            0.24.5-11            0.24.5-12


:: Different overlay package(s) in repository core x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-01-14           2018-01-15
-------------------------------------------------------------------------------
                      linux415 4.15.r180107.gb2cd1df-1 4.15.r180114.ga8750dd-1
              linux415-headers 4.15.r180107.gb2cd1df-1 4.15.r180114.ga8750dd-1


:: Different sync package(s) in repository core x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-01-14           2018-01-15
-------------------------------------------------------------------------------
                          libseccomp              2.3.2-1              2.3.2-2
                          libsystemd              236.0-3             236.80-1
                             systemd              236.0-3             236.80-1
                  systemd-sysvcompat              236.0-3             236.80-1


:: Different overlay package(s) in repository extra x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-01-14           2018-01-15
-------------------------------------------------------------------------------
                           calamares             3.1.12-2             3.1.12-3
                 calamares-git 3.2.0.r4279.c857568b7-2 3.2.0.r4302.bff689035-1
          grub-theme-live-common-dev             17.1.1-2             17.1.1-3
         grub-theme-live-manjaro-dev             17.1.1-2             17.1.1-3
              grub-theme-manjaro-dev             17.1.1-2             17.1.1-3
                  linux415-acpi_call            1.1.0-0.6           1.1.0-0.11
                   linux415-bbswitch             0.8-0.10             0.8-0.11
                   linux415-catalyst   1:15.201.1151-0.10   1:15.201.1151-0.11
                     linux415-nvidia       1:384.111-0.10       1:384.111-0.11
               linux415-nvidia-304xx       1:304.137-0.10       1:304.137-0.11
               linux415-nvidia-340xx         340.104-0.10         340.104-0.11
                   linux415-nvidiabl            0.88-0.10            0.88-0.11
                linux415-vhba-module        20161009-0.10        20161009-0.11
   linux415-virtualbox-guest-modules            5.2.4-0.1           5.2.4-0.11
    linux415-virtualbox-host-modules            5.2.4-0.1           5.2.4-0.11


:: Different sync package(s) in repository extra x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-01-14           2018-01-15
-------------------------------------------------------------------------------
                               irssi              1.0.5-1              1.0.6-1
                             jsoncpp              1.8.3-2              1.8.4-1
                         jsoncpp-doc              1.8.3-2              1.8.4-1
                             libpqxx              5.1.0-1              6.0.0-1
                           memcached              1.5.3-1              1.5.4-1


:: Different overlay package(s) in repository multilib x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-01-14           2018-01-15
-------------------------------------------------------------------------------
                       lib32-systemd                    -             236.80-0

  • No issues, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself. (Please post your solution)
  • Yes I am currently experiencing an issue due to the update. (Please post about it)

0 voters


Check if your mirror has already synced:


#2

Known issues and solutions

This is a wiki post; please edit as necessary


My rtl8723be wifi card stopped working

You may need to specify (or switch) the antenna selection via the ant_sel driver option, e.g.:

echo "options rtl8723be ant_sel=2" | sudo tee /etc/modprobe.d/50-rtl8723be.conf

If you already have an driver options file try switching the option between 0, 1, and 2.


Network connection is unreliable, not working, or not connecting

Occasionally, Network Manager updates change the underlying settings structure (schemas). This can change or break existing settings without you knowing about it.

This can be fixed by removing the existing connection settings, and then re-adding the connection. You may also need to reboot. If this does not work, move to the next point.


networkmanager 1.10.2-1 does not get an IP address

For some configurations, Network Manager tries to use its internal DHCP client which appears to be incompatible with some wireless access points. This shows up as a timeout during the connection attempt.

To switch back to the previous behaviour of 1.10.0, run the following from a terminal:

echo -e "[main]\ndhcp=dhclient" | sudo tee /etc/NetworkManager/conf.d/dhclient.conf

The creates a file which sets Network Manager to use the stand-alone dhclient program, as it did before. If this still doesn’t work (e.g. after a reboot), there’s the option of downgrading (see the next point).


networkmanager 1.10.2-1 does not auto-connect to WLAN (KDE)

If you find that your WLAN does not auto connect even if the entry is ticked to do so, you can downgrade the Network Manager package. Before doing so, please check the points above.

It’s possible to downgrade to the working build:

sudo pacman -U https://archive.archlinux.org/packages/n/networkmanager/networkmanager-1.10.0-1-x86_64.pkg.tar.xz

You’ll also need to temporarily ignore the package in /etc/pacman.conf

# Pacman won't upgrade packages listed in IgnorePkg and members of IgnoreGroup
IgnorePkg   = networkmanager
#IgnoreGroup =

Don’t forget to reverse this ignore setting as and when a networkmanager fix is announced and released to stable.

Also, have a look at Network Manager MegaThread .


Cannot update nautilus-admin

error: failed to prepare transaction (could not satisfy dependencies)
:: nautilus-admin: installing python2-nautilus (1.2.1-2) breaks dependency 'python-nautilus'

Solution:
Remove nautilus-admin and python2-nautilus by

sudo pacman -Rs nautilus-admin

and then install nautilus-admin again.


#3

Other kernels have retpoline coming?


#4

I would say 4.14 at very least will do. It is meant to be the first 6yr LTS kernel after all.

They’re probably working on mainline first so all future kernels are “fixed” before anything is backported.


#5

I assume this, eventually, just curious if retpoline patch for other kernels are just around the corner or a way off.


#6
  • Kernel compiled with retpoline option: YES
  • Kernel compiled with a retpoline-aware compiler: NO

STATUS: VULNERABLE (IBRS hardware + kernel support OR kernel with retpoline are needed to mitigate the vulnerability)

seems that option for compiler is needed or compiler that is patched with retpoline…


#7

I’ve tested the 4.15-kernel and had a minor issue. The tap to click function of the touchpad on my Thinkpad T530 got lost. I tried to reactivate it in xfce4-settings-manager, but with no effect. Back on 4.14 all worked well.


#8

Needed compiler patches will come in March. So it is still a long way to go here. All LTS kernels will get retpoline backported. First will be v4.9 and v4.14 series.


#9

Again with Vertex Maia Icon theme, I think I did sh*t. Somehow, I introduced a broken symlink instead of a working one.


Same thing has been noticed in a VM.

I don’t know why though. The target path seems to be perfectly written in the Github. According to Thunar, there would be a garbage character in the path.

If I delete the symlink, then recreate it manually with ln -s -r with the exact same path, the symlinks works fine and Thunar doesn’t show a garbage character anymore.

And after a sudo gtk-update-icon-cache /usr/share/icons/Vertex-Maia and a reboot, it looks as it would supposed to be.
broken-link-fixed-after-gtk-update

I’m sorry for introducing a regression and losing your time. I posted here my suggested fix to correct that problem. I’ll let someone who is more competent than me with git to correctly implement and commit a fix in the vertex-maia-icon-themes Github.

Nothing else to report for now.


[Testing Update] 2018-01-18 - Kernels, Systemd, Pamac, KDE FW, Haskell, Python
#10

OK, that’s definetly weird. I recreated the symlinnk locally and according to git diff your version had a newline in the symlink path… It’s beyond me what’s going on… and GitHub’s diff is of no use either, since it does not show whitespace characters.

Don’t feel bad about it, it slipped by all of us.

Here’s the output from ls on that file:

ls -la ac-adapter.svg 
lrwxrwxrwx 1 sdwolf sdwolf 33 Jan 16 00:03 ac-adapter.svg -> '../24x24/ac-adapter-symbolic.svg'$'\n'

That '$'\n' should not be there.

Try removing the symlink and creating it again. This time don’t use the -r flag… I did not need it for the rest of the images I linked, ln -s was enough.

You should get a diff like this:

diff --git a/Vertex-Maia/status/scalable/ac-adapter.svg b/Vertex-Maia/status/scalable/ac-adapter.svg
index bc19bb2..ee22d62 120000
--- a/Vertex-Maia/status/scalable/ac-adapter.svg
+++ b/Vertex-Maia/status/scalable/ac-adapter.svg
@@ -1 +1 @@
-../24x24/ac-adapter-symbolic.svg
+../24x24/ac-adapter-symbolic.svg
\ No newline at end of file

If it’s different then the problem might lie somewhere else in your system…
Try creating a PR with the change and I’l check it out locally and inspect the symlink on my machine to see if it’s OK.


#11

I have closed my eyes and compiled kernel with gcc trunk from svn repo :wink:


#12

@sdwolf Can you check if the commit I did in my repository solved the broken symlink issue? If yes, I’ll do a pull request with this.

Seems to work for me. After a fresh gitclone and a ls -la, ls shows a correct symlink.

Thunar seems to be OK with this symlink too.

Did a pull request since it looks fine, but I would still like to have a confirmation in case there’s something I did wrong.


[Testing Update] 2018-01-18 - Kernels, Systemd, Pamac, KDE FW, Haskell, Python
#13

Yes, it works as expected. I also did a xdg-open on it and it correctly opened the file with inkscape. :+1:


#14

Some retpoline patches are in 4.14.14-rc1.


#15

@philm
I edited my mirrors.conf to switch to testing. I even upgraded (if I may use that term) from 4.14 to 4.15.r180114.ga875Odd-1 (at least that’s what’s showing as installed and running in Settings Manager under Kernels). I do not explicitly see linux v4.15-rc8 that you mention here and I don’t see that as an option in the aforementioned Settings Manager. I have run the mitigation detection tool v0.31 but still see vulnerabilities. Variant 1 = vulnerable, Variant 2 reports vulnerable Minimal generic ASM retpoline and the Meltdown aka Variant 3 is not vulnerable. So, am I using the correct kernel and the testing branch properly?


#16

Tested Linux 4.15.r180114.ga875Odd-1, It not only gave an error concerning WIFI, which I don’t use, it knocked me off my Ethernet which I depend on. I did not see comments on this.


#17

I have a Surface Pro 3 with a USB3 3-port-hub+Ethernet dongle. After this update, unplugging the dongle with an Ethernet cable connected immediately crashes my Gnome session and I’m dumped back to the login screen. (If I unplug the Ethernet cable before unplugging the dongle, then the crash doesn’t happen.)

This worked flawlessly before. Not sure which package might be responsible – I tried downgrading systemd, libsystemd, systemd-sysvcompat, and networkmanager but no luck. It happens with all the kernels I have installed (latest 4.15, 4.14, and 4.9), and on both Wayland and Xorg.

My logs don’t seem to reveal anything telling apart from gnome-shell itself crashing after the USB disconnect:
Jan 18 11:07:20 ... systemd-coredump[2414]: Process 1129 (gnome-shell) of user 1000 dumped core.

Any ideas?


#18

Well, click here for the specific git-commit I used for that release …


#19

Resolved with the 2018-01-21 update!


#20

Now I’ve found the cause. I’ve set the tap to click with an xinput-command and found that the number given for Tapping enabled changed from 279 to 278 when using the 4.15 kernel instead of the 4.14. I learned my lesson and now I changed the xinput command so that the option name is used instead of a number. For someone having a similar issue, here is my solution as example

xinput set-prop “SynPS/2 Synaptics TouchPad” “libinput Tapping Enabled” 1