[Testing Update] 2018-01-14 - Adapta & Grub Live themes, WebDAD, LibCDIO rebuild

update
testiing

#1

Hi community,

Stefano worked again on our Adapta Theme and the Grub-Live-Theme. We had the libcdio v2.0 rebuild and added some more WebDAD packages.

Our effort and all the needed information about the new security risk can be found here.

So please report back and give us feedback for given changes made to our repositories. Users of our 32-bit Distro should read this.


Current supported Kernels

  • linux316 3.16.52
  • linux318 3.18.91 [EOL]
  • linux41 4.1.48
  • linux44 4.4.111
  • linux49 4.9.76
  • linux412 4.12.14 [EOL]
  • linux413 4.13.16 [EOL]
  • linux414 4.14.13
  • linux415 4.15-rc7
  • linux-RT-LTS 4.9.68_rt60
  • linux-RT 4.11.12_rt16

Package Updates (Sun Jan 14 21:12:11 CET 2018)

  • testing community x86_64: 94 new and 93 removed package(s)
  • testing core x86_64: 2 new and 2 removed package(s)
  • testing extra x86_64: 29 new and 28 removed package(s)
:: Different overlay package(s) in repository community x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-01-13           2018-01-14
-------------------------------------------------------------------------------
           adapta-black-breath-theme          3.93.0.12-1          3.93.0.43-1
             adapta-black-maia-theme          3.93.0.12-1          3.93.0.43-1
                 adapta-breath-theme          3.93.0.12-1          3.93.0.43-1
                   adapta-maia-theme          3.93.0.12-1          3.93.0.43-1
         manjaro-webdad-settings-git         r4.e04efa2-1         r7.5355d91-1
              vertex-maia-icon-theme           20160809-1           20180114-1
                         vlc-nightly     3.0.0v20180112-1     3.0.0v20180114-1
                   vlc-nightly-debug     3.0.0v20180106-1     3.0.0v20180114-1
                  webdad-theming-git         r2.10c7f12-1         r3.8d967a3-1


:: Different sync package(s) in repository community x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-01-13           2018-01-14
-------------------------------------------------------------------------------
                               agave              0.4.7-8              0.4.7-9
                             angband              4.1.1-1              4.1.2-1
                        ansible-lint             3.4.17-1             3.4.20-1
                       arc-gtk-theme           20170302-4           20180114-1
                 arc-solid-gtk-theme           20170302-4           20180114-1
                               bless              0.6.0-4              0.6.0-5
                             cantata              2.2.0-2              2.2.0-3
                          clementine             1.3.1-11             1.3.1-12
                                cmus              2.7.1-8              2.7.1-9
                            deadbeef              0.7.2-2              0.7.2-3
                           git-annex         6.20180112-1         6.20180112-2
                            gnome-do             0.95.3-5             0.95.3-6
                              gopass              1.6.7-2              1.6.9-1
                       haskell-brick             0.32.1-1             0.32.1-3
                   haskell-criterion            1.2.6.0-3            1.3.0.0-1
                       haskell-hspec              2.4.6-1              2.4.7-1
                  haskell-hspec-core              2.4.6-1              2.4.7-1
              haskell-hspec-discover              2.4.6-1              2.4.7-1
            haskell-hspec-smallcheck             0.4.2-20             0.4.2-21
                   haskell-hspec-wai              0.9.0-8              0.9.0-9
              haskell-hspec-wai-json              0.9.0-9             0.9.0-10
                   haskell-microlens            0.4.8.1-4            0.4.8.3-1
             haskell-microlens-aeson            2.2.0.2-3            2.2.0.2-4
               haskell-microlens-ghc            0.4.8.0-5            0.4.8.0-6
               haskell-microlens-mtl           0.1.11.0-5           0.1.11.1-1
          haskell-microlens-platform            0.3.9.0-7            0.3.9.0-9
                haskell-microlens-th            0.4.1.1-6            0.4.1.1-7
           haskell-persistent-sqlite             2.6.4-14             2.6.4-15
             haskell-servant-swagger             1.1.4-13             1.1.4-14
                       haskell-store           0.4.3.2-30           0.4.3.2-31
                         haskell-vty             5.19.1-1             5.19.1-3
                  haskell-yesod-test            1.5.9.1-8            1.5.9.1-9
                         hledger-api               1.5-10               1.5-13
                          hledger-ui                1.5-5                1.5-7
                                inxi             2.3.53-1             2.3.55-1
                                kodi               17.6-3               17.6-4
                            kodi-dev               17.6-3               17.6-4
                   kodi-eventclients               17.6-3               17.6-4
            kodi-tools-texturepacker               17.6-3               17.6-4
                               libfm              1.2.5-1              1.2.5-2
                         libfm-extra              1.2.5-1              1.2.5-2
                          libfm-gtk2              1.2.5-1              1.2.5-2
                          libfm-gtk3              1.2.5-1              1.2.5-2
      libreoffice-extension-texmaths               0.43-1               0.44-1
                   libringclient 2:20171215.1.bc414d7-2 2:20180112.2.d0bda53-1
                       mediastreamer             2.16.1-1             2.16.1-2
                                 mpv           1:0.27.0-5           1:0.27.0-6
                            oblogout               0.2-18               0.2-19
                         offlineimap              7.1.4-1              7.1.5-1
                      packagekit-qt5              1.0.0-1              1.0.0-2
                              pifpaf             1.12.1-1              2.0.0-1
                       poppler-sharp              0.0.3-3              0.0.3-4
                              pragha              1.3.3-2              1.3.3-3
                            prettier             1.10.0-1             1.10.2-1
                                pypy             5.10.0-1             5.10.0-3
                               pypy3             5.10.0-1             5.10.0-3
                    python-construct             2.8.20-1             2.8.21-1
                    python-decorator              4.1.2-1              4.2.1-1
                   python-hypothesis            3.44.14-1            3.44.16-1
                       python-pygit2             0.26.2-1             0.26.3-1
                   python2-construct             2.8.20-1             2.8.21-1
                   python2-decorator              4.1.2-1              4.2.1-1
                  python2-hypothesis            3.44.14-1            3.44.16-1
                      python2-pifpaf             1.12.1-1              2.0.0-1
                      python2-pycdio               0.21-1               0.21-2
                      python2-pygit2             0.26.2-1             0.26.3-1
                        python2-yapf             0.20.0-1             0.20.1-1
                                qmmp              1.2.0-1              1.2.0-2
                            qupzilla              2.2.3-1              2.2.3-2
                     ring-daemon 2:20171215.1.bc414d7-4 2:20180112.2.d0bda53-1
                      ring-gnome 3:20171215.1.bc414d7-3 3:20180112.2.d0bda53-1
                       scummvm-tools              1.9.0-2              2.0.0-1
                               stack             1.6.3-19             1.6.3-22
                          stone-soup             0.20.1-1             0.21.0-1
                             tellico                3.1-2                3.1-3
                               timew              1.0.0-4              1.1.0-1
                           tinyproxy              1.8.4-3              1.8.4-4
                                tldr              0.4.1-1              0.4.2-1
                           uglify-js              3.3.5-1              3.3.7-1
                              warsow              2.1.0-1              2.1.2-1
                         warsow-data              2.1.0-1                    -
                      xmms2 0.8DrO_o.949.gca15e830-8 0.8DrO_o.949.gca15e830-10
                                yapf             0.20.0-1             0.20.1-1
                          youtube-dl         2018.01.07-1         2018.01.14-1
                              percol                    -              0.2.1-2
                       python-pycdio                    -               0.21-2


:: Different sync package(s) in repository core x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-01-13           2018-01-14
-------------------------------------------------------------------------------
                               glib2             2.54.3-1             2.54.3-2
                          glib2-docs             2.54.3-1             2.54.3-2


:: Different overlay package(s) in repository extra x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-01-13           2018-01-14
-------------------------------------------------------------------------------
          grub-theme-live-common-dev             17.1.1-1             17.1.1-2
         grub-theme-live-manjaro-dev             17.1.1-1             17.1.1-2
                              polkit 0.113+29+g3272a98-1 0.113+34+g29ba7af-1.1
              grub-theme-manjaro-dev                    -             17.1.1-2


:: Different sync package(s) in repository extra x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-01-13           2018-01-14
-------------------------------------------------------------------------------
                   audacious-plugins                3.9-1                3.9-2
                            discover             5.11.5-2             5.11.5-3
                     gst-plugins-bad             1.12.4-1             1.12.4-2
                    gst-plugins-ugly             1.12.4-2             1.12.4-3
                                gvfs 1.34.1+8+g091ac25d-11.34.1+11+gad63dfb7-1
                            gvfs-afc 1.34.1+8+g091ac25d-11.34.1+11+gad63dfb7-1
                            gvfs-goa 1.34.1+8+g091ac25d-11.34.1+11+gad63dfb7-1
                         gvfs-google 1.34.1+8+g091ac25d-11.34.1+11+gad63dfb7-1
                        gvfs-gphoto2 1.34.1+8+g091ac25d-11.34.1+11+gad63dfb7-1
                            gvfs-mtp 1.34.1+8+g091ac25d-11.34.1+11+gad63dfb7-1
                            gvfs-nfs 1.34.1+8+g091ac25d-11.34.1+11+gad63dfb7-1
                            gvfs-smb 1.34.1+8+g091ac25d-11.34.1+11+gad63dfb7-1
                             libcdio               0.94-2              2.0.0-1
                    libcdio-paranoia        10.2+0.94+2-1        10.2+0.94+2-2
                            libkgapi            17.12.1-1            17.12.1-2
                             libsrtp            1:1.5.4-2            1:2.1.0-1
                            mencoder              37998-2              37998-3
                                 mpd            0.20.15-1            0.20.15-2
                             mplayer              37998-2              37998-3
                     perl-xml-libxml             2.0129-4             2.0132-1
                           quodlibet              4.0.0-2              4.0.1-1
                              spglib             1.10.2-1             1.10.3-1
                           vcdimager             0.7.24-7              2.0.1-1
                                 vlc              2.2.8-2              2.2.8-3
                            xine-lib              1.2.9-1              1.2.9-2


  • No issues, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself. (Please post your solution)
  • Yes I am currently experiencing an issue due to the update. (Please post about it)

0 voters


Check if your mirror has already synced:


#2

I am using the Vertex Maia icon theme. It seems there’s a problem with the Power Management tray icon, as you can see in this screenshot.
vertex-maia-icon-bug-powermanagement
Removing the tray icon and put it back didn’t solve the issue. Changing panel size didn’t solve the issue. Rebooting didn’t solve the issue.

Nothing else to report for now.


#3

Got this added with our latest commit ?!? If so, please comment in given pull request @Pepito


#4

Reported in the pull request as you asked.


#5

If anybody else has problems with the vertex maia icons and is willing to debug it here are the steps to do it:

# First clone the repository
git clone https://github.com/manjaro/vertex-maia-icon-themes.git

# Then checkout the commit before this PR
git checkout 2b2469e5cec1c850a982f6ae1253d6d4b74e4369

# Quit the current `xfce4-power-manager` session
xfce4-power-manager -q

# Use these commands below to overwrite the icon files and start the power manager in debug mode:
sudo rm -rf /usr/share/icons/Vertex-Maia/ 

# In this case the `vertex-maia-icon-themes` is the repository. 
# Change the path as you see apropriate!
sudo cp -r ~/vertex-maia-icon-themes/Vertex-Maia/ /usr/share/icons/ 

sudo gtk-update-icon-cache /usr/share/icons/Vertex-Maia 
xfce4-power-manager --debug

Just post the output from xfce4-power-manager before and after the change. Also a screenshot with the icons would help.


#6

Created a pull request that could fix the issue I had with the Power manager’s tray icon : https://github.com/manjaro/vertex-maia-icon-themes/pull/7

Discussion about the isssue and solution here : https://github.com/manjaro/vertex-maia-icon-themes/pull/6#issuecomment-357546925


#7

Following this update after suspend to ram (which does work!) the session is terminated at some point (either before or after the suspend)


Jän 15 06:31:30 hk-01 systemd-coredump[2679]: Process 1176 (Xwayland) of user 1000 du
                                               
                                               Stack trace of thread 1176:
                                               #0  0x00007f90e852f860 n/a (n/a)

Which is all I get from journalctl by the way - only noticed as the open programs were closed after resume.


#8

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.