[Testing Update] 2018-01-09 - Linux316, Nvidia, GCC, Octopi, Firefox

update
testing

#1

Hi community,

this is more or less the boost rebuild. We also added some more fixes to gcc, which prevents issues with Spectre and Meltdown. Additionally we fixed some issues within Nvidia drivers and Octopi, updated our Firefox developer edition. linux316 gained the needed KPTI patches.

About our effort and all the needed information about the new security risk can be found here.

So please report back and give us feedback for given changes made to our repositories. Users of our 32-bit Distro should read this.


Current supported Kernels

  • linux316 3.16.53
  • linux318 3.18.91 [EOL]
  • linux41 4.1.48
  • linux44 4.4.109
  • linux49 4.9.74
  • linux412 4.12.14 [EOL]
  • linux413 4.13.16 [EOL]
  • linux414 4.14.12
  • linux415 4.15-rc6
  • linux-RT-LTS 4.9.68_rt60
  • linux-RT 4.11.12_rt16

Package Updates (Tue Jan 9 21:19:43 CET 2018)

  • testing community x86_64: 189 new and 184 removed package(s)
  • testing core x86_64: 13 new and 13 removed package(s)
  • testing extra x86_64: 31 new and 32 removed package(s)
  • testing multilib x86_64: 2 new and 2 removed package(s)
:: Different overlay package(s) in repository community x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-01-08           2018-01-09
-------------------------------------------------------------------------------
                          artwork-i3           20180107-1           20180109-1
                            conky-i3           20160915-1           20180109-1
                               hyper              2.1.1-2   1:2.0.0.canary.8-1
                  i3-default-artwork           20170225-1           20180109-1
                 manjaro-i3-settings           20180107-2           20180109-1
                              octopi             0.8.10-2             0.8.10-3
                 octopi-cachecleaner             0.8.10-1             0.8.10-3
          octopi-notifier-frameworks             0.8.10-1             0.8.10-3
                 octopi-notifier-qt5             0.8.10-1             0.8.10-3
                 octopi-pacmanhelper             0.8.10-1             0.8.10-3
                   octopi-repoeditor             0.8.10-1             0.8.10-3
                               mimic                    -            1.2.0.2-1


:: Different sync package(s) in repository community x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-01-08           2018-01-09
-------------------------------------------------------------------------------
                            bonnie++               1.97-2             1.97.3-1
                               brook           20171113-1           20171113-2
                             cblrepo            0.24.0-46            0.24.0-47
                              chrony                3.2-1                3.2-2
                   fcitx-cloudpinyin              0.3.6-1              0.3.6-2
                    fcitx-configtool             0.4.10-2             0.4.10-3
                          fcitx-rime              0.3.2-1              0.3.2-2
                               fcron              3.2.1-2              3.2.1-3
                                 fio                3.2-1                3.3-1
           firefox-developer-edition            58.0b14-1            58.0b15-1
  firefox-developer-edition-i18n-ach            58.0b14-1            58.0b15-1
   firefox-developer-edition-i18n-af            58.0b14-1            58.0b15-1
   firefox-developer-edition-i18n-an            58.0b14-1            58.0b15-1
   firefox-developer-edition-i18n-ar            58.0b14-1            58.0b15-1
   firefox-developer-edition-i18n-as            58.0b14-1            58.0b15-1
  firefox-developer-edition-i18n-ast            58.0b14-1            58.0b15-1
   firefox-developer-edition-i18n-az            58.0b14-1            58.0b15-1
   firefox-developer-edition-i18n-be            58.0b14-1            58.0b15-1
   firefox-developer-edition-i18n-bg            58.0b14-1            58.0b15-1
firefox-developer-edition-i18n-bn-bd            58.0b14-1            58.0b15-1
firefox-developer-edition-i18n-bn-in            58.0b14-1            58.0b15-1
   firefox-developer-edition-i18n-br            58.0b14-1            58.0b15-1
   firefox-developer-edition-i18n-bs            58.0b14-1            58.0b15-1
   firefox-developer-edition-i18n-ca            58.0b14-1            58.0b15-1
  firefox-developer-edition-i18n-cak            58.0b14-1            58.0b15-1
   firefox-developer-edition-i18n-cs            58.0b14-1            58.0b15-1
   firefox-developer-edition-i18n-cy            58.0b14-1            58.0b15-1
   firefox-developer-edition-i18n-da            58.0b14-1            58.0b15-1
   firefox-developer-edition-i18n-de            58.0b14-1            58.0b15-1
  firefox-developer-edition-i18n-dsb            58.0b14-1            58.0b15-1
   firefox-developer-edition-i18n-el            58.0b14-1            58.0b15-1
firefox-developer-edition-i18n-en-gb            58.0b14-1            58.0b15-1
firefox-developer-edition-i18n-en-us            58.0b14-1            58.0b15-1
firefox-developer-edition-i18n-en-za            58.0b14-1            58.0b15-1
   firefox-developer-edition-i18n-eo            58.0b14-1            58.0b15-1
firefox-developer-edition-i18n-es-ar            58.0b14-1            58.0b15-1
firefox-developer-edition-i18n-es-cl            58.0b14-1            58.0b15-1
firefox-developer-edition-i18n-es-es            58.0b14-1            58.0b15-1
firefox-developer-edition-i18n-es-mx            58.0b14-1            58.0b15-1
   firefox-developer-edition-i18n-et            58.0b14-1            58.0b15-1
   firefox-developer-edition-i18n-eu            58.0b14-1            58.0b15-1
   firefox-developer-edition-i18n-fa            58.0b14-1            58.0b15-1
   firefox-developer-edition-i18n-ff            58.0b14-1            58.0b15-1
   firefox-developer-edition-i18n-fi            58.0b14-1            58.0b15-1
   firefox-developer-edition-i18n-fr            58.0b14-1            58.0b15-1
firefox-developer-edition-i18n-fy-nl            58.0b14-1            58.0b15-1
firefox-developer-edition-i18n-ga-ie            58.0b14-1            58.0b15-1
   firefox-developer-edition-i18n-gd            58.0b14-1            58.0b15-1
   firefox-developer-edition-i18n-gl            58.0b14-1            58.0b15-1
   firefox-developer-edition-i18n-gn            58.0b14-1            58.0b15-1
firefox-developer-edition-i18n-gu-in            58.0b14-1            58.0b15-1
   firefox-developer-edition-i18n-he            58.0b14-1            58.0b15-1
firefox-developer-edition-i18n-hi-in            58.0b14-1            58.0b15-1
   firefox-developer-edition-i18n-hr            58.0b14-1            58.0b15-1
  firefox-developer-edition-i18n-hsb            58.0b14-1            58.0b15-1
   firefox-developer-edition-i18n-hu            58.0b14-1            58.0b15-1
firefox-developer-edition-i18n-hy-am            58.0b14-1            58.0b15-1
   firefox-developer-edition-i18n-id            58.0b14-1            58.0b15-1
   firefox-developer-edition-i18n-is            58.0b14-1            58.0b15-1
   firefox-developer-edition-i18n-it            58.0b14-1            58.0b15-1
   firefox-developer-edition-i18n-ja            58.0b14-1            58.0b15-1
   firefox-developer-edition-i18n-ka            58.0b14-1            58.0b15-1
  firefox-developer-edition-i18n-kab            58.0b14-1            58.0b15-1
   firefox-developer-edition-i18n-kk            58.0b14-1            58.0b15-1
   firefox-developer-edition-i18n-km            58.0b14-1            58.0b15-1
   firefox-developer-edition-i18n-kn            58.0b14-1            58.0b15-1
   firefox-developer-edition-i18n-ko            58.0b14-1            58.0b15-1
  firefox-developer-edition-i18n-lij            58.0b14-1            58.0b15-1
   firefox-developer-edition-i18n-lt            58.0b14-1            58.0b15-1
   firefox-developer-edition-i18n-lv            58.0b14-1            58.0b15-1
  firefox-developer-edition-i18n-mai            58.0b14-1            58.0b15-1
   firefox-developer-edition-i18n-mk            58.0b14-1            58.0b15-1
   firefox-developer-edition-i18n-ml            58.0b14-1            58.0b15-1
   firefox-developer-edition-i18n-mr            58.0b14-1            58.0b15-1
   firefox-developer-edition-i18n-ms            58.0b14-1            58.0b15-1
   firefox-developer-edition-i18n-my            58.0b14-1            58.0b15-1
firefox-developer-edition-i18n-nb-no            58.0b14-1            58.0b15-1
   firefox-developer-edition-i18n-nl            58.0b14-1            58.0b15-1
firefox-developer-edition-i18n-nn-no            58.0b14-1            58.0b15-1
   firefox-developer-edition-i18n-or            58.0b14-1            58.0b15-1
firefox-developer-edition-i18n-pa-in            58.0b14-1            58.0b15-1
   firefox-developer-edition-i18n-pl            58.0b14-1            58.0b15-1
firefox-developer-edition-i18n-pt-br            58.0b14-1            58.0b15-1
firefox-developer-edition-i18n-pt-pt            58.0b14-1            58.0b15-1
   firefox-developer-edition-i18n-rm            58.0b14-1            58.0b15-1
   firefox-developer-edition-i18n-ro            58.0b14-1            58.0b15-1
   firefox-developer-edition-i18n-ru            58.0b14-1            58.0b15-1
   firefox-developer-edition-i18n-si            58.0b14-1            58.0b15-1
   firefox-developer-edition-i18n-sk            58.0b14-1            58.0b15-1
   firefox-developer-edition-i18n-sl            58.0b14-1            58.0b15-1
  firefox-developer-edition-i18n-son            58.0b14-1            58.0b15-1
   firefox-developer-edition-i18n-sq            58.0b14-1            58.0b15-1
   firefox-developer-edition-i18n-sr            58.0b14-1            58.0b15-1
firefox-developer-edition-i18n-sv-se            58.0b14-1            58.0b15-1
   firefox-developer-edition-i18n-ta            58.0b14-1            58.0b15-1
   firefox-developer-edition-i18n-te            58.0b14-1            58.0b15-1
   firefox-developer-edition-i18n-th            58.0b14-1            58.0b15-1
   firefox-developer-edition-i18n-tr            58.0b14-1            58.0b15-1
   firefox-developer-edition-i18n-uk            58.0b14-1            58.0b15-1
   firefox-developer-edition-i18n-ur            58.0b14-1            58.0b15-1
   firefox-developer-edition-i18n-uz            58.0b14-1            58.0b15-1
   firefox-developer-edition-i18n-vi            58.0b14-1            58.0b15-1
   firefox-developer-edition-i18n-xh            58.0b14-1            58.0b15-1
firefox-developer-edition-i18n-zh-cn            58.0b14-1            58.0b15-1
firefox-developer-edition-i18n-zh-tw            58.0b14-1            58.0b15-1
                               gammu             1.38.5-1             1.39.0-1
                 gnome-initial-setup             3.26.0-1             3.26.0-2
                               gsoap             2.8.49-1             2.8.59-1
                             haproxy              1.8.2-1              1.8.2-2
               haskell-binary-tagged           0.1.4.2-36           0.1.4.2-37
                      haskell-fmlist              0.9.1-1              0.9.2-1
                haskell-generics-sop            0.3.1.0-4            0.3.2.0-1
                    haskell-listlike             4.5.1-10             4.5.1-11
              haskell-process-extras              0.7.2-8              0.7.2-9
             haskell-servant-swagger             1.1.4-12             1.1.4-13
                    haskell-swagger2                2.2-4                2.2-5
                   haskell-unixutils            1.54.1-15            1.54.1-16
                             hexedit             1.2.13-3              1.4.2-1
                         hledger-api                1.5-5                1.5-6
                            homebank              5.1.6-1              5.1.7-1
                              hoogle            5.0.14-22            5.0.14-23
                                hugo             0.32.1-1             0.32.3-1
                               idris             1.1.1-23              1.2.0-1
                              incron             0.5.12-2             0.5.12-3
                              marked              0.3.9-1             0.3.12-1
                                pari              2.9.3-1              2.9.4-1
                       perl-datetime               1.42-4               1.45-1
      perl-params-validationcompiler               0.24-3               0.26-1
                              pifpaf             1.12.0-1             1.12.1-1
                              polipo              1.1.1-2              1.1.1-3
                           postgrest           0.4.3.0-25           0.4.3.0-26
                            postgrey               1.37-1               1.37-2
                               pynac             0.7.14-1             0.7.15-1
                        python-boto3              1.5.9-1             1.5.10-1
                        python-gammu               2.10-1               2.11-1
                   python-hypothesis            3.44.13-1            3.44.14-1
                  python-oslo-config              5.1.0-1              5.2.0-1
                 python-oslo-context             2.19.3-1             2.20.0-1
                      python-oslo-db             4.32.0-1             4.33.0-1
           python-oslo-serialization             2.22.0-1             2.23.0-1
                   python-oslo-utils             3.33.0-1             3.34.0-1
                   python-oslosphinx             4.17.0-1             4.18.0-1
                     python-oslotest              3.0.0-1              3.2.0-1
                         python-rope             0.10.7-1             0.10.7-2
                       python2-gammu               2.10-1               2.11-1
                  python2-hypothesis            3.44.13-1            3.44.14-1
                 python2-oslo-config              5.1.0-1              5.2.0-1
                python2-oslo-context             2.19.3-1             2.20.0-1
                     python2-oslo-db             4.32.0-1             4.33.0-1
          python2-oslo-serialization             2.22.0-1             2.23.0-1
                  python2-oslo-utils             3.33.0-1             3.34.0-1
                  python2-oslosphinx             4.17.0-1             4.18.0-1
                    python2-oslotest              3.0.0-1              3.2.0-1
                      python2-pifpaf             1.12.0-1             1.12.1-1
                        python2-rope             0.10.3-2             0.10.7-2
                          ruby-gpgme             2.0.15-2             2.0.16-1
                              rustup              1.8.0-2              1.9.0-1
                               sigil              0.9.8-2              0.9.9-1
                           smokeping             2.6.11-3             2.6.11-4
                         springlobby              0.260-2              0.263-1
                    telegram-desktop              1.2.6-1              1.2.6-3
                         ttf-symbola              10.03-1              10.23-1
                           typespeed              0.6.5-6              0.6.5-7
                            umockdev              0.9.4-1               0.10-1
                             unpaper                6.1-4                6.1-5
                               vault              0.9.0-3              0.9.0-4
                       wireshark-cli              2.4.3-1              2.4.3-2
                    wireshark-common              2.4.3-1              2.4.3-2
                       wireshark-gtk              2.4.3-1              2.4.3-2
                        wireshark-qt              2.4.3-1              2.4.3-2
                       xmms2 0.8DrO_o.949.gca15e830-7 0.8DrO_o.949.gca15e830-8
                          youtube-dl         2017.12.31-1         2018.01.07-1
                             ziproxy              3.3.1-1              3.3.1-2
                              emovix                    -              0.9.0-7
                               fastd                    -                 18-4
                           git-crypt                    -              0.6.0-3
                             libuecc                    -                  7-2


:: Different overlay package(s) in repository core x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-01-08           2018-01-09
-------------------------------------------------------------------------------
                            linux316            3.16.52-1            3.16.53-1
                    linux316-headers            3.16.52-1            3.16.53-1


:: Different sync package(s) in repository core x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-01-08           2018-01-09
-------------------------------------------------------------------------------
                   archlinux-keyring           20171213-1           20180108-1
                              argon2           20171227-2           20171227-3
                                 gcc     7.2.1+20171224-1     7.2.1+20171224-2
                             gcc-ada     7.2.1+20171224-1     7.2.1+20171224-2
                         gcc-fortran     7.2.1+20171224-1     7.2.1+20171224-2
                              gcc-go     7.2.1+20171224-1     7.2.1+20171224-2
                            gcc-libs     7.2.1+20171224-1     7.2.1+20171224-2
                            gcc-objc     7.2.1+20171224-1     7.2.1+20171224-2
                      lib32-gcc-libs     7.2.1+20171224-1     7.2.1+20171224-2
                              netctl               1.14-1               1.15-1
                             openssh              7.6p1-1              7.6p1-2


:: Different overlay package(s) in repository extra x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-01-08           2018-01-09
-------------------------------------------------------------------------------
                  linux316-acpi_call             1.1.0-35             1.1.0-36
                   linux316-bbswitch               0.8-34               0.8-35
                linux316-broadcom-wl      6.30.223.271-14      6.30.223.271-15
                   linux316-catalyst     1:15.201.1151-23     1:15.201.1151-24
                linux316-ndiswrapper              1.61-14              1.61-15
                     linux316-nvidia          1:384.111-1          1:384.111-2
               linux316-nvidia-304xx          1:304.137-5          1:304.137-6
               linux316-nvidia-340xx            340.104-5            340.104-6
                   linux316-nvidiabl              0.88-24              0.88-25
      linux316-open-vm-tools-modules      2:2013.09.16-34      2:2013.09.16-35
                      linux316-r8168          8.044.02-10          8.044.02-11
                  linux316-rt3562sta        2.4.1.1_r4-14        2.4.1.1_r4-15
                        linux316-spl           0.7.5-1.52              0.7.5-2
                   linux316-tp_smapi              0.41-34              0.41-35
                linux316-vhba-module          20161009-14          20161009-15
   linux316-virtualbox-guest-modules              5.2.4-2              5.2.4-3
    linux316-virtualbox-host-modules              5.2.4-2              5.2.4-3
                        linux316-zfs           0.7.5-1.52              0.7.5-2
                  nvidia-304xx-utils          1:304.137-2          1:304.137-3
                  nvidia-340xx-utils            340.104-2            340.104-3
                        nvidia-utils          1:384.111-2          1:384.111-3


:: Different sync package(s) in repository extra x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-01-08           2018-01-09
-------------------------------------------------------------------------------
                         flashplugin         28.0.0.126-1         28.0.0.137-1
                            ghostpcl               9.22-6               9.22-7
                         ghostscript               9.22-6               9.22-7
                            ghostxps               9.22-6               9.22-7
                            inkscape             0.92.2-7             0.92.2-8
                     kdebase-runtime            17.08.3-1            17.08.3-2
                          kio-extras            17.12.0-1            17.12.0-2
                          libgdiplus                4.2-2                5.6-1
                             openslp              2.0.0-2                    -
                        pepper-flash         28.0.0.126-1         28.0.0.137-1
                            perl-uri               1.72-2               1.73-1


:: Different sync package(s) in repository multilib x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-01-08           2018-01-09
-------------------------------------------------------------------------------
                           lib32-acl             2.2.52-2             2.2.52-3
                   lib32-flashplugin         28.0.0.126-1         28.0.0.137-1

  • No issues, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself. (Please post your solution)
  • Yes I am currently experiencing an issue due to the update. (Please post about it)

0 voters


Check if your mirror has already synced:


#2

Known issues and solutions

This is a wiki post; please edit as necessary


My rtl8723be wifi card stopped working

You may need to specify (or switch) the antenna selection via the ant_sel driver option, e.g.:

echo "options rtl8723be ant_sel=2" | sudo tee /etc/modprobe.d/50-rtl8723be.conf

If you already have an driver options file try switching the option between 0, 1, and 2.


Network connection is unreliable, not working, or not connecting

Occasionally, Network Manager updates change the underlying settings structure (schemas). This can change or break existing settings without you knowing about it.

This can be fixed by removing the existing connection settings, and then re-adding the connection. You may also need to reboot. If this does not work, move to the next point.


networkmanager 1.10.2-1 does not get an IP address

For some configurations, Network Manager tries to use its internal DHCP client which appears to be incompatible with some wireless access points. This shows up as a timeout during the connection attempt.

To switch back to the previous behaviour of 1.10.0, run the following from a terminal:

echo -e "[main]\ndhcp=dhclient" | sudo tee /etc/NetworkManager/conf.d/dhclient.conf

The creates a file which sets Network Manager to use the stand-alone dhclient program, as it did before. If this still doesn’t work (e.g. after a reboot), there’s the option of downgrading (see the next point).


networkmanager 1.10.2-1 does not auto-connect to WLAN (KDE)

If you find that your WLAN does not auto connect even if the entry is ticked to do so, you can downgrade the Network Manager package. Before doing so, please check the points above.

It’s possible to downgrade to the working build:

sudo pacman -U https://archive.archlinux.org/packages/n/networkmanager/networkmanager-1.10.0-1-x86_64.pkg.tar.xz

You’ll also need to temporarily ignore the package in /etc/pacman.conf

# Pacman won't upgrade packages listed in IgnorePkg and members of IgnoreGroup
IgnorePkg   = networkmanager
#IgnoreGroup =

Don’t forget to reverse this ignore setting as and when a networkmanager fix is announced and released to stable.

Also, have a look at Network Manager MegaThread .



#3

Over the last flurry of updates I can not get the Testing branch running in a VmWare Virtual Machine to adjust screen size any more, or copy/paste to-from the host.

I had this working perfectly before.

When I load vmware-user-suid-wrapper it says
vmware-user could not open /proc/fs/vmblock/dev

I’ve tried re-installing open-vm-tools but no luck.


#4

If you run other distros in VMWare, is Manjaro the only problematic OS?

What graphic driver does mhwd install for VMWare?

Similar issue, even if it is a couple of years old


#5

I also run Solus/Budgie, SUSE Enterprise, Ubuntu Gnome in Vmware worstation VMs (windows host).
Also Manjaro LXDE in Vmware worstation VMs (linux host). These all behave properly, using open-vmware tools.

I get video-vmware driver (and video-visa) according to mhwd. MSM says the same - open source driver only.

The problem machine has been rolling in testing since December 2015. I see reference to dropping vmblock driver in your linked article and about halfway down I see a potential work around using fuse.

All the fuse bits seem to be in place so maybe I’ll fiddle with that a while.

Thanks.


#6

For the Google Spiders: SOLVED-ish.

Something @sueridgepipe mentioned caused me to compare settings in my Manjaro LXDE to my settings in Manjaro KDE (testing branch). Both running in Vmware Workstation machines.

The resize screen feature of Vmware video drivers stopped working for some reason in the testing branch.

Upon comparing the settings in Manjaro Settings Manager i found that LXDE had both boxes checked in MSM, but the second column checkbox was missing on my KDE Testing machine.

Screenshot_msm

Suddenly this started to matter in testing.

I simply checked the Installed column, (to match the working LXDE) machine, said yes to the prompt, and the testing machine instantly started operating correctly with regard to screen size.

@philm
The way I read the msm screen above is that if open-source is checked we are using the open source drivers. If Installed is checked, I have no idea what driver we are using.

What does “installed” mean?

Can’t that “Installed” column get a better title?
Can’t it display the actual driver that is in use?

The output of mhwd remains the same.


#7

This is why I prefer mhwd CLI over MSM GUI.

The open source check box simply indicates if an mhwd driver is open source or not, no relevance to installed status. If not checked then it is a proprietary blob (ie nvidia).

$ mhwd -la
> All PCI configs:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
...
          video-vmware            2017.03.12                true            PCI
...
            video-vesa            2017.03.12                true            PCI
...
          video-nvidia            2017.03.12                false           PCI
...

If installed is checked then the driver (ie all associated packages and config files) is installed, again I prefer CLI for this info.

mhwd -li [-d]

So video-vmware wasn’t actually installed? Does the kernel default to vesa when no driver is installed?

Checking installed column is the equivalent of

sudo mhwd -i pci video-vmware

#8

Well your favorite command line tool shows exactly the same display before and after checking the installed box, so I suspect your explanation misses a few subtleties.

How it changed during the last couple of updates is a mystery.


#9

Re-installing a driver could well fix any issues, either via mhwd or MSM.


#10

Well it seems to have fixed it, and I’m a happy camper.

It’s like the second time I went through that process in as many days.

I did take a hint or two from the link you posted, and that may have allowed it to work this time around.


#11

All good, the issue with octopi-notifier (right click and sync), seems to be solved (after a reboot).


#12

Good to see that linux316 received KPTI.
Yet, it won’t benifit from ‘PCID’ cpu flag which softens performance panalty by smoothing syscalls between seperated spaces, only linux414 and upwards benifits from ‘pcid’.
This means more performance impact on all kernels below linux414!, including linux316!


#13

Well, Intel always wanted to level with AMD in speed :hugs:


#14

It’s slightly misleading. If “Open-source” is “ticked”, the driver is an open-source driver. If “Installed” is ticked, that driver is installed.


#15

I only use gui to gather information of what I have and what can I have.
Seriuos root access tasks are done in cli.


#16

That makes it even harder to figure out. Sorry.

It Installed is NOT ticked, then WHAT driver is used? The open source one? Some other one? if so which one?

If the user un-ticks open-source, then what happens? What driver is used?

What does it mean when Open-Source is ticked but installed is not? How could it know its open source if its not installed.


#17

Installed marks what driver is installed, and therefore used (through mhwd, manually configured drivers might not show up).

Open-source marks the drivers that are open-source.

Both marks are completely independent from each other, as they indicate two different things.


#18

If nothing is ticked, whichever one that’s included with the kernel or X (i.e. the fallback, might be modesetting or vesa).

That one can’t be “unticked”. It is an indicator rather than a selector.

The driver is an open-source driver but not installed.


#19

How would it know it was open source if not installed?

Never mind. I give up. Clearly MSM has the best design ever.


#20

Because MSM is only offering you a selected few automatic installation options, i.e. it has its own internal database to know which driver option is fully open source and how to install it.