[Testing Update] 2017-11-09 - Kernels, Pamac, Pacman-Mirrors - End of i686 ?!?

update
testing

#1

Hi community,

this is the LAST i686 UPDATE we had synced from Archlinux. From Yesterday on Arch doesn’t update their 32bit architecture anymore. Therefore they have started the community project Archlinux32. So we are still deciding, if we continue to sync from both projects or drop i686 for good. What is the community take on this?

  • Archive i686 packages
  • Sync i686 packages from Archlinux32
  • Remove i686 packages for good

0 voters

Last poll was in favour of removing them.

So anyway, what changed for us? We have updated all kernels for the last time, fixed compatibility issues with Pamac and Pacman-Mirrors v4.4 and synced with Arch the last time on both architectures.

Please test and give us feedback as usual


Current supported Kernels

  • linux316 3.16.49
  • linux318 3.18.80 [EOL]
  • linux41 4.1.44
  • linux44 4.4.97
  • linux49 4.9.61
  • linux412 4.12.14 [EOL]
  • linux413 4.13.12
  • linux414 4.14-rc8 (x86_64)
  • linux-RT-LTS 4.9.47_rt37 (x86_64)
  • linux-RT 4.11.12_rt16 (x86_64)

Package Updates (Wed Nov 8 21:19:31 CET 2017)

  • testing community i686: 9 new and 9 removed package(s)
  • testing community x86_64: 12 new and 12 removed package(s)
  • testing core i686: 9 new and 9 removed package(s)
  • testing core x86_64: 11 new and 11 removed package(s)
  • testing extra i686: 57 new and 57 removed package(s)
  • testing extra x86_64: 75 new and 75 removed package(s)
  • testing multilib x86_64: 1 new and 1 removed package(s)
:: Different sync package(s) in repository community i686

-------------------------------------------------------------------------------
                             PACKAGE           2017-11-08           2017-11-09
-------------------------------------------------------------------------------
                        deepin-clone            0.0.5.1-1              0.0.6-1
                    firefox-noscript              5.1.4-1              5.1.5-1
                             jenkins               2.88-1               2.89-1
                              neovim              0.2.1-1              0.2.1-2
                  perl-finance-quote               1.40-1               1.44-1
                               pigar              0.7.0-1              0.7.1-1
                    python2-m2crypto             0.26.0-2             0.27.0-1
                       python2-pigar              0.7.0-1              0.7.1-1
                            tigervnc              1.8.0-2              1.8.0-3


:: Different sync package(s) in repository community x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2017-11-08           2017-11-09
-------------------------------------------------------------------------------
                               aria2             1.33.0-1             1.33.1-1
                                atom             1.21.2-1             1.22.0-1
                        deepin-clone            0.0.5.1-1              0.0.6-1
                    firefox-noscript              5.1.4-1              5.1.5-1
             haskell-microlens-aeson           2.2.0.1-19            2.2.0.2-1
                             jenkins               2.88-1               2.89-1
                              neovim              0.2.1-1              0.2.1-2
                  perl-finance-quote               1.40-1               1.44-1
                               pigar              0.7.0-1              0.7.1-1
                    python2-m2crypto             0.26.0-2             0.27.0-1
                       python2-pigar              0.7.0-1              0.7.1-1
                            tigervnc              1.8.0-2              1.8.0-3


:: Different overlay package(s) in repository core i686

-------------------------------------------------------------------------------
                             PACKAGE           2017-11-08           2017-11-09
-------------------------------------------------------------------------------
                            linux318            3.18.79-1            3.18.80-1
                    linux318-headers            3.18.79-1            3.18.80-1
                            linux413            4.13.11-1            4.13.12-1
                    linux413-headers            4.13.11-1            4.13.12-1
                             linux44             4.4.96-1             4.4.97-1
                     linux44-headers             4.4.96-1             4.4.97-1
                             linux49             4.9.60-1             4.9.61-3
                     linux49-headers             4.9.60-1             4.9.61-3


:: Different sync package(s) in repository core i686

-------------------------------------------------------------------------------
                             PACKAGE           2017-11-08           2017-11-09
-------------------------------------------------------------------------------
                               glibc               2.26-5               2.26-6


:: Different overlay package(s) in repository core x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2017-11-08           2017-11-09
-------------------------------------------------------------------------------
                            linux318            3.18.79-1            3.18.80-1
                    linux318-headers            3.18.79-1            3.18.80-1
                            linux413            4.13.11-1            4.13.12-1
                    linux413-headers            4.13.11-1            4.13.12-1
                          linux414 4.14.r1104.g2d63499-1 4.14.r1108.g87df261-1
                  linux414-headers 4.14.r1104.g2d63499-1 4.14.r1108.g87df261-1
                             linux44             4.4.96-1             4.4.97-1
                     linux44-headers             4.4.96-1             4.4.97-1
                             linux49             4.9.60-1             4.9.61-3
                     linux49-headers             4.9.60-1             4.9.61-3


:: Different sync package(s) in repository core x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2017-11-08           2017-11-09
-------------------------------------------------------------------------------
                               glibc               2.26-5               2.26-6


:: Different overlay package(s) in repository extra i686

-------------------------------------------------------------------------------
                             PACKAGE           2017-11-08           2017-11-09
-------------------------------------------------------------------------------
                  linux318-acpi_call             1.1.0-39             1.1.0-40
                   linux318-bbswitch               0.8-39               0.8-40
                linux318-broadcom-wl      6.30.223.271-15      6.30.223.271-16
                   linux318-catalyst     1:15.201.1151-29     1:15.201.1151-30
                linux318-ndiswrapper              1.61-15              1.61-16
                     linux318-nvidia           1:384.98-1           1:384.98-2
               linux318-nvidia-304xx          1:304.137-4          1:304.137-5
               linux318-nvidia-340xx            340.104-4            340.104-5
                   linux318-nvidiabl              0.88-29              0.88-30
      linux318-open-vm-tools-modules      2:2013.09.16-39      2:2013.09.16-40
                      linux318-r8168          8.044.02-10          8.044.02-11
                  linux318-rt3562sta        2.4.1.1_r4-15        2.4.1.1_r4-16
                        linux318-spl              0.7.2-3              0.7.2-4
                   linux318-tp_smapi              0.41-39              0.41-40
                linux318-vhba-module          20161009-15          20161009-16
   linux318-virtualbox-guest-modules              5.2.0-2              5.2.0-3
    linux318-virtualbox-host-modules              5.2.0-2              5.2.0-3
                        linux318-zfs              0.7.2-3              0.7.2-4
                  linux413-acpi_call              1.1.0-8              1.1.0-9
                   linux413-bbswitch                0.8-8                0.8-9
                linux413-broadcom-wl       6.30.223.271-8       6.30.223.271-9
                   linux413-catalyst      1:15.201.1151-8      1:15.201.1151-9
                linux413-ndiswrapper               1.61-8               1.61-9
                     linux413-nvidia           1:384.98-1           1:384.98-2
               linux413-nvidia-304xx          1:304.137-6          1:304.137-7
               linux413-nvidia-340xx            340.104-6            340.104-7
                   linux413-nvidiabl               0.88-8               0.88-9
                      linux413-r8168           8.044.02-8           8.044.02-9
                  linux413-rt3562sta         2.4.1.1_r4-8         2.4.1.1_r4-9
                        linux413-spl              0.7.2-4              0.7.2-5
                   linux413-tp_smapi               0.41-8               0.41-9
                linux413-vhba-module           20161009-8           20161009-9
   linux413-virtualbox-guest-modules              5.2.0-3              5.2.0-4
    linux413-virtualbox-host-modules              5.2.0-3              5.2.0-4
                        linux413-zfs              0.7.2-4              0.7.2-5
                   linux49-acpi_call             1.1.0-48             1.1.0-49
                    linux49-bbswitch               0.8-48               0.8-49
                 linux49-broadcom-wl      6.30.223.271-48      6.30.223.271-49
                    linux49-catalyst     1:15.201.1151-48     1:15.201.1151-49
                 linux49-ndiswrapper              1.61-46              1.61-47
                      linux49-nvidia           1:384.98-1           1:384.98-2
                linux49-nvidia-304xx          1:304.137-7          1:304.137-8
                linux49-nvidia-340xx            340.104-7            340.104-8
                    linux49-nvidiabl              0.88-48              0.88-49
                       linux49-r8168          8.044.02-28          8.044.02-29
                   linux49-rt3562sta        2.4.1.1_r4-46        2.4.1.1_r4-47
                         linux49-spl              0.7.2-5              0.7.2-6
                    linux49-tp_smapi              0.41-48              0.41-49
                 linux49-vhba-module          20161009-46          20161009-47
    linux49-virtualbox-guest-modules              5.2.0-3              5.2.0-4
     linux49-virtualbox-host-modules              5.2.0-3              5.2.0-4
                         linux49-zfs              0.7.2-5              0.7.2-6
                               pamac              6.2.1-1              6.2.1-2
             pamac-tray-appindicator              6.2.1-1              6.2.1-2
                            libxfont                    -              1.5.3-1


:: Different sync package(s) in repository extra i686

-------------------------------------------------------------------------------
                             PACKAGE           2017-11-08           2017-11-09
-------------------------------------------------------------------------------
                            libxfont              1.5.3-1                    -
                        python-attrs             17.2.0-1             17.3.0-1
                       python2-attrs             17.2.0-1             17.3.0-1
                       smartmontools                6.5-2                6.6-1


:: Different overlay package(s) in repository extra x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2017-11-08           2017-11-09
-------------------------------------------------------------------------------
                  linux318-acpi_call             1.1.0-39             1.1.0-40
                   linux318-bbswitch               0.8-39               0.8-40
                linux318-broadcom-wl      6.30.223.271-15      6.30.223.271-16
                   linux318-catalyst     1:15.201.1151-29     1:15.201.1151-30
                linux318-ndiswrapper              1.61-15              1.61-16
                     linux318-nvidia           1:384.98-1           1:384.98-2
               linux318-nvidia-304xx          1:304.137-4          1:304.137-5
               linux318-nvidia-340xx            340.104-4            340.104-5
                   linux318-nvidiabl              0.88-29              0.88-30
      linux318-open-vm-tools-modules      2:2013.09.16-39      2:2013.09.16-40
                      linux318-r8168          8.044.02-10          8.044.02-11
                  linux318-rt3562sta        2.4.1.1_r4-15        2.4.1.1_r4-16
                        linux318-spl              0.7.2-3              0.7.2-4
                   linux318-tp_smapi              0.41-39              0.41-40
                linux318-vhba-module          20161009-15          20161009-16
   linux318-virtualbox-guest-modules              5.2.0-2              5.2.0-3
    linux318-virtualbox-host-modules              5.2.0-2              5.2.0-3
                        linux318-zfs              0.7.2-3              0.7.2-4
                  linux413-acpi_call              1.1.0-8              1.1.0-9
                   linux413-bbswitch                0.8-8                0.8-9
                linux413-broadcom-wl       6.30.223.271-8       6.30.223.271-9
                   linux413-catalyst      1:15.201.1151-8      1:15.201.1151-9
                linux413-ndiswrapper               1.61-8               1.61-9
                     linux413-nvidia           1:384.98-1           1:384.98-2
               linux413-nvidia-304xx          1:304.137-6          1:304.137-7
               linux413-nvidia-340xx            340.104-6            340.104-7
                   linux413-nvidiabl               0.88-8               0.88-9
                      linux413-r8168           8.044.02-8           8.044.02-9
                  linux413-rt3562sta         2.4.1.1_r4-8         2.4.1.1_r4-9
                        linux413-spl              0.7.2-4              0.7.2-5
                   linux413-tp_smapi               0.41-8               0.41-9
                linux413-vhba-module           20161009-8           20161009-9
   linux413-virtualbox-guest-modules              5.2.0-3              5.2.0-4
    linux413-virtualbox-host-modules              5.2.0-3              5.2.0-4
                        linux413-zfs              0.7.2-4              0.7.2-5
                  linux414-acpi_call           1.1.0-0.16           1.1.0-0.17
                   linux414-bbswitch             0.8-0.16             0.8-0.17
                linux414-broadcom-wl    6.30.223.271-0.16    6.30.223.271-0.17
                   linux414-catalyst   1:15.201.1151-0.16   1:15.201.1151-0.17
                linux414-ndiswrapper            1.61-0.16            1.61-0.17
                     linux414-nvidia        1:384.98-0.16        1:384.98-0.17
               linux414-nvidia-304xx       1:304.137-0.16       1:304.137-0.17
               linux414-nvidia-340xx         340.104-0.16         340.104-0.17
                   linux414-nvidiabl            0.88-0.16            0.88-0.17
                      linux414-r8168        8.044.02-0.16        8.044.02-0.17
                  linux414-rt3562sta      2.4.1.1_r4-0.16      2.4.1.1_r4-0.17
                        linux414-spl           0.7.2-0.16           0.7.2-0.17
                   linux414-tp_smapi            0.41-0.16            0.41-0.17
                linux414-vhba-module        20161009-0.16        20161009-0.17
   linux414-virtualbox-guest-modules           5.2.0-0.16           5.2.0-0.17
    linux414-virtualbox-host-modules           5.2.0-0.16           5.2.0-0.17
                        linux414-zfs           0.7.2-0.16           0.7.2-0.17
                   linux49-acpi_call             1.1.0-48             1.1.0-49
                    linux49-bbswitch               0.8-48               0.8-49
                 linux49-broadcom-wl      6.30.223.271-48      6.30.223.271-49
                    linux49-catalyst     1:15.201.1151-48     1:15.201.1151-49
                 linux49-ndiswrapper              1.61-46              1.61-47
                      linux49-nvidia           1:384.98-1           1:384.98-2
                linux49-nvidia-304xx          1:304.137-7          1:304.137-8
                linux49-nvidia-340xx            340.104-7            340.104-8
                    linux49-nvidiabl              0.88-48              0.88-49
                       linux49-r8168          8.044.02-28          8.044.02-29
                   linux49-rt3562sta        2.4.1.1_r4-46        2.4.1.1_r4-47
                         linux49-spl              0.7.2-5              0.7.2-6
                    linux49-tp_smapi              0.41-48              0.41-49
                 linux49-vhba-module          20161009-46          20161009-47
    linux49-virtualbox-guest-modules              5.2.0-3              5.2.0-4
     linux49-virtualbox-host-modules              5.2.0-3              5.2.0-4
                         linux49-zfs              0.7.2-5              0.7.2-6
                               pamac              6.2.1-1              6.2.1-2
             pamac-tray-appindicator              6.2.1-1              6.2.1-2
                            libxfont                    -              1.5.3-1


:: Different sync package(s) in repository extra x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2017-11-08           2017-11-09
-------------------------------------------------------------------------------
                        gnu-efi-libs              3.0.3-2              3.0.6-1
                            libxfont              1.5.3-1                    -
                        python-attrs             17.2.0-1             17.3.0-1
                       python2-attrs             17.2.0-1             17.3.0-1
                       smartmontools                6.5-2                6.6-1


:: Different sync package(s) in repository multilib x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2017-11-08           2017-11-09
-------------------------------------------------------------------------------
                        lib32-libdrm             2.4.87-1             2.4.88-1

  • No issues, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself. (Please post your solution)
  • Yes I am currently experiencing an issue due to the update. (Please post about it)

0 voters


Check if your mirror has already synced:


[Manjaro32] Getting rid of 32bit Manjaro based on Archlinux
[Stable Update] 2017-11-12 - Kernels, Plasma5, Deepin, Cinnamon, END OF LIFE for 32bit support
#7

Known issues and solutions


#8

I think, now (nearly) all know that 32bit will not be supported in Manjaro any longer. It’s not necessary that you do a U-turn now. I think the best you could do is building some kind of script to ease the migration from Manjaro 32bit to archlinux32. You know, take away the Manjaro-specific parts like mhwd, replace the kernels and migrate to the new repos. I believe people over at archlinux32.org would help if you asked.
For me it’s too late. I’ve already installed Debian on the old Dell Inspiron my son is using.


#9

Maybe this is a newbie questions: could some programs be affected by not having no more 32bits libs upgraded? Or is not this that will happen? Is some programs in 32bits still in use, how can I verify?


#10

It’s not an issue, check this: https://wiki.archlinux.org/index.php/Multilib


#11

I’d just say, if you don’t have a 32-bit system and you want to vote, you should carefully consider before you do so. :wink:

From my perspective, i686 removal should come down to what effort it would be for the rest of the Manjaro team to keep it. archlinux32 is (now) a viable upstream source so as long as the effort of including these packages isn’t massive/unbalanced I’d see it as a win. Annoying for people who have already migrated, definitely, but then archlinux32 wasn’t really an option when the announcements were first made.

On the other hand, if the rest of the team has had enough of i686 and it’s lots of effort for not much benefit, then I suppose I’ll wave goodbye to the official i686 packages… :sob:


#13

Yeah, you’re right. As I wrote for my part it’s too late. But I thought, if the team takes a last effort to help the x86-users to migrate over to archlinux32 and don’t have to bother with it after this, they would be as fair as they could be to the users of the old systems and after it could concentrate on the supported of 64-bit-systems.


#14

The multilib repository is not affected, so if you have a 64bit system that also uses 32bit packages, those will be continued to be updated.


#15

@philm

So what am I supposed to do?! Just throw my i686 Manjaro machine in the rubbish?


#16

Wow, really? You’re shouting at Phil now, nine months after i686 removal was first announced?

Dude…


#17

Quite frankly that is probably the best solution for those older 32bit machines.

Sadly, I don’t expect Archlinux32 to last all that long. If one or two maintainers walk away I suspect the whole project comes crashing down.

Maybe its time to move to FreeBSD or OpenBSD and learn something new in the process.


#18

All good so far on Plasma.


#19

@jonathon

I didn’t know and wasn’t expecting it so soon.


#20

#21

Sorry, but this is not the tone we are used to. Phil and the team are doing what they can for us and they have just given you the choice to vote for using archlinux32 as a way for having i686 still in the game for some time. So if you want this, vote for it! But don’t be sour on those who have given you a great system as long as it were doable.


#22

That would be good starting point :grinning:


#23

OK, let’s leave this particular issue now. :slight_smile: No need to keep going over it now @manja1 knows what’s going on.


#24

I’m using archlinux32, I think it is not completely ready, they are learning and trying to implement an automatic build infrastucture. I’m more optimistic that they would get some more support now that Arch did what they announced.

What might work is to sync archlinux32 to unstable only. This would be a clear signal of no liability. But their package versions haven’t caught up with Arch, yet. You would know better how to take this into account.

I voted for “archive i686 packages”, because I’m against syncing them to stable.


#25

I voted to remove 686 packages for good, because I don’t know anyone that has 32 bit CPU any more.
I guess that maintaining those requires work, which can be redirected elsewhere ;p


#26

Thats also my point … there are also not many people who can test 32bit only stuff …