[Testing Update] 2017-09-28 - Firefox-KDE, Palemoon, Timeshift, Kernels

update
testing

#1

Hi community,

Stefano is working on adding Timeshift to Manjaro, I released a couple of new kernels and Kirek managed to compile Firefox-KDE against the new freetype2 v2.8.1. Since freetype2 breaks Wine and some other packages, we kept v2.8.0 in our testing branch. Bernhard had updated Palemoon and is currently working with me on enhancing the BIOS of the Spitfire.

Please test and give us feedback as usual


Current supported Kernels

  • linux316 3.16.48
  • linux318 3.18.72 [EOL]
  • linux41 4.1.43
  • linux44 4.4.89
  • linux49 4.9.52
  • linux412 4.12.14 [EOL]
  • linux413 4.13.4
  • linux414 4.14-rc2 (x86_64)
  • linux-RT-LTS 4.9.40_rt30 (x86_64)
  • linux-RT 4.11.12_rt12 (x86_64)

Package Updates (Wed Sep 27 11:07:07 CEST 2017)

  • testing community i686: 51 new and 51 removed package(s)
  • testing community x86_64: 53 new and 53 removed package(s)
  • testing core i686: 8 new and 8 removed package(s)
  • testing core x86_64: 10 new and 10 removed package(s)
  • testing extra i686: 61 new and 61 removed package(s)
  • testing extra x86_64: 75 new and 75 removed package(s)
:: Different overlay package(s) in repository community i686

-------------------------------------------------------------------------------
                             PACKAGE           2017-09-25           2017-09-28
-------------------------------------------------------------------------------
           adapta-black-breath-theme         3.91.2.189-1         3.91.2.198-1
             adapta-black-maia-theme         3.91.2.189-1         3.91.2.198-1
                 adapta-breath-theme         3.91.2.189-1         3.91.2.198-1
             adapta-breath-theme-dev         3.91.2.109-1                    -
                    adapta-gtk-theme         3.91.2.189-1         3.91.2.198-1
                   adapta-maia-theme         3.91.2.189-1         3.91.2.198-1
               adapta-maia-theme-dev         3.91.2.109-1                    -
                         firefox-kde             55.0.3-1             55.0.3-2
gnome-shell-extension-manjaro-update                1.2-3                1.2-4
 gnome-shell-extension-topicons-plus                 20-1                 21-1
          manjaro-gnome-breath-theme         3.91.2.189-1         3.91.2.198-1
    manjaro-gnome-extension-settings           20170723-1           20170926-1
            manjaro-gnome-maia-theme         3.91.2.189-1         3.91.2.198-1
              manjaro-gnome-settings           20170822-2           20170926-1
                          packagekit            1.1.6-0.1            1.1.7-1.1
                        palemoon-bin             27.4.2-1             27.5.0-1
                    palemoon-i18n-cs             27.4.1-1             27.5.0-1
                    palemoon-i18n-de             27.4.1-1             27.5.0-1
                 palemoon-i18n-en-gb             27.4.1-1             27.5.0-1
                 palemoon-i18n-es-ar             27.4.1-1             27.5.0-1
                 palemoon-i18n-es-es             27.4.1-1             27.5.0-1
                 palemoon-i18n-es-mx             27.4.1-1             27.5.0-1
                    palemoon-i18n-fr             27.4.1-1             27.5.0-1
                    palemoon-i18n-hu             27.4.1-1             27.5.0-1
                    palemoon-i18n-it             27.4.1-1             27.5.0-1
                    palemoon-i18n-ko             27.4.1-1             27.5.0-1
                    palemoon-i18n-nl             27.4.1-1             27.5.0-1
                    palemoon-i18n-pl             27.4.1-1             27.5.0-1
                 palemoon-i18n-pt-br             27.4.1-1             27.5.0-1
                 palemoon-i18n-pt-pt             27.4.1-1             27.5.0-1
                    palemoon-i18n-ru             27.4.1-1             27.5.0-1
                 palemoon-i18n-sv-se             27.4.1-1             27.5.0-1
                    palemoon-i18n-tr             27.4.1-1             27.5.0-1
                 palemoon-i18n-zh-cn             27.4.1-1             27.5.0-1
                       timeshift-dev                    - v17.2.r41.gdf5b91c-1


:: Different sync package(s) in repository community i686

-------------------------------------------------------------------------------
                             PACKAGE           2017-09-25           2017-09-28
-------------------------------------------------------------------------------
                         blur-effect              1.1.2-1              1.1.3-1
                                dumb                1.0-1              2.0.0-1
                       elasticsearch              5.6.1-1              5.6.2-1
                              kibana              5.6.1-1              5.6.2-1
                                kodi               17.4-1               17.4-4
                            kodi-dev               17.4-1               17.4-4
                   kodi-eventclients               17.4-1               17.4-4
            kodi-tools-texturepacker               17.4-1               17.4-4
                            logstash              5.6.1-1              5.6.2-1
                         php-mongodb             1.2.10-1              1.3.0-1
                              pwndbg         2017.02.01-1         2017.09.26-1
                        python-pdfrw                0.3-2                0.4-1
                        python-qiniu              7.1.5-1              7.1.6-1
                       python2-pdfrw                0.3-2                0.4-1
                       python2-qiniu              7.1.5-1              7.1.6-1
                              reaver              1.6.1-1              1.6.2-1
                              xmobar             0.24.5-5             0.24.5-6
                      haskell-libmpd                    -            0.9.0.7-1


:: Different overlay package(s) in repository community x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2017-09-25           2017-09-28
-------------------------------------------------------------------------------
           adapta-black-breath-theme         3.91.2.189-1         3.91.2.198-1
             adapta-black-maia-theme         3.91.2.189-1         3.91.2.198-1
                 adapta-breath-theme         3.91.2.189-1         3.91.2.198-1
             adapta-breath-theme-dev         3.91.2.109-1                    -
                    adapta-gtk-theme         3.91.2.189-1         3.91.2.198-1
                   adapta-maia-theme         3.91.2.189-1         3.91.2.198-1
               adapta-maia-theme-dev         3.91.2.109-1                    -
                         firefox-kde             55.0.3-1             55.0.3-2
gnome-shell-extension-manjaro-update                1.2-3                1.2-4
 gnome-shell-extension-topicons-plus                 20-1                 21-1
          manjaro-gnome-breath-theme         3.91.2.189-1         3.91.2.198-1
    manjaro-gnome-extension-settings           20170723-1           20170926-1
            manjaro-gnome-maia-theme         3.91.2.189-1         3.91.2.198-1
              manjaro-gnome-settings           20170822-2           20170926-1
               manjaro-sx-wallpapers           20170913-1           20170927-1
                          packagekit            1.1.6-0.1            1.1.7-1.1
                        palemoon-bin             27.4.2-1             27.5.0-1
                    palemoon-i18n-cs             27.4.1-1             27.5.0-1
                    palemoon-i18n-de             27.4.1-1             27.5.0-1
                 palemoon-i18n-en-gb             27.4.1-1             27.5.0-1
                 palemoon-i18n-es-ar             27.4.1-1             27.5.0-1
                 palemoon-i18n-es-es             27.4.1-1             27.5.0-1
                 palemoon-i18n-es-mx             27.4.1-1             27.5.0-1
                    palemoon-i18n-fr             27.4.1-1             27.5.0-1
                    palemoon-i18n-hu             27.4.1-1             27.5.0-1
                    palemoon-i18n-it             27.4.1-1             27.5.0-1
                    palemoon-i18n-ko             27.4.1-1             27.5.0-1
                    palemoon-i18n-nl             27.4.1-1             27.5.0-1
                    palemoon-i18n-pl             27.4.1-1             27.5.0-1
                 palemoon-i18n-pt-br             27.4.1-1             27.5.0-1
                 palemoon-i18n-pt-pt             27.4.1-1             27.5.0-1
                    palemoon-i18n-ru             27.4.1-1             27.5.0-1
                 palemoon-i18n-sv-se             27.4.1-1             27.5.0-1
                    palemoon-i18n-tr             27.4.1-1             27.5.0-1
                 palemoon-i18n-zh-cn             27.4.1-1             27.5.0-1
                       timeshift-dev                    - v17.2.r41.gdf5b91c-1


:: Different sync package(s) in repository community x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2017-09-25           2017-09-28
-------------------------------------------------------------------------------
                         blur-effect              1.1.2-1              1.1.3-1
                                dumb                1.0-1              2.0.0-1
                       elasticsearch              5.6.1-1              5.6.2-1
                              kibana              5.6.1-1              5.6.2-1
                                kodi               17.4-1               17.4-4
                            kodi-dev               17.4-1               17.4-4
                   kodi-eventclients               17.4-1               17.4-4
            kodi-tools-texturepacker               17.4-1               17.4-4
                            logstash              5.6.1-1              5.6.2-1
                               opera       47.0.2631.80-1       48.0.2685.32-1
                         php-mongodb             1.2.10-1              1.3.0-1
                              pwndbg         2017.02.01-1         2017.09.26-1
                        python-pdfrw                0.3-2                0.4-1
                        python-qiniu              7.1.5-1              7.1.6-1
                       python2-pdfrw                0.3-2                0.4-1
                       python2-qiniu              7.1.5-1              7.1.6-1
                              reaver              1.6.1-1              1.6.2-1
                              xmobar             0.24.5-5             0.24.5-6
                      haskell-libmpd                    -            0.9.0.7-1


:: Different overlay package(s) in repository core i686

-------------------------------------------------------------------------------
                             PACKAGE           2017-09-25           2017-09-28
-------------------------------------------------------------------------------
                            linux318            3.18.71-1            3.18.72-1
                    linux318-headers            3.18.71-1            3.18.72-1
                            linux413             4.13.3-2             4.13.4-1
                    linux413-headers             4.13.3-2             4.13.4-1
                             linux44             4.4.88-1             4.4.89-1
                     linux44-headers             4.4.88-1             4.4.89-1
                             linux49             4.9.51-1             4.9.52-1
                     linux49-headers             4.9.51-1             4.9.52-1


:: Different overlay package(s) in repository core x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2017-09-25           2017-09-28
-------------------------------------------------------------------------------
                            linux318            3.18.71-1            3.18.72-1
                    linux318-headers            3.18.71-1            3.18.72-1
                            linux413             4.13.3-2             4.13.4-1
                    linux413-headers             4.13.3-2             4.13.4-1
              linux414 4.14rc1.20170923.gcd4175b-1 4.14rc2.20170927.g9cd6681-1
      linux414-headers 4.14rc1.20170923.gcd4175b-1 4.14rc2.20170927.g9cd6681-1
                             linux44             4.4.88-1             4.4.89-1
                     linux44-headers             4.4.88-1             4.4.89-1
                             linux49             4.9.51-1             4.9.52-1
                     linux49-headers             4.9.51-1             4.9.52-1


:: Different overlay package(s) in repository extra i686

-------------------------------------------------------------------------------
                             PACKAGE           2017-09-25           2017-09-28
-------------------------------------------------------------------------------
                  linux413-acpi_call              1.1.0-3              1.1.0-4
                   linux413-bbswitch                0.8-3                0.8-4
                linux413-broadcom-wl       6.30.223.271-3       6.30.223.271-4
                   linux413-catalyst      1:15.201.1151-3      1:15.201.1151-4
                linux413-ndiswrapper               1.61-3               1.61-4
                     linux413-nvidia           1:384.90-1           1:384.90-2
               linux413-nvidia-304xx          1:304.137-1          1:304.137-2
               linux413-nvidia-340xx            340.104-1            340.104-2
                   linux413-nvidiabl               0.88-3               0.88-4
                      linux413-r8168           8.044.02-3           8.044.02-4
                  linux413-rt3562sta         2.4.1.1_r4-3         2.4.1.1_r4-4
                        linux413-spl              0.7.0-3              0.7.0-4
                   linux413-tp_smapi               0.41-3               0.41-4
                linux413-vhba-module           20161009-3           20161009-4
   linux413-virtualbox-guest-modules             5.1.28-2             5.1.28-3
    linux413-virtualbox-host-modules             5.1.28-2             5.1.28-3
                        linux413-zfs              0.7.0-3              0.7.0-4
                   linux44-acpi_call             1.1.0-60             1.1.0-61
                    linux44-bbswitch               0.8-60               0.8-61
                 linux44-broadcom-wl      6.30.223.271-30      6.30.223.271-31
                    linux44-catalyst     1:15.201.1151-60     1:15.201.1151-61
                 linux44-ndiswrapper              1.61-28              1.61-29
                      linux44-nvidia           1:384.90-1           1:384.90-2
                linux44-nvidia-304xx         1:304.134-30         1:304.134-31
                linux44-nvidia-340xx            340.104-1            340.104-2
                    linux44-nvidiabl              0.88-60              0.88-61
       linux44-open-vm-tools-modules      2:2013.09.16-60      2:2013.09.16-61
                       linux44-r8168          8.044.02-14          8.044.02-15
                   linux44-rt3562sta        2.4.1.1_r4-28        2.4.1.1_r4-29
                         linux44-spl              0.7.0-6              0.7.0-7
                    linux44-tp_smapi              0.41-60              0.41-61
                 linux44-vhba-module          20161009-28          20161009-29
    linux44-virtualbox-guest-modules             5.1.28-1             5.1.28-2
     linux44-virtualbox-host-modules             5.1.28-1             5.1.28-2
                         linux44-zfs              0.7.0-6              0.7.0-7
                   linux49-acpi_call             1.1.0-42             1.1.0-43
                    linux49-bbswitch               0.8-42               0.8-43
                 linux49-broadcom-wl      6.30.223.271-42      6.30.223.271-43
                    linux49-catalyst     1:15.201.1151-42     1:15.201.1151-43
                 linux49-ndiswrapper              1.61-40              1.61-41
                      linux49-nvidia           1:384.90-1           1:384.90-2
                linux49-nvidia-304xx          1:304.137-1          1:304.137-2
                linux49-nvidia-340xx            340.104-1            340.104-2
                    linux49-nvidiabl              0.88-42              0.88-43
                       linux49-r8168          8.044.02-22          8.044.02-23
                   linux49-rt3562sta        2.4.1.1_r4-40        2.4.1.1_r4-41
                         linux49-spl              0.7.0-9             0.7.0-10
                    linux49-tp_smapi              0.41-42              0.41-43
                 linux49-vhba-module          20161009-40          20161009-41
    linux49-virtualbox-guest-modules             5.1.28-2             5.1.28-3
     linux49-virtualbox-host-modules             5.1.28-2             5.1.28-3
                         linux49-zfs              0.7.0-9             0.7.0-10
            manjaro-documentation-en           20170326-1           20170926-1


:: Different sync package(s) in repository extra i686

-------------------------------------------------------------------------------
                             PACKAGE           2017-09-25           2017-09-28
-------------------------------------------------------------------------------
                           appstream             0.11.5-1             0.11.5-2
                        appstream-qt             0.11.5-1             0.11.5-2
                             flatpak             0.9.12-1             0.9.98-1
                          libsynctex         2017.44590-4         2017.44590-5
                              ostree            2017.10-1            2017.11-1
                       python-nbxmpp              0.5.6-1              0.6.0-1
                      python2-nbxmpp              0.5.6-1              0.6.0-1
                         texlive-bin         2017.44590-4         2017.44590-5


:: Different overlay package(s) in repository extra x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2017-09-25           2017-09-28
-------------------------------------------------------------------------------
                  linux413-acpi_call              1.1.0-3              1.1.0-4
                   linux413-bbswitch                0.8-3                0.8-4
                linux413-broadcom-wl       6.30.223.271-3       6.30.223.271-4
                   linux413-catalyst      1:15.201.1151-3      1:15.201.1151-4
                linux413-ndiswrapper               1.61-3               1.61-4
                     linux413-nvidia           1:384.90-1           1:384.90-2
               linux413-nvidia-304xx          1:304.137-1          1:304.137-2
               linux413-nvidia-340xx            340.104-1            340.104-2
                   linux413-nvidiabl               0.88-3               0.88-4
                      linux413-r8168           8.044.02-3           8.044.02-4
                  linux413-rt3562sta         2.4.1.1_r4-3         2.4.1.1_r4-4
                        linux413-spl              0.7.0-3              0.7.0-4
                   linux413-tp_smapi               0.41-3               0.41-4
                linux413-vhba-module           20161009-3           20161009-4
   linux413-virtualbox-guest-modules             5.1.28-2             5.1.28-3
    linux413-virtualbox-host-modules             5.1.28-2             5.1.28-3
                        linux413-zfs              0.7.0-3              0.7.0-4
                  linux414-acpi_call            1.1.0-0.4            1.1.0-0.5
                   linux414-bbswitch              0.8-0.4              0.8-0.5
                linux414-broadcom-wl     6.30.223.271-0.4     6.30.223.271-0.5
                   linux414-catalyst    1:15.201.1151-0.4    1:15.201.1151-0.5
                linux414-ndiswrapper             1.61-0.4             1.61-0.5
                     linux414-nvidia         1:384.90-0.4         1:384.90-0.5
               linux414-nvidia-304xx        1:304.137-0.4        1:304.137-0.5
               linux414-nvidia-340xx          340.104-0.4          340.104-0.5
                   linux414-nvidiabl             0.88-0.4             0.88-0.5
                      linux414-r8168         8.044.02-0.4         8.044.02-0.5
                   linux414-tp_smapi             0.41-0.4             0.41-0.5
                linux414-vhba-module         20161009-0.4         20161009-0.5
   linux414-virtualbox-guest-modules           5.1.28-0.1           5.1.28-0.5
    linux414-virtualbox-host-modules           5.1.28-0.1           5.1.28-0.5
                   linux44-acpi_call             1.1.0-60             1.1.0-61
                    linux44-bbswitch               0.8-60               0.8-61
                 linux44-broadcom-wl      6.30.223.271-30      6.30.223.271-31
                    linux44-catalyst     1:15.201.1151-60     1:15.201.1151-61
                 linux44-ndiswrapper              1.61-28              1.61-29
                      linux44-nvidia           1:384.90-1           1:384.90-2
                linux44-nvidia-304xx         1:304.134-30         1:304.134-31
                linux44-nvidia-340xx            340.104-1            340.104-2
                    linux44-nvidiabl              0.88-60              0.88-61
       linux44-open-vm-tools-modules      2:2013.09.16-60      2:2013.09.16-61
                       linux44-r8168          8.044.02-14          8.044.02-15
                   linux44-rt3562sta        2.4.1.1_r4-28        2.4.1.1_r4-29
                         linux44-spl              0.7.0-6              0.7.0-7
                    linux44-tp_smapi              0.41-60              0.41-61
                 linux44-vhba-module          20161009-28          20161009-29
    linux44-virtualbox-guest-modules             5.1.28-1             5.1.28-2
     linux44-virtualbox-host-modules             5.1.28-1             5.1.28-2
                         linux44-zfs              0.7.0-6              0.7.0-7
                   linux49-acpi_call             1.1.0-42             1.1.0-43
                    linux49-bbswitch               0.8-42               0.8-43
                 linux49-broadcom-wl      6.30.223.271-42      6.30.223.271-43
                    linux49-catalyst     1:15.201.1151-42     1:15.201.1151-43
                 linux49-ndiswrapper              1.61-40              1.61-41
                      linux49-nvidia           1:384.90-1           1:384.90-2
                linux49-nvidia-304xx          1:304.137-1          1:304.137-2
                linux49-nvidia-340xx            340.104-1            340.104-2
                    linux49-nvidiabl              0.88-42              0.88-43
                       linux49-r8168          8.044.02-22          8.044.02-23
                   linux49-rt3562sta        2.4.1.1_r4-40        2.4.1.1_r4-41
                         linux49-spl              0.7.0-9             0.7.0-10
                    linux49-tp_smapi              0.41-42              0.41-43
                 linux49-vhba-module          20161009-40          20161009-41
    linux49-virtualbox-guest-modules             5.1.28-2             5.1.28-3
     linux49-virtualbox-host-modules             5.1.28-2             5.1.28-3
                         linux49-zfs              0.7.0-9             0.7.0-10
            manjaro-documentation-en           20170326-1           20170926-1


:: Different sync package(s) in repository extra x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2017-09-25           2017-09-28
-------------------------------------------------------------------------------
                           appstream             0.11.5-1             0.11.5-2
                        appstream-qt             0.11.5-1             0.11.5-2
                             flatpak             0.9.12-1             0.9.98-1
                          libsynctex         2017.44590-4         2017.44590-5
                              ostree            2017.10-1            2017.11-1
                       python-nbxmpp              0.5.6-1              0.6.0-1
                      python2-nbxmpp              0.5.6-1              0.6.0-1
                         texlive-bin         2017.44590-4         2017.44590-5

Full list of all package changes can be found here.


  • No issues, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself. (Please post your solution)
  • Yes I am currently experiencing an issue due to the update. (Please post about it)

0 voters


Check if your mirror has already synced:


#2

Seems everything good for me :smiley:

You people are awesome. :hugs::hugs:


#3

Looks good - will it be the regular Xfce or the GTK3 version?


#4

4.13.4 seems bugged, I had 3 freezes in a row, no problem with 4.9


#5

Nevermind…


#6

no problem here on an AMD/AMD system.
what are your specs?


#7

Look, I had no problems with 4.13.3 whatsoever, but 4.13.4 freezes almost immediately upon boot. Specs are normal PC Intel i7 z97 mainboard.


#8

graphic card? driver version?
bug reports with a simple “freezes for me” do not help at all as they do not help to narrow down which parts could cause it.


#9

They’ll fix it in next release, this is kernel, not Manajro bug.


#10

In Gnome, looks like the menu text got too dark in the “Maia-Dark” theme… the text is now too dark to easily see. Up until this update, the text was white(-ish) like the icons and text in the menubar.


Maia Color is strange
#11

Can you check if in the change-log you find some regression? Does linux414 work on your end?


#12

Great idea to add Timeshift!


#13

I assume you use arc-maia theme and normal gtk+ system ( no gtk3-classic) so the problem is this : upstream not update the theme so i think with upcoming gtk 3.26 possibly break the theme… i suggest to switch into another theme . In next 17.1 Hakoila release i switch gnome into adapta-manjaro-themes and to be precise into adapta-maia . In our repo you find adapta-gtk,adapta-maia,adapta-breath,adapta-black-maia/breath … :wink:


#14

"Can you check if in the change-log3 you find some regression? Does linux414 work on your end?"
Oh, it’s long time since I reported bugs to kernel mail list ;p
414 I cannot use since zfs doesn’t support it. For now I use 4.9 :wink:


#15

Since I don’t see issues on my Ryzen system with the current v4.14 and v4.13 kernel series, it might be Intel specific. Will check the v4.13.4 more on our Spitfire Laptop. Current list of packages can be found here. Hope we can publish that soon also to our stable branch.


#16

Not only in Manjaro :wink: existing problem


#17

Seems that intel_iommu related. I have removed intel_iommu=on from kernel command line and now cannot reproduce freeze.


#18

Well, if that is the case I don’t know. CONFIG_INTEL_IOMMU_DEFAULT_ON is not set, neither in v4.13 nor v4.14 series.


#19

Yeah, I set it manually on grub cmd line. Now without it I am still up, no freeze.

edit: mah I just got two freezes, problem remains. Usually happens when I start game.


#20

Wine 2.18 just got released which fixes that issue. :wink:

from here: https://www.winehq.org/announce/2.18

Bugs fixed in 2.18 (total 22):
43715 Many applications (winecfg, …) crash on startup with freetype 2.8.1
43716 freetype 2.8.1 breaks Wine build during font conversion with sfnt2fon