[Testing Update] 2017-09-24 - Nvidia, Gambas, JADE, Haskell, JDK9, Python

update
testing

#13

I assume the issues are with firefox-kde and thunderbird-kde. Those need a rebuild it seems. @Kirek


#14

I got a fresh newly re-installed KDE Manjaro 17.0.5 and I get the same error as always before when the nvidia drivers are updated: It still insists on trying to load the old kernel modules, and I need to uninstall the current kernel using mhwd-kernel -r, boot into another kernel and reinstall the kernel I wish to use to get the nvidia drivers running properly again.


#15

exactly, thanks for the upcoming rebuild.

Edit: @philm @Ste74 I replaced the two packages in question with their non-KDE counterparts and can not see any negative effects so far on my KDE machines. Are those packages really still needed? Wouldn’t it be better to replace them with the “pure” firefox and thunderbird packages?


#16

The only difference with the regular apps are the patch made by opensuse for the better integration with plasma/kde … but you know the appearence is an argument more subjective :slight_smile:


#17

What do you mean with: still insists on loading the old module? You simply install the upgrade with a normal pamac or pacman update and reboot your system. I never had issues, even when running a little longer with the current driver in RAM. However, doing games might not work in that state. So what are the exact issues you face? Do you loose your UI in some way during the upgrade?


#18

there a bug with serie 384 drivers
https://devtalk.nvidia.com/default/topic/1019761/linux/no-sound-using-displayport-audio-with-375-82-384-59-and-384-69/2
anyone can confirm this for use HDMI audio is broken ?


#20

I switched some days before to Unstable cause of the Firefox update.

Nvidida driver working good on Kernel 413 and GTX960, Manjaro Xfce.


#21

Yep, it’s the reboot that fails: [Unstable Update] 2017-05-02 - Plasma5, Gnome, VirtualBox, OpenSSL


#22

So far, so good with the new drivers. Will test more before the official thumbs up.


#23

@philm:

I got also problems without reboot with 3D acceleration on VirtualBox.
There should be a suggestion to do a Reboot after switching to a new version of the Nvidia driver.


#24

or maybe a “install updates on shutdown” option. Thats how i do it on my mothers computer and it would be a perfect match for this situation :thinking:


#25

We’ve added thunderbird-kde and other updates today. firefox-kde will come soon …

### BoxIt memo ###

User philip created a snapshot of branch 'unstable' to 'testing'.

 - testing community i686:  82 new and 79 removed package(s)
 - testing community x86_64:  86 new and 81 removed package(s)
 - testing core i686:  4 new and 4 removed package(s)
 - testing core x86_64:  4 new and 4 removed package(s)
 - testing extra i686:  13 new and 13 removed package(s)
 - testing extra x86_64:  13 new and 13 removed package(s)
 - testing multilib x86_64:  6 new and 6 removed package(s)

:: Different overlay package(s) in repository community i686

-------------------------------------------------------------------------------
                             PACKAGE           2017-09-24           2017-09-25
-------------------------------------------------------------------------------
                     thunderbird-kde             52.3.0-1             52.3.0-2


:: Different sync package(s) in repository community i686

-------------------------------------------------------------------------------
                             PACKAGE           2017-09-24           2017-09-25
-------------------------------------------------------------------------------
                        cabal-helper            0.7.3.0-6            0.7.3.0-7
                               cgrep            6.6.17-18            6.6.17-19
                          easystroke             0.6.0-15             0.6.0-16
                       gitlab-runner              9.5.0-2             10.0.0-1
                haskell-aeson-pretty             0.8.5-12             0.8.5-13
         haskell-annotated-wl-pprint              0.7.0-4              0.7.0-5
              haskell-bindings-uname                0.1-2                0.1-3
                     haskell-cmdargs            0.10.17-4            0.10.18-1
                      haskell-colour              2.3.3-4              2.3.3-5
      haskell-data-accessor-template           0.2.1.14-2           0.2.1.14-3
                  haskell-data-bword            0.1.0.1-3            0.1.0.1-4
 haskell-data-default-instances-base            0.1.0.1-4            0.1.0.1-5
                  haskell-data-dword            0.3.1.1-5            0.3.1.1-6
                 haskell-data-endian              0.1.1-3              0.1.1-4
                       haskell-foldl              1.3.1-3              1.3.2-1
                      haskell-gnutls                0.2-5                0.2-6
                      haskell-hakyll           4.9.8.0-56           4.9.8.0-58
                       haskell-hasql          0.19.18.1-8          0.19.18.2-1
                  haskell-hasql-pool             0.4.1-73             0.4.1-74
           haskell-hasql-transaction               0.5-55               0.5-56
                 haskell-hledger-lib              1.3.2-3              1.3.2-4
                       haskell-hspec              2.4.4-3              2.4.4-4
                        haskell-json              0.9.1-9             0.9.1-10
                      haskell-logict            0.6.0.2-3            0.6.0.2-4
                haskell-microlens-th            0.4.1.1-4            0.4.1.1-5
                  haskell-monad-time                0.2-1                0.2-2
                 haskell-murmur-hash            0.1.0.9-3            0.1.0.9-4
                        haskell-only                0.1-2                0.1-3
                haskell-pandoc-types             1.17.1-3             1.17.2-1
              haskell-roman-numerals            0.5.1.5-6            0.5.1.5-7
       haskell-tamarin-prover-theory              1.2.2-5              1.2.2-6
                     haskell-texmath            0.9.4.2-2            0.9.4.2-3
                  haskell-text-short              0.1.1-1              0.1.1-2
                     haskell-th-lift              0.7.7-3              0.7.7-4
                      haskell-turtle              1.4.3-4              1.4.3-5
             haskell-unexceptionalio              0.3.0-4              0.3.0-5
                    haskell-unliftio            0.1.0.0-5            0.1.0.0-6
                  haskell-utility-ht             0.0.14-3             0.0.14-4
                         haskell-x11                1.8-4                1.8-5
                             hledger              1.3.1-6              1.3.1-7
                         hledger-api             1.3.1-12             1.3.1-13
                          hledger-ui              1.3.1-8              1.3.1-9
                         hledger-web              1.3.2-1              1.3.2-2
                               hlint             2.0.9-20             2.0.9-21
                              hoogle            5.0.13-20            5.0.13-21
                               i3-wm               4.14-1             4.14.1-1
                                inxi             2.3.39-1             2.3.40-1
                               jruby           9.1.12.0-1           9.1.13.0-1
             mythplugins-mytharchive             1:29.0-1             1:29.0-2
             mythplugins-mythbrowser             1:29.0-1             1:29.0-2
             mythplugins-mythgallery             1:29.0-1             1:29.0-2
                mythplugins-mythgame             1:29.0-1             1:29.0-2
               mythplugins-mythmusic             1:29.0-1             1:29.0-2
           mythplugins-mythnetvision             1:29.0-1             1:29.0-2
                mythplugins-mythnews             1:29.0-1             1:29.0-2
             mythplugins-mythweather             1:29.0-1             1:29.0-2
                 mythplugins-mythweb             1:29.0-1             1:29.0-2
          mythplugins-mythzoneminder             1:29.0-1             1:29.0-2
                              mythtv             1:29.0-2             1:29.0-3
                              pandoc         1.19.2.1-114         1.19.2.1-115
                     pandoc-citeproc           0.11.1.1-2           0.11.1.1-4
                     pandoc-crossref           0.2.6.0-12           0.2.6.0-13
      plasma5-applets-weather-widget              1.6.9-1             1.6.10-1
                           postgrest           0.4.2.0-15           0.4.2.0-16
                     python-autobahn             17.9.2-1             17.9.3-1
                   python-hypothesis             3.30.1-1             3.30.2-1
                    python2-autobahn             17.9.2-1             17.9.3-1
                  python2-hypothesis             3.30.1-1             3.30.2-1
                               redis              4.0.1-1              4.0.2-1
                        riot-desktop             0.12.3-1             0.12.6-1
                            riot-web             0.12.3-1             0.12.6-1
                          shellcheck              0.4.6-7              0.4.6-8
                           shorewall            5.1.6.1-1            5.1.7.1-1
                      shorewall-core            5.1.6.1-1            5.1.7.1-1
                          shorewall6            5.1.6.1-1            5.1.7.1-1
                              sysdig             0.17.0-1             0.18.0-1
                      tamarin-prover             1.2.2-20             1.2.2-21
                           uglify-js              3.1.1-1              3.1.2-1
                  haskell-configfile                    -              1.1.4-1
                        haskell-diff                    -              0.3.4-1
                            pixiewps                    -  1.2.2.19.gf723d50-1


:: Different overlay package(s) in repository community x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2017-09-24           2017-09-25
-------------------------------------------------------------------------------
                     thunderbird-kde             52.3.0-1             52.3.0-2
   linux-rt-lts-manjaro-nvidia-340xx                    -            340.104-1
       linux-rt-manjaro-nvidia-340xx                    -            340.104-1


:: Different sync package(s) in repository community x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2017-09-24           2017-09-25
-------------------------------------------------------------------------------
                        cabal-helper            0.7.3.0-6            0.7.3.0-7
                               cgrep            6.6.17-18            6.6.17-19
                          easystroke             0.6.0-15             0.6.0-16
                       gitlab-runner              9.5.0-2             10.0.0-1
                haskell-aeson-pretty             0.8.5-12             0.8.5-13
         haskell-annotated-wl-pprint              0.7.0-4              0.7.0-5
              haskell-bindings-uname                0.1-2                0.1-3
                     haskell-cmdargs            0.10.17-4            0.10.18-1
                      haskell-colour              2.3.3-4              2.3.3-5
      haskell-data-accessor-template           0.2.1.14-2           0.2.1.14-3
                  haskell-data-bword            0.1.0.1-3            0.1.0.1-4
 haskell-data-default-instances-base            0.1.0.1-4            0.1.0.1-5
                  haskell-data-dword            0.3.1.1-5            0.3.1.1-6
                 haskell-data-endian              0.1.1-3              0.1.1-4
                       haskell-foldl              1.3.1-3              1.3.2-1
                      haskell-gnutls                0.2-5                0.2-6
                      haskell-hakyll           4.9.8.0-56           4.9.8.0-58
                       haskell-hasql          0.19.18.1-8          0.19.18.2-1
                  haskell-hasql-pool             0.4.1-73             0.4.1-74
           haskell-hasql-transaction               0.5-55               0.5-56
                 haskell-hledger-lib              1.3.2-3              1.3.2-4
                       haskell-hspec              2.4.4-3              2.4.4-4
                        haskell-json              0.9.1-9             0.9.1-10
                      haskell-logict            0.6.0.2-3            0.6.0.2-4
                haskell-microlens-th            0.4.1.1-4            0.4.1.1-5
                  haskell-monad-time                0.2-1                0.2-2
                 haskell-murmur-hash            0.1.0.9-3            0.1.0.9-4
                        haskell-only                0.1-2                0.1-3
                haskell-pandoc-types             1.17.1-3             1.17.2-1
              haskell-roman-numerals            0.5.1.5-6            0.5.1.5-7
       haskell-tamarin-prover-theory              1.2.2-5              1.2.2-6
                     haskell-texmath            0.9.4.2-2            0.9.4.2-3
                  haskell-text-short              0.1.1-1              0.1.1-2
                     haskell-th-lift              0.7.7-3              0.7.7-4
                      haskell-turtle              1.4.3-4              1.4.3-5
             haskell-unexceptionalio              0.3.0-4              0.3.0-5
                    haskell-unliftio            0.1.0.0-5            0.1.0.0-6
                  haskell-utility-ht             0.0.14-3             0.0.14-4
                         haskell-x11                1.8-4                1.8-5
                             hledger              1.3.1-6              1.3.1-7
                         hledger-api             1.3.1-12             1.3.1-13
                          hledger-ui              1.3.1-8              1.3.1-9
                         hledger-web              1.3.2-1              1.3.2-2
                               hlint             2.0.9-20             2.0.9-21
                              hoogle            5.0.13-20            5.0.13-21
                               i3-wm               4.14-1             4.14.1-1
                                inxi             2.3.39-1             2.3.40-1
                               jruby           9.1.12.0-1           9.1.13.0-1
             mythplugins-mytharchive             1:29.0-1             1:29.0-2
             mythplugins-mythbrowser             1:29.0-1             1:29.0-2
             mythplugins-mythgallery             1:29.0-1             1:29.0-2
                mythplugins-mythgame             1:29.0-1             1:29.0-2
               mythplugins-mythmusic             1:29.0-1             1:29.0-2
           mythplugins-mythnetvision             1:29.0-1             1:29.0-2
                mythplugins-mythnews             1:29.0-1             1:29.0-2
             mythplugins-mythweather             1:29.0-1             1:29.0-2
                 mythplugins-mythweb             1:29.0-1             1:29.0-2
          mythplugins-mythzoneminder             1:29.0-1             1:29.0-2
                              mythtv             1:29.0-2             1:29.0-3
                              pandoc         1.19.2.1-114         1.19.2.1-115
                     pandoc-citeproc           0.11.1.1-2           0.11.1.1-4
                     pandoc-crossref           0.2.6.0-12           0.2.6.0-13
      plasma5-applets-weather-widget              1.6.9-1             1.6.10-1
                           postgrest           0.4.2.0-15           0.4.2.0-16
                     python-autobahn             17.9.2-1             17.9.3-1
                   python-hypothesis             3.30.1-1             3.30.2-1
                    python2-autobahn             17.9.2-1             17.9.3-1
                  python2-hypothesis             3.30.1-1             3.30.2-1
                               redis              4.0.1-1              4.0.2-1
                        riot-desktop             0.12.3-1             0.12.6-1
                            riot-web             0.12.3-1             0.12.6-1
                            rubinius               3.84-1               3.85-1
                       rubinius-ruby               3.84-1               3.85-1
                          shellcheck              0.4.6-7              0.4.6-8
                           shorewall            5.1.6.1-1            5.1.7.1-1
                      shorewall-core            5.1.6.1-1            5.1.7.1-1
                          shorewall6            5.1.6.1-1            5.1.7.1-1
                              sysdig             0.17.0-1             0.18.0-1
                      tamarin-prover             1.2.2-20             1.2.2-21
                           uglify-js              3.1.1-1              3.1.2-1
                  haskell-configfile                    -              1.1.4-1
                        haskell-diff                    -              0.3.4-1
                            pixiewps                    -  1.2.2.19.gf723d50-1


:: Different sync package(s) in repository core i686

-------------------------------------------------------------------------------
                             PACKAGE           2017-09-24           2017-09-25
-------------------------------------------------------------------------------
                          libsystemd             234.11-8             234.11-9
                             systemd             234.11-8             234.11-9
                  systemd-sysvcompat             234.11-8             234.11-9
             thin-provisioning-tools              0.7.1-1              0.7.2-1


:: Different sync package(s) in repository core x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2017-09-24           2017-09-25
-------------------------------------------------------------------------------
                          libsystemd             234.11-8             234.11-9
                             systemd             234.11-8             234.11-9
                  systemd-sysvcompat             234.11-8             234.11-9
             thin-provisioning-tools              0.7.1-1              0.7.2-1


:: Different overlay package(s) in repository extra i686

-------------------------------------------------------------------------------
                             PACKAGE           2017-09-24           2017-09-25
-------------------------------------------------------------------------------
                       manjaro-hello              0.5.5-1              0.5.6-1


:: Different sync package(s) in repository extra i686

-------------------------------------------------------------------------------
                             PACKAGE           2017-09-24           2017-09-25
-------------------------------------------------------------------------------
                          f2fs-tools              1.8.0-1              1.9.0-1
                      geoip-database           20170801-1           20170905-1
                geoip-database-extra           20170801-1           20170905-1
                               ipset               6.33-1               6.34-1
                             libdmtx              0.7.4-5              0.7.4-6
                              openal             1.18.1-1             1.18.2-1
                     openal-examples             1.18.1-1             1.18.2-1
                    shared-mime-info                1.8-1                1.9-1
                      vulkan-headers           1:1.0.59-1           1:1.0.61-1
                    vulkan-html-docs           1:1.0.59-1           1:1.0.61-1
                   vulkan-icd-loader           1.0.57.0-1           1.0.61.1-1
            vulkan-validation-layers           1.0.57.0-1           1.0.61.1-1


:: Different overlay package(s) in repository extra x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2017-09-24           2017-09-25
-------------------------------------------------------------------------------
                       manjaro-hello              0.5.5-1              0.5.6-1


:: Different sync package(s) in repository extra x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2017-09-24           2017-09-25
-------------------------------------------------------------------------------
                          f2fs-tools              1.8.0-1              1.9.0-1
                      geoip-database           20170801-1           20170905-1
                geoip-database-extra           20170801-1           20170905-1
                               ipset               6.33-1               6.34-1
                             libdmtx              0.7.4-5              0.7.4-6
                              openal             1.18.1-1             1.18.2-1
                     openal-examples             1.18.1-1             1.18.2-1
                    shared-mime-info                1.8-1                1.9-1
                      vulkan-headers           1:1.0.59-1           1:1.0.61-1
                    vulkan-html-docs           1:1.0.59-1           1:1.0.61-1
                   vulkan-icd-loader           1.0.57.0-1           1.0.61.1-1
            vulkan-validation-layers           1.0.57.0-1           1.0.61.1-1


:: Different sync package(s) in repository multilib x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2017-09-24           2017-09-25
-------------------------------------------------------------------------------
                          lib32-gtk3            3.22.19-1            3.22.21-1
                        lib32-openal             1.18.1-1             1.18.2-1
                           lib32-tcl              8.6.6-3              8.6.7-1
             lib32-vulkan-icd-loader           1.0.54.0-1           1.0.61.1-1
      lib32-vulkan-validation-layers           1.0.54.0-1           1.0.61.1-1
                       lib32-wayland             1.13.0-1             1.14.0-1


#26

This is what I’m finding:

:: Proceed with installation? [Y/n] 
:: Retrieving packages...
 linux49-4.9.51-1-x86_64                                      60,2 MiB  2,06M/s 00:29 [########################################
 linux49-r8168-8.044.02-22-x86_64                            161,0 KiB  2,38M/s 00:00 [########################################
 lib32-mesa-17.2.1-1-x86_64                                   11,2 MiB  2,07M/s 00:05 [########################################
(66/66) checking keys in keyring                                                      [########################################
(66/66) checking package integrity                                                    [########################################
error: lib32-mesa: signature from "Philip Müller (Called Little) <philm@manjaro.org>" is marginal trust
:: File /var/cache/pacman/pkg/lib32-mesa-17.2.1-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature))
Do you want to delete it? [Y/n] 
error: linux49: signature from "Philip Müller (Called Little) <philm@manjaro.org>" is marginal trust
:: File /var/cache/pacman/pkg/linux49-4.9.51-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] 
error: linux49-r8168: signature from "Philip Müller (Called Little) <philm@manjaro.org>" is marginal trust
:: File /var/cache/pacman/pkg/linux49-r8168-8.044.02-22-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signa
Do you want to delete it? [Y/n] 
error: failed to commit transaction (invalid or corrupted package)
Errors occurred, no packages were upgraded.

Update:
Fixed it with:
gpg --recv-keys 247B52CC 11C7F07E 59152F77 5C0102A6 604F8BA2 AC97B894 5DCB998E B35859F8 663CA268 8DF53602 A42D53A2

All smooth sailing. Thanks Manjaro team!


#27

Also these added packages worked fine - thanks!


#28

removed firefox-kde and updated pamac.


#29

Added some more packages


#30

firefox-kde and thunderbird-kde are back in testing by using an older freetype v2.8 package. This should make wine work again too.


#31

Thumbs up after switching mirrors.


#32

Thanks for telling. Did the same and after removing kernel 4.11 update started.


#33