[Testing Update] 2017-09-24 - Nvidia, Gambas, JADE, Haskell, JDK9, Python



Hi community,

this is more or less about Nvidia driver updates. All our series got updated to their latest version. Please test, especially the RT-Kernel drivers and give us feedback about them.

Vitor Lopes released JADE v0.4 with new features to play web-videos directly on the dashboard:

Give it a try by installing jade-dashboard-git.

For our developers we have updated Python, Haskell and JDK9.

Please test and give us feedback as usual

Current supported Kernels

  • linux316 3.16.48
  • linux318 3.18.71 [EOL]
  • linux41 4.1.44
  • linux44 4.4.88
  • linux49 4.9.51
  • linux412 4.12.14 [EOL]
  • linux413 4.13.3
  • linux414 4.14-rc1 (x86_64)
  • linux-RT-LTS 4.9.40_rt30 (x86_64)
  • linux-RT 4.11.12_rt12 (x86_64)

Package Updates (Sun Sep 24 08:45:42 CEST 2017)

  • testing community i686: 672 new and 666 removed package(s)
  • testing community x86_64: 679 new and 673 removed package(s)
  • testing core i686: 6 new and 6 removed package(s)
  • testing core x86_64: 8 new and 8 removed package(s)
  • testing extra i686: 89 new and 82 removed package(s)
  • testing extra x86_64: 103 new and 94 removed package(s)
  • testing multilib x86_64: 7 new and 7 removed package(s)

A detailed list of package changes can be found here.

  • No issues, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself. (Please post your solution)
  • Yes I am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:



Flawless update on my main rig, 48 packages. Nvidia has no issue …
I’ll install the 4.14 kernel and see how it performs.

It seems the 4.14 kernel uses the old module version. From journalctl:

NVRM: this kernel module has the version 375.82.  Please
                                  NVRM: make sure that this kernel module and all NVIDIA driver



For Minecrafters, that want to use jre9, remove -XX:+CMSIncrementalMode (and only this!) from JVM arguments. after this Minecraft will start just fine.


Without nvidia graphics only the mhwd pakets updated for me.
All the others went fine! - Thanks


One laptop I switched to unstable to get the new nvidia drivers yesterday (GeForce GT 740M), no issues, good performance.

Second laptop testing update smooth (GeForce GTX 965M), no issues so far, tested via primusrun with about 10 different apps and no issues, good perfomance.

Rest of update smooth as silk on 4.13 and 4.9.

Will wait on 4.14 until a little closer to actual production ready release.


After this update I have ugly fonts in Firefox, I don’t know which package could have caused the issue (KDE and Firefox font settings are okay), I’ll investigate later when I have the time. In the mean time, anyone with the same issue?


second that, Thunderbird is also affected. Looks like some pixels are missing or "antialiased away"
see this screenshots for reference:


It seems to me that some kernels cause problems. I had some 4.11 kernel version installed( but not used) and it failed to upgrade due to its nvidia dependencies.
While I was remving 4.11 I wanted to give 4.13 a try and pacman refused to cooperate due to same nvidia kernel dependencies,

resolving dependencies…
looking for conflicting packages…
error: failed to prepare transaction (could not satisfy dependencies)
:: linux411-nvidia: installing nvidia-utils (1:384.90-1) breaks dependency ‘nvidia-utils=1:375.82’


After removing kenel 4.11 the upgrade went on without issues.


@Cubanpit @BS86 alrrady open issue in our repo… seem ff and thunderbird need to be rebuild with kde patch …


…is this an option or a trap?

:: Starte vollständige Systemaktualisierung...
:: snap-confine durch community/snapd ersetzen? [J/n] 
:: snap-confine durch community/snapd-git ersetzen? [J/n] 
Löse Abhängigkeiten auf...
Suche nach in Konflikt stehenden Paketen...
Warnung: Entferne 'snapd' aus der Ziel-Liste, da es mit 'snapd-git' in 
Konflikt steht
:: snapd-git und snapd stehen miteinander in Konflikt. snapd entfernen? 

is git the preferred option? I haven’t ever used snap.


Thank you for the tip.
Let’s get some more diamonds :wink:


I assume the issues are with firefox-kde and thunderbird-kde. Those need a rebuild it seems. @Kirek


I got a fresh newly re-installed KDE Manjaro 17.0.5 and I get the same error as always before when the nvidia drivers are updated: It still insists on trying to load the old kernel modules, and I need to uninstall the current kernel using mhwd-kernel -r, boot into another kernel and reinstall the kernel I wish to use to get the nvidia drivers running properly again.


exactly, thanks for the upcoming rebuild.

Edit: @philm @Ste74 I replaced the two packages in question with their non-KDE counterparts and can not see any negative effects so far on my KDE machines. Are those packages really still needed? Wouldn’t it be better to replace them with the “pure” firefox and thunderbird packages?


The only difference with the regular apps are the patch made by opensuse for the better integration with plasma/kde … but you know the appearence is an argument more subjective :slight_smile:


What do you mean with: still insists on loading the old module? You simply install the upgrade with a normal pamac or pacman update and reboot your system. I never had issues, even when running a little longer with the current driver in RAM. However, doing games might not work in that state. So what are the exact issues you face? Do you loose your UI in some way during the upgrade?


there a bug with serie 384 drivers
anyone can confirm this for use HDMI audio is broken ?


I switched some days before to Unstable cause of the Firefox update.

Nvidida driver working good on Kernel 413 and GTX960, Manjaro Xfce.


Yep, it’s the reboot that fails: [Unstable Update] 2017-05-02 - Plasma5, Gnome, VirtualBox, OpenSSL