[Testing Update] 2017-07-17 - Kernels, Architect, Deepin, KDE Apps, Toolchain

Hi community,

Matti worked on Manjaro Architect, Bernhard pushed out some more Deepin packages, I worked on a new set of Kernels, Stefano polished some settings and we merged upstream Stuff like KDE Apps v17.04.3 and the new Toolchain. Additionally VirtualBox should now run on kernels v4.12 and v4.13 series.

Please test and give us feedback as usual


Current supported Kernels

  • linux310 3.10.106
  • linux312 3.12.74 [EOL]
  • linux316 3.16.45
  • linux318 3.18.61 [EOL]
  • linux41 4.1.42
  • linux44 4.4.77
  • linux48 4.8.17 [EOL]
  • linux49 4.9.38
  • linux410 4.10.17 [EOL]
  • linux411 4.11.11
  • linux412 4.12.2
  • linux413 4.13-rc1 (x86_64)
  • linux-RT-LTS 4.9.35_rt25 (x86_64)
  • linux-RT 4.11.9_rt7 (x86_64)

Package Updates (Mon Jul 17 10:28:53 CEST 2017)

  • testing community i686: 201 new and 192 removed package(s)
  • testing community x86_64: 222 new and 208 removed package(s)
  • testing core i686: 29 new and 27 removed package(s)
  • testing core x86_64: 31 new and 27 removed package(s)
  • testing extra i686: 388 new and 388 removed package(s)
  • testing extra x86_64: 406 new and 389 removed package(s)
  • testing multilib x86_64: 12 new and 12 removed package(s)

A detailed list of package changes can be found here.


  • No issues, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself. (Please post your solution)
  • Yes I am currently experiencing an issue due to the update. (Please post about it)

0 voters


Check if your mirror has already synced:

4 Likes

Everything went very smoothly. Keep it up!

1 Like

With kernel 4.12.2 my system freezes when I resume from suspend. Some others are still facing the same problem:

kernel 4.13-rc1 boots normally but my mouse is frozen.

All the rest running smooth without issues.

1 Like

Any Arch bugs or kernel bugs been raised?

Everything is working correctly. I never had a problem with virtual machines to begin with (virtualbox), but I do have a hardware error with a Marvell 91xx SATA 6GB/s controller, where I get FPDMA READ errors on boot. I just plugged that rarely used SSD with Win10 into a regular SATA 3GB/s socket (Intel chipset) for now. Strange I only get that error on kernel 4.12, but not any of the previous kernels. Anyway, otherwise, everything is good here! :smiley:

good update on two machines. One systemd, one OpenRC. I am able to use VB with 4.12 now :grin:

Could you give more details now or is still early; :slightly_smiling_face:

2 Likes

I didn’t know about that. Got me all curious now! What could it be…?

On real system or in VirtualBox?

Much to early. Will be a bang for sure :smile:

2 Likes
  1. volume icon animation is back (deepin) :thumbsup:
  2. “open with” menu is back (deepin) :thumbsup:
  3. resume is working again with 4.12.2 (deepin and budgie) :thumbsup:
  4. no problem with vmware :thumbsup:
  5. no problem with kernel 4.13 (virtual machine) :thumbsup:

only one problem:
login loop with the new startdde 3.1.13-1 (no problem with 3.1.11-1)

1 Like

On real system.
Virtualbox running normally BUT guest-gnome doesn’t launch at all with kernel 4.12 (black screen).

ghc is still broken. I have flagged this update with no problems as this is broken in earlier update.

~/…/examples/haskell >>> cat hello.hs
main = do
putStrLn “Hello World!”
~/…/examples/haskell >>> ghc hello.hs
[1 of 1] Compiling Main ( hello.hs, hello.o )
Linking hello …
/usr/bin/ld: cannot find -lHSbase-4.9.1.0
/usr/bin/ld: cannot find -lHSinteger-gmp-1.0.0.1
/usr/bin/ld: cannot find -lHSghc-prim-0.5.0.0
/usr/bin/ld: cannot find -lHSrts
collect2: error: ld returned 1 exit status
gcc' failed in phaseLinker’. (Exit code: 1)

PS. Heh now is even ghc8.0.1 broken because of gcc update ;p
PS2 gcc now requires -static when linking object files or it gives error about requiring to compile with fPIC which breaks older ghc now
Also ghc development snapshot does not builds with gcc any more, trying with clang
PS3 nope , ghc devel seems is broken in their repo currently.
ghc-static compiles and links now but cabal is still broken as same problem with package names emerges so packages cannot find dependencies.
To conclude: Haskell is useless currently in any form.
Epilogue: I finally successfully bootstraped ghc devel snap with ghc-static and new compiler does not have problem regarding latest gcc changes, cabal works perfectly and so I found solution :wink:
Other suggested solution is to use stack which is sandbox environment for Haskell.
hm, building ghc 8.0.2 from source without problem and it works.

Still kernel 412 is unable to load nvidia-304 driver. Have I to collect some more info?

1 Like

Cool update, many packages (182)
One thing to mention, resume from suspend gives me some small artifacts on Latte Dock icons. Switching activities (KDE) makes them go away. Only on 4.12.2-1 kernel happens. I will test the 4.13 kernel soon … Cheers!

nvidia driver? Nvidia driver has bug that screen is garbled after resume. Refreshing screen fixes the issue.

2 Likes

It seems so. It does the same thing on whatever kernel i use (4.12.2-1, 4.11.11-1 and 4.9.38-1) so is clear that is an nvidia driver problem.

On 4.13.0rc1-1 kernel i get a warning SUPR0GipMap: fGetGipCpu=0xb and i recall it was present on 4.10-rc4 too (not talking about VBox but native install). Anyway, this kernel looks already promising :smiley: 13 is a good number …

I have the same issue. The latest beta drivers supposedly fix this issue. I have nvidia will release them as stable sometime soon. How do you refresh the screen in KDE? Do you mean refresh desktop in the right-click menu?

Update crashed while running ‘99-grub.hook’… Had to shut down with power key. Ran update-grub after startup showed kernel 4.12.1-1 Now showing 4.12.2-1.
[bob@Manjaro ~]$ uname -r
4.12.2-1-MANJARO

After trying it out thoroughly 4.12.2-1 has same problem, crashing when opening external USB HD.

That would work only on Folder View, there is the Refresh Desktop on right click, but i don’t like folder view, so i do that “refresh” by switching Activities :slight_smile:

1 Like

Every time I get kernel updates, along with the VirtualBox host DKMS, I get the following;

( 1/15) Install DKMS modules
==> No kernel 4.11.11-1-MANJARO headers. You must install them to use DKMS!
==> No kernel 4.9.38-1-MANJARO headers. You must install them to use DKMS!
==> No kernel 4.11.11-1-MANJARO headers. You must install them to use DKMS!
==> No kernel 4.9.38-1-MANJARO headers. You must install them to use DKMS!

Is there a reason for this, or should I just ignore it?

Forum kindly sponsored by Bytemark