[Testing Update] 2017-05-04 - Plasma5, Gnome, VirtualBox, OpenSSL, ICU

Hi community,

it is again time to do another testing update. This one will be a little bigger than the usual updates. It took us longer to prepare this one, as we had to rebuild a lot of our packages due the given upstream changes made by Arch Linux.

We had several updates:

Please test and give us feedback as usual


Current supported Kernels

  • linux310 3.10.105
  • linux312 3.12.73
  • linux316 3.16.42
  • linux318 3.18.51
  • linux41 4.1.39
  • linux44 4.4.66
  • linux48 4.8.17 [EOL]
  • linux49 4.9.26
  • linux410 4.10.14
  • linux411 4.11.0
  • linux-RT-LTS 4.4.60_rt73
  • linux-RT 4.9.20_rt16

Package Updates (Thu May 4 10:21:56 CEST 2017)

  • testing community i686: 793 new and 785 removed package(s)
  • testing community x86_64: 803 new and 793 removed package(s)
  • testing core i686: 55 new and 51 removed package(s)
  • testing core x86_64: 55 new and 51 removed package(s)
  • testing extra i686: 695 new and 676 removed package(s)
  • testing extra x86_64: 695 new and 676 removed package(s)
  • testing multilib x86_64: 33 new and 31 removed package(s)

A detailed list of all changes can be found here.


  • No issues, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself. (Please post your solution)
  • Yes I am currently experiencing an issue due to the update. (Please post about it)

0 voters


Check if your mirror has already synced:

4 Likes

Most Steam apps which need OPENSSL_1.0.0 can by tricked by installing openssl-1.0-compat and/or lib32-openssl-1.0-compat from our repos.

Then either do:

LD_PRELOAD='/usr/$LIB/openssl-1.0-compat/' %command%

Or create symlinks to: /usr/lib{32}/openssl-1.0-compat/libssl.so.1.0.0 and /usr/lib{32}/openssl-1.0-compat/libcrypto.so.1.0.0 within for example ~/.steam/steam/steamapps/common/Tomb Raider/lib/i686/

i686

ln -sfv /usr/lib/openssl-1.0-compat/libssl.so.1.0.0 ~/.steam/steam/steamapps/common/Tomb Raider/lib/i686/libssl.so.1.0.0
ln -sfv /usr/lib/openssl-1.0-compat/libcrypto.so.1.0.0 ~/.steam/steam/steamapps/common/Tomb Raider/lib/i686/libcrypto.so.1.0.0

x86_64

ln -sfv /usr/lib32/openssl-1.0-compat/libssl.so.1.0.0 ~/.steam/steam/steamapps/common/Tomb Raider/lib/i686/libssl.so.1.0.0
ln -sfv /usr/lib32/openssl-1.0-compat/libcrypto.so.1.0.0 ~/.steam/steam/steamapps/common/Tomb Raider/lib/i686/libcrypto.so.1.0.0
1 Like

I updated my dell 7440 and it went ok until it got the vlc nightly the following error
updating vlc plugin cache: error: command terminated by signal 11 segmentation fault. So i rebooted the machine and now it won’t start. When rebooting it gives a failed to start NetworkManager

same to me…back to stable for now

Acer ao521, Lenovo x121e, xfce, no problems at all.

Updated today (HP Compaq 6005, Manjaro cinnamon) and no problems so far.

I just did the update on my Lenovo Thinkpad T410 and I didn’t install the network manager 1.8rc3 and the update went ok.

I’ve no issues with NetworkManager on my XFCE installation:

phil@manjaro /var/cache/manjaro-tools/iso/manjaro/xfce/17.0.2-pre1 $ pacman -Qi networkmanager
Name            : networkmanager
Version         : 1.8rc3+10+gddd6f94ab-1
Description     : Network connection manager and user applications
Architecture    : x86_64
URL             : https://wiki.gnome.org/Projects/NetworkManager
Licenses        : GPL2  LGPL2.1
Groups          : gnome
Provides        : None
Depends On      : libnm-glib  iproute2  polkit  wpa_supplicant  libsoup
                  libmm-glib  libnewt  libndp  libteam  curl  bluez-libs
Optional Deps   : dnsmasq: connection sharing [installed]
                  bluez: Bluetooth support [installed]
                  openresolv: resolvconf support [installed]
                  ppp: dialup connection support [installed]
                  dhclient: External DHCP client [installed]
                  modemmanager: cellular network support [installed]
Required By     : networkmanager-dispatcher-ntpd
Optional For    : blueman  firefox  geoclue  libproxy  packagekit
Conflicts With  : None
Replaces        : None
Installed Size  : 11.29 MiB
Packager        : Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
Build Date      : Fri Apr 21 23:34:47 2017
Install Date    : Mon Apr 24 23:48:40 2017
Install Reason  : Explicitly installed
Install Script  : No
Validated By    : Signature

So what is the issue you guys may have?

When I rebooted networkmanager failed to start. I would boot into another tty and login and I tried do sudo systemctl enable networkmanager and then I would start networkmanager but it would still fail. I ran systemctl status networkmanager.service and it wold say network manager failed to start code=exited status=127. No matter what I did it would not get network manager failed.

What the … a download:

Gesamtgröße des Downloads:           1145,28 MiB
Gesamtgröße der installierten Pakete:  3711,25 MiB
Größendifferenz der Aktualisierung:   102,52 MiB

Working here so far with Kernel 4.11:

  • networkmanager 1.8

  • amule

  • BOINC

  • VirtualBox
    with AMDGPU on Xfce.

    $ inxi -Fxzc0
    System: Host: manjaro Kernel: 4.11.0-1-MANJARO x86_64 (64 bit gcc: 6.3.1) Desktop: Xfce 4.12.3 (Gtk 2.24.31)
    Distro: Manjaro Linux
    Machine: Device: desktop System: Dell product: Precision WorkStation T3500
    Mobo: Dell model: 09KPNV v: A00 BIOS: Dell v: A17 date: 05/28/2013
    CPU: Hexa core Intel Xeon W3680 (-HT-MCP-) cache: 12288 KB
    flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 40019
    clock speeds: max: 3326 MHz 1: 1596 MHz 2: 1596 MHz 3: 1596 MHz 4: 1596 MHz 5: 1596 MHz 6: 1596 MHz
    Graphics: Card: Advanced Micro Devices [AMD/ATI] Bonaire XTX [Radeon R7 260X/360] bus-ID: 02:00.0
    Display Server: X.Org 1.19.3 drivers: amdgpu (unloaded: modesetting) Resolution: 2560x1440@59.95hz
    GLX Renderer: Gallium 0.4 on AMD BONAIRE (DRM 3.10.0 / 4.11.0-1-MANJARO, LLVM 4.0.0)
    GLX Version: 3.0 Mesa 17.0.5 Direct Rendering: Yes
    Audio: Card-1 Advanced Micro Devices [AMD/ATI] Tobago HDMI Audio [Radeon R7 360 / R9 360 OEM]
    driver: snd_hda_intel bus-ID: 02:00.1
    Card-2 Intel 82801JI (ICH10 Family) HD Audio Controller driver: snd_hda_intel bus-ID: 00:1b.0
    Sound: Advanced Linux Sound Architecture v: k4.11.0-1-MANJARO
    Network: Card: Broadcom Limited NetXtreme BCM5761 Gigabit Ethernet PCIe driver: tg3 v: 3.137 bus-ID: 05:00.0
    IF: enp5s0 state: up speed: 1000 Mbps duplex: full mac:
    Drives: HDD Total Size: 7065.4GB (55.7% used)
    ID-1: /dev/sda model: ADATA_SP900 size: 64.0GB
    ID-2: /dev/sdb model: ST3000VX000 size: 3000.6GB
    ID-3: /dev/sdc model: WDC_WD2003FYPS size: 2000.4GB
    ID-4: /dev/sdd model: WDC_WD2003FYPS size: 2000.4GB
    Partition: ID-1: / size: 48G used: 14G (28%) fs: btrfs dev: /dev/sda2
    ID-2: /boot size: 976M used: 174M (19%) fs: ext3 dev: /dev/sda1
    ID-3: /home size: 2.7T used: 1.2T (44%) fs: ext4 dev: /dev/sdb1
    ID-4: swap-1 size: 8.59GB used: 0.00GB (0%) fs: swap dev: /dev/sda3
    Sensors: System Temperatures: cpu: 25.0C mobo: N/A gpu: 35.0
    Fan Speeds (in rpm): cpu: N/A
    Info: Processes: 235 Uptime: 2 min Memory: 1046.8/12014.1MB Init: systemd Gcc sys: 6.3.1
    Client: Shell (bash 4.4.121) inxi: 2.3.8

ok tried again with a fresh install of manajro kde vm (no btrfs, no architect installer) and here it works…not a single issue…even with unstable it is fine…don’t knwo whats the difference here

Also have a Thinkpad. Did you achieve this by using the ignore package option in pacman.conf ?

Nah I just unchecked it in pamac

All went well with the update. I was hoping the cups-nosystemd update would fix my printing problem but it didn’t.

update went ok

People who want to try out fresh ISOs, I’d created some: XFCE, KDE, Gnome.

2 Likes

Ah I see. Never used Pamac before but I see it has that functionality compared to Octopi

thx phil…is btrfs as root better integrated in calamares?

I’ve instability problem, after this upgrade, that I never get before. The final result is always the same: file system unmounted and system blocked; its impossible also to start a tty: I’m able to open a tty session but no way to login.
The only solution is a hard power off.
Three episodes:

  1. connecting an external USB, system crashed
  2. while opening a txt file with kate
  3. while looking a movie with smplayer.

The system configuration is:

System:    Host: dark9402 Kernel: 4.10.14-1-MANJARO x86_64 (64 bit gcc: 6.3.1)
           Desktop: KDE Plasma 5.9.5 (Qt 5.8.0) dm: sddm,sddm Distro: Manjaro Linux                                                                      
Machine:   Device: portable System: Dell product: MP061 Chassis: type: 8                                                                                 
           Mobo: Dell model: 0YD479 BIOS: Dell v: A10 date: 08/26/2009                                                                                   
Battery    BAT0: charge: 66.0 Wh 130.8% condition: 50.5/66.0 Wh (76%) volts: 11.5/11.1                                                                   
           model: SMP DELLRD8 Li-ion serial: 1984 status: Full cycles: 0                                                                                 
CPU:       Dual core Intel Core2 T7600 (-MCP-) cache: 4096 KB flags: (lm nx sse sse2 sse3 ssse3 vmx) bmips: 9313                                         
           clock speeds: min/max: 1000/2333 MHz 1: 1000 MHz 2: 1000 MHz                                                                                  
Memory:    Using dmidecode: you must be root to run dmidecode                                                                                            
Graphics:  Card: NVIDIA G71M [GeForce Go 7950 GTX] bus-ID: 01:00.0 chip-ID: 10de:0297
           Display Server: N/A driver: nvidia Resolution: 153x45
Audio:     Card Intel NM10/ICH7 Family High Definition Audio Controller
           driver: snd_hda_intel bus-ID: 00:1b.0 chip-ID: 8086:27d8
           Sound: Advanced Linux Sound Architecture v: k4.10.14-1-MANJARO
Network:   Card: Broadcom Limited BCM4401-B0 100Base-TX driver: b44 v: 2.0 bus-ID: 03:00.0 chip-ID: 14e4:170c
           IF: eth0 state: down mac: 00:14:22:f3:fe:95
           WAN IP: 93.65.45.108 IF: eth0 ip-v4: N/A ip-v6: N/A
           IF: wlan0 ip-v4: 192.168.0.113 ip-v6: fe80::a354:d398:80f9:a2a6
Drives:    HDD Total Size: 1500.3GB (22.7% used)
           ID-1: /dev/sda model: HGST_HTS721010A9 size: 1000.2GB serial: JR1004D31KZ6MM
           ID-2: USB /dev/sdb model: 5AS size: 500.1GB serial: 5VEQYMRQ
           Optical: /dev/sr0 model: TSST DVD+-RW TS-L532B rev: DE04 dev-links: cdrom
           Features: speed: 24x multisession: yes audio: yes dvd: yes rw: cd-r,cd-rw,dvd-r state: running
Partition: ID-1: / size: 463G used: 314G (69%) fs: btrfs dev: /dev/dm-0
           label: MyCrypt2 uuid: 80551afd-aab2-4c19-aa46-c9d7b659b2b8
           ID-2: /boot size: 488M used: 78M (18%) fs: ext4 dev: /dev/sdb1
           label: N/A uuid: ff29e873-9b79-4d09-90bc-0565a08f9af2
           ID-3: swap-1 size: 3.43GB used: 0.00GB (0%) fs: swap dev: /dev/sdb3
           label: N/A uuid: 4d878faf-847e-48c9-9572-f7343a87bf1f
RAID:      No RAID data: /proc/mdstat missing-is md_mod kernel module loaded?
Unmounted: ID-1: /dev/sda1 size: 0.54G label: MyBoot1 uuid: c582c702-5a39-4d3a-b808-eac9a9e91316
           ID-2: /dev/sda2 size: 996.24G label: N/A uuid: c9174bd5-af4b-469c-a024-b936645027b5
           ID-3: /dev/sda3 size: 3.43G label: N/A uuid: 45cc644d-a0ce-407b-b067-bf9de8a3cb1c
           ID-4: /dev/sdb2 size: 496.14G label: N/A uuid: 8a16b31b-3bce-43d5-993e-0755af659087
Sensors:   System Temperatures: cpu: 43.0C mobo: N/A gpu: 0.0:52C
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 160 Uptime: 9 min Memory: 1013.1/3263.6MB
           Init: SysVinit v: 2.88 rc: OpenRC v: 0.25 runlevel: default default: 3 Gcc sys: 6.3.1
           Client: Shell (bash 4.4.121 running in konsole) inxi: 2.3.8

The glxinfo program… disappear:

[francesco@dark9402 ~]$ glxinfo
bash: glxinfo: command not found

mhwd command, another strange answer:

[francesco@dark9402 ~]$ mhwd -li
> Installed PCI configs:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
    video-nvidia-304xx            2017.03.12               false            PCI


Warning: No installed USB configs!

If some other info is needed, ask me, but when the system crash I can only press the power off button.

This is a test installation so, I can do… test if needed :slight_smile:

I went back and installed networkmanager and it seems to be working on the Thinkpad

1 Like

Forum kindly sponsored by