[Testing Update] 2017-03-17 - Deepin, KDE Framework, Haskell, Python, Kernels

update
testing

#1

Hi community,

with this update we have updated most of our Kernels, added the latest KDE framework, pushed out some more Deepin packages and renewed Python and Haskell.

The upgrade to ca-certificates-utils 20170307-1 requires manual intervention because a symlink which used to be generated post-install has been moved into the package proper. As deleting the symlink may leave you unable to download packages, perform this upgrade in three steps:

# pacman -Syuw                           # download packages
# rm /etc/ssl/certs/ca-certificates.crt  # remove conflicting file
# pacman -Su                             # perform upgrade

Please test and give us feedback as usual


Current supported Kernels

  • linux310 3.10.105
  • linux312 3.12.70
  • linux316 3.16.41
  • linux318 3.18.48 [EOL]
  • linux41 4.1.39
  • linux44 4.4.54
  • linux48 4.8.17 [EOL]
  • linux49 4.9.15
  • linux410 4.10.3
  • linux-RT-LTS 4.4.50_rt62
  • linux-RT 4.9.13_rt11

Package Updates (Fri Mar 17 08:15:08 CET 2017)

Upstream package changes

  • testing core x86_64: 11 new and 11 removed package(s)
  • testing core i686: 11 new and 11 removed package(s)
  • testing community i686: 342 new and 332 removed package(s)
  • testing multilib x86_64: 20 new and 19 removed package(s)
  • testing extra x86_64: 194 new and 195 removed package(s)
  • testing extra i686: 194 new and 195 removed package(s)
  • testing community x86_64: 345 new and 334 removed package(s)

Overlay package changes

  • testing community i686: 22 new and 19 removed package(s)
  • testing core x86_64: 10 new and 10 removed package(s)
  • testing core i686: 10 new and 10 removed package(s)
  • testing multilib x86_64: 4 new and 0 removed package(s)
  • testing extra i686: 80 new and 71 removed package(s)
  • testing extra x86_64: 80 new and 71 removed package(s)
  • testing community x86_64: 22 new and 19 removed package(s)

Detailed package changes can be viewed here.


  • No issues, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself. (Please post your solution)
  • Yes I am currently experiencing an issue due to the update. (Please post about it)

0 voters


Check if your mirror has already synced:


Can't access AUR after update
Installation with Manjaro-Architect ISO
[Stable Update] 2017-03-20 - Deepin, KDE Framework, Haskell, Python, Kernels
[Testing Update] 2017-03-12 - Pamac, OpenRC, Firefox, Thunderbird, KDE-Apps, Virtualbox
#2

so far so good.


#3

Worked well, following instructions.
It would be truly outstanding if those announcements were shown in pamac. Not for me, I check the forum fairly often, but for those who do not.

In any case thanks for the great work!
Cheers,


#4

I did it with

sudo pacman -Sy ca-certificates-utils --force
sudo pacman -Syu

But it’s sad that we can’t do anything to automate this. :disappointed_relieved:


#5

i agree.
this should be automated when these updates hit the stable branch.


#6

But how. The file will conflict, no matter what and we can not remove the file from the package. We also can not use the pre-upgrade script, because the conflict happens before the pre-upgrade ist running.

The only thing i can think of is to overlay the ca-certificates, create a new dependency with a name like ca-certificates-hotfix-20170307. Now that ca-certificates-hotfix-20170307 runs a script that asks if /etc/ssl/certs/ca-certificates.crt belongs to someone and if not just removes it.

Because this new package is set as dependency it wouls be installed prior the ca-certificates and there would be no conflict anymore. :thinking: It feels a bit overkill but right now i dont see any other option…


#7

it’s not the purpose of manjaro-system?..
hmm it would not solve the problem of “missing” ca-certificate to download all the other packages after manjaro-system run.


#8

Will that work? I mean manjaro-system will be upgraded before everything else in its own pacman run because of /etc/pacman.conf

Now when the manjaro-system update removes /etc/ssl/certs/ca-certificates.crt, is pacman still full functional or broken because of the now broken ca-certificates package? (I really dont know)


#9

just edited my post about that yes. :frowning: it will work if the user has at least one plain http mirror in his list. but it can’t be certified


#10

What would you think about something like this:

ca-certificates-hotfix-20170307

post_upgrade() {
    CONFLFILE="/etc/ssl/certs/ca-certificates.crt"

    pacman -Qo "${CONFLFILE}" &> /dev/null
    if [ ! $? -eq 0 ] && [ -f "${CONFLFILE}" ]
        then
            rm "${CONFLFILE}"
    fi
}
pkgname=ca-certificates-hotfix-20170307
pkgver=1
pkgrel=1
arch=('i686' 'x86_64')
pkgdesc="Hotfixes an update issue for ca-certificates 20170307"
license=('GPL2')
depends=('bash')
install=$pkgname.install
  1. This will added as pkg dependency to ca-certificates for this release of ca-certificates
  2. ca-certificates-hotfix-20170307 will be replaced by the next release of ca-certificates itself, so we’re clean again and ship not additional package anymore
  3. We can use the Archlinux package directly in 3 releases again

#11

No problems so far following the recommended steps on my XFCE/i3 system.


#12

I don’t understand this but if this fixes file conflicts this needs to be the default for all packs with conflicts. It is hard for me to understand why I have to run some commands by myself when I want to update the system.


#13

This is testing and I didn’t add a routine to manjaro-system yet. We will make it smooth for stable branch.


#14

I agree (for both pamac & octopi) that would be a huge streamlining improvement, so it would be possible to only open one application/process (in place of two) to see all important information in one place and complete the update.

When required, could the option to run a command like this be made to appear as part of the pacman command line process, similar to the AUR PKGBUILD y/n questions?


#15

Could not find [Testing Update] 2017-03-17 until after doing a search. deleted ca-certificates to get update via pacman to work, first time this has come up.
The rest is okay.


#16

Really glad I found this after getting back :slight_smile:
All’s well. Thanks for the heads-up !


#17

Testing Mate once again.
Follow the update instructions.
No problems at all.

Quad core AMD A8-3520M APU with Radeon HD Graphics
Kernel: 4.10.3-1-MANJARO x86_64
Display Server: X.Org 1.19.2 driver: radeon
Desktop: MATE 1.16.1 (Gtk 3.22.10)


#18

Did not check forum; issued pacaur -Syu; downloaded update; updater told me that ca-certificates.crt existed; pacaur asked me if I should nuke file; nuked file; finished update; everything seems ok.


#19

Hello together,

I did the update in 3 steps as in the first post.
Now I cant install any updates or packages from aur?
If i try to search for aur packages ocotopi crashes! After restart of ocotopi I can search for aur pacakges.
But when I want to install a package I get the error:

Fehler: Konnte Datei /var/lib/pacman/sync/extra.db nicht öffnen: Unrecognized archive format
Fehler: Konnte Datei /var/lib/pacman/sync/community.db nicht öffnen: Unrecognized archive format
Fehler: Konnte Datei /var/lib/pacman/sync/multilib.db nicht öffnen: Unrecognized archive format
Fehler: Ziel nicht gefunden: yasm

What ca I do?

Best regards,
Stefan


#20

Everything worked just fine. :slight_smile: