[Testing Update] 2017-01-11 - Python3.6, Mesa, Breath-themes, Kernels, Xorg 1.19

update
testing

#1

Hi community!

It’s about time for another testing update! :wink:
This time it took a little longer because of the update of Python to version 3.6. This resulted in a very long list of necessary rebuilds and several package issues needed to be spotted and fixed before it felt right to ship all this to the testing branch.

  • If you are still using infinality fonts, namely with Plasma 5, please pay special attention that the update to harfbuzz 1.4.1 is incompatible with infinality bundle. More information can be found here
    Also consider that meanwhile it might really not be necessary to keep infinality at all instead of configuring the improved native subpixel rendering of freetype2.

  • The update of python might require you to rebuild some AUR packages, which you can simply achieve by reinstalling them with yaourt.
    A good way to spot affected packages is to look in your directory /usr/lib/python3.5/site-packages which libraries are currently still installed in that location.
    You can also check that with pacman -Qo /usr/lib/python3.5/site-packages.
    After the rebuild of these packages those files will be moved to the python3.6 directory and all should be fine.

Apart from that I added cinnamon-sounds to our repos, which is a collection of the default Linuxmint system-sounds to be used in the next Manjaro Cinnamon release. So in case you feel like ‘mintifying’ your Mate or Cinnamon install a bit, go ahead and just install that package! :wink:
Some of our settings-packages also got updated while their maintainers are working on the upcoming 17.0 editions.
The new default KDE themes collection Breath, created again by @mcder3, was now completed with: plasma5-themes-breath, breath-wallpaper, breath-icon-theme , breath-dark-icon-theme and sddm-breath-theme.
Xreader has now added epub support.
Deepin-desktop received a bugfix and some more Deepin packages where updated.
And of course also some kernels have seen their next point releases: linux 4.4.41, linux 4.8.17, linux 4.9.2 and linux 4.10rc3


Current supported kernels

  • linux310 3.10.104
  • linux312 3.12.69
  • linux316 3.16.39
  • linux318 3.18.46
  • linux41 4.1.37
  • linux44 4.4.41
  • linux48 4.8.17 [EOL]
  • linux49 4.9.2
  • linux410 4.10-rc3
  • linux-RT-LTS 4.4.39_rt50
  • linux-RT 4.9_rt1

package overview

  • core i686: 27 new and 26 removed packages
  • core x86_64: 27 new and 26 removed packages
  • extra i686: 376 new and 400 removed packages
  • extra x86_64: 376 new and 400 removed packages
  • community i686: 1531 new and 1514 removed packages
  • community x86_64: 1570 new and 1555 removed packages
  • multilib x86_64: 29 new and 27 removed packages

The full list of package changes can be found here.

Please report your findings and any issues with this update as usual
your Manjaro Development Team

  • No issues, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself. (Please post your solution)
  • Yes I am currently experiencing an issue due to the update. (Please post about it)

0 voters


Terminus font name fix after freetype2 update to 2.7.1-1
Unable to launch DevedeNG [SOLVED]
#2
https://forum.manjaro.org/t/testing-update-2017-01-11-python-mesa-kernels-wine-calamares/15511?source_topic_id=15512

#3

Well, I should spend my time otherwise. :wink: Moved to trash:airplane: :ship: :palm_tree:


#4

@oberon I have the libraries of liblouis package (from extra repository) in /usr/lib/python3.5/site-packages even if I uninstall and install it again.

└──╼ pacman -Qo /usr/lib/python3.5/site-packages
/usr/lib/python3.5/site-packages/ is owned by liblouis 3.0.0-2.1

Maybe it should be to rebuilt in order to moved to the /python3.6/site-packages.


#5

Using

yaourt -S <package>

didnt work ?

try with

yaourt -S <package> --rebuild

…I’m still waiting on my update to finish :blush:


#6

We still need to develop our telepathy skills a little further, I guess … :stuck_out_tongue_winking_eye:


#7

Good for you, have a blast! :clap: :+1: :ocean: :sunny: :dolphin: :speedboat:


#8

I know the solution (I’m on unstable branch and I have already faced the “python issues” in previous days) but this package exists in the official repo (extra) not in the Aur and it should to rebuilt by a manjaro maintainer.


#9

@kouros17 and @cscs
Seems like liblouis is a packages we missed to rebuild.
yaourt -S does indeed rebuild packages from the AUR but this one is actually in our repos! :wink:
Stay tuned for another package update…


#10

Well …

/usr/lib/python3.5/site-packages/ is owned by liblouis 3.0.0-2.1
/usr/lib/python3.5/site-packages/ is owned by mugshot 0.3.1-2```

Is my remaining, and they persist even after reinstall/--rebuild 

Edit - Oh looks like 'Terminus' is now 'xos4 Terminus' so requires manual intervention or else defaults to crap

@kouros17 - oh gotchya ;-)

#11

Cool! One more :stuck_out_tongue_closed_eyes:


#12

liblouis and mugshot are fixed. (mugshot updated to 0.3.2 on this occacion :wink: )
The terminus-font thing is interesting @cscs. The font itself hasn’t even been updated, but fontconfig was… Where and how exactly do you set your terminal font?

btw: If someone has some spare time and inspiration … there are a bunch of avatars/logos in our mugshot package that still need to be updated to the latest icon-design… Feel free to clone or fork the avatar repo and play with those files in the faces-folder…! :blush:


#13

I confirm that liblouis is fixed! Thanks a lot oberon! :slight_smile:


#14

I use it across everything - terminal, windows, general - so in ‘appearance’ ‘window manager’ and terminal>Prefs … something else to note - terminal now doesnt match everything else
[general gui is using 8pt font but terminal must use 10 to match]


#15

This xos4-terminus is from XLFD:


Somehow it needs now to be renamed in GUI font settings. Confirming your issue.

Edit: Otherwise no issues on two machines.


#16

I was not able to figure out how this change was provoked. As I said terminus-font package itself is still the same - somehow it looks like an alias was working until now and isn’t any longer for whatever reason…


#17

I havent had a chance to look myself - but for now it didnt really ‘break’ terribly.

But my two packages above still remain where they were … is a full uninstall necessary ?


#18

You mean liblouis and mugshot? Not at all! Just install the update I just pushed - just might take a while until your mirror syncs and has liblouis-3.0.0-2.2 and mugshot-0.3.2-1 available for you! :slight_smile:


#19

System settings on KDE crash when going to Application Styles - Window decorations and then press All settings to go back.
I got a systemd-coredumb from KSystemlog http://pastebin.com/FtEJTmZT but i have no idea if it is related.
One more issue is when right-clicking an ogg file you get two amarok entries.


#20

All went fine except Terminus font as mentioned above.