[Testing Update] 2016-08-01 - RT-Kernels, Systemd, MSM, Calamares

I suppose it’s either the Nvidia or Mesa or both updates but my system still boots to a black screen after openrc loads. I had to revert back in order to get my system working again.

Well I’m not running OpenRC but I am on the Newest Nvidia drivers and it does load to the desktop it just takes… a bit longer now since systemd 231. Surprised actually that no one has said anything about it. Sits at the black screen and the Plymouth splash screen longer as well.

The Archpackage has been flagged out of date for ages. I can upload a temporary overlay later tonight.

Hm. I have no idea atm what the reason can be. Here everything works normally…

I’m grinding my gears with gsfonts 2016053-3 - the same version available at the Arch repo’s right now - Webfonts such as Nimbus are horribly rendered.

1 Like

Screenshot of Nimbus’ rendering (top: gsfonts 20150811-1 bottom: gsfonts 20160531-3)

1 Like

Maybe the reason is that 9 days ago gsfonts changed from type1 to otf format. See
https://git.archlinux.org/svntogit/packages.git/commit/?h=packages/gsfonts&id=9e39461f6747113319db57ac2e9c03a553e3cc54

nomacs 3.4 is in unstable repo now :slight_smile:

1 Like

So what can we do about these fonts’ rendering?

I’m not sure. There are several patches to freetype2. Maybe they will help. I know of Infinality
https://wiki.archlinux.org/index.php/Infinality
Ubuntu patch
https://aur.archlinux.org/packages/freetype2-ubuntu/
Cleartype patch
https://aur.archlinux.org/packages/freetype2-cleartype/
Yet some people say you don’t need any patches, you just need a good configuration of fontconfig. See


And
https://wiki.archlinux.org/index.php/Font_configuration
https://wiki.archlinux.org/index.php/Font_configuration/Examples

1 Like

I prefer not tweaking fontconfig neither freetype2.

All other TTF and OTF fonts are displayed in a pleaseant way with these fontconfig symlinks:

$ ls /etc/fonts/conf.d
10-hinting-full.conf                   49-sansserif.conf
10-scale-bitmap-fonts.conf             50-user.conf
20-unhint-small-dejavu-sans.conf       51-local.conf
20-unhint-small-dejavu-sans-mono.conf  60-latin.conf
20-unhint-small-dejavu-serif.conf      65-fonts-persian.conf
20-unhint-small-vera.conf              65-nonlatin.conf
30-metric-aliases.conf                 69-unifont.conf
30-urw-aliases.conf                    80-delicious.conf
40-nonlatin.conf                       90-synthetic.conf
45-latin.conf                          README

Optimal rendering for me is achieved with grayscale antialiasing and full hinting set on GNOME Tweak Tool… it’s just Nimbus Sans (alias for ‘Helvetica’ on the web) and other URW fonts that aren’t as well rendered in OTF format when compared to the Type1 format.

1 Like

Check if you have this package installed. If so, uninstall it.
xorg-fonts-75dpi
See
https://wiki.archlinux.org/index.php/Font_configuration#Font_problem_in_Generated_PDFs

1 Like

No I don’t have it.

:: Iniciando actualización completa del sistema…
advertencia: gtk2: la versión instalada (2.24.30+95+g876b5f7-1) es más nueva que extra (2.24.30-3)
advertencia: lib32-nvidia-utils: la versión instalada (1:367.35-1) es más nueva que multilib (1:364.19-1)
advertencia: linux44-nvidia: la versión instalada (1:367.35-3) es más nueva que extra (1:364.19-10)
advertencia: linux47-nvidia: la versión instalada (1:367.35-0.8) es más nueva que extra (1:364.19-0.7)
advertencia: mhwd-nvidia: la versión instalada (1:367.35-1) es más nueva que core (1:364.19-1)
advertencia: nvidia-utils: la versión instalada (1:367.35-1) es más nueva que extra (1:364.19-1)
advertencia: xf86-video-intel: la versión instalada (1:2.99.917+688+g49daf5d-0.1) es más nueva que extra (1:2.99.917+670+gcac7c8d-1)

so manjaro went back to nvidia 364?

I had to update testing for todays stable update. New packages will come when we have fixed the firefox-kde issue we currently have. Simply wait for the update.

1 Like

Well, as for gsfonts I made a PKGBUILD named ‘gsfonts-type1’ aimed for those who prefer the ‘old’ format and rending. I’m about to submit it to the AUR.

EDIT - first commit made :slight_smile:

2 Likes

Thanks mate. I’ve pinpointed the problem to compton. Strangely, i’ve used the same compton config for eons without problems in i3lock. I wonder what’s the glitch. Anyways, imma figure some out. It has to be due to opengl backend, xrender does fine with i3lock (but uses too much cpu as expected. Not to mention video tearing. Yuck!)

Cheers.

update : Apparently unredir-if-possible option was creating trouble. Disabling it helps.

after the update, if I put the laptop to sleep I cant connect to the wifi after that

Network: Card-1: Intel Wireless 7260 driver: iwlwifi bus-ID: 04:00.0
IF: wlp4s0 state: up mac:
Card-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
driver: r8168 v: 8.040.00-NAPI port: d000 bus-ID: 05:00.1
IF: enp5s0f1 state: down mac:

Please take a look at Wifi ceases to function after wake-up from suspend

Forum kindly sponsored by Bytemark