[Testing Update] 2016-06-28 - Manjaro-Tools, qt5-styleplugins, Deepin, Haskell

Seems with qt 5.7 some changes were made so gtk theming was broken. Follow our troubleshoots to fix it on your box. With this we also updated some haskell and deepin packages. Detailed changes can be found here.

Archlinux upstream fixes are now from: Tue Jun 28 07:49 CEST 2016.

Kind regards,
Philip Müller and the Manjaro Development Team


Troubleshoots

GTK3

With this we updated Gnome and GTK to 3.20. This will break most of the themes, which will be fixed if and when their developers decide to update them. Some GTK 3.20-compliant themes are ready now - see further down this post.

The new default Manjaro GTK theme, which is GTK 3.20 compatible, is Vertex-Maia

You can install it with:

sudo pacman -Sy vertex-maia-themes vertex-maia-icon-theme xcursor-maia

QT apps style with GTK

With QT 5.7 you need to install qt5-styleplugins and qt5ct and configure your system to have an unified look again. A followup on this can be found in our forum.

ufw

If you have issues with ufw not working anymore, you have to copy your custom rules to a different folder. Do it like this:

sudo cp -v /usr/lib/ufw/user.rules.pacsave /etc/ufw/user.rules
sudo cp -v /usr/lib/ufw/user6.rules.pacsave /etc/ufw/user6.rules

steam

Steam might not work due incompatiblity of libgpg. You my try followed command to “fix” it:

find ~/.steam/root/ \( -name "libgcc_s.so*" -o -name "libstdc++.so*" -o -name "libxcb.so*" -o -name "libgpg-error.so*" \) -print -delete
find ~/.local/share/Steam/ \( -name "libgcc_s.so*" -o -name "libstdc++.so*" -o -name "libxcb.so*" -o -name "libgpg-error.so*" \) -print -delete

Reference: Archlinux wiki



Did you experience any issue with this update?

  • No issues, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself. (Please post your solution)
  • Yes I am currently experiencing an issue due to the update. (Please post about it)

0 voters


Current supported kernels

  • Linux310 3.10.102
  • Linux312 3.12.61
  • Linux314 3.14.73
  • Linux316 3.16.36
  • Linux318 3.18.36
  • Linux319 3.19.8.22
  • Linux41 4.1.27
  • Linux42 4.2.8.12
  • Linux44 4.4.14
  • Linux45 4.5.7 [EOL]
  • Linux46 4.6.3
1 Like

I get a core dump when I try to select gtk2 in qt5ct:

(qt5ct:2053): GLib-GObject-WARNING **: cannot register existing type 'GdkDisplayManager'
(qt5ct:2053): GLib-CRITICAL **: g_once_init_leave: assertion 'result != 0' failed
(qt5ct:2053): GLib-GObject-CRITICAL **: g_object_new: assertion 'G_TYPE_IS_OBJECT (object_type)' failed
(qt5ct:2053): GLib-GObject-WARNING **: invalid (NULL) pointer instance
(qt5ct:2053): GLib-GObject-CRITICAL **: g_signal_connect_data: assertion 'G_TYPE_CHECK_INSTANCE (instance)' failed
(qt5ct:2053): GLib-GObject-WARNING **: invalid (NULL) pointer instance
(qt5ct:2053): GLib-GObject-CRITICAL **: g_signal_connect_data: assertion 'G_TYPE_CHECK_INSTANCE (instance)' failed
(qt5ct:2053): GLib-GObject-WARNING **: cannot register existing type 'GdkDisplay'
(qt5ct:2053): GLib-CRITICAL **: g_once_init_leave: assertion 'result != 0' failed
(qt5ct:2053): GLib-GObject-CRITICAL **: g_type_register_static: assertion 'parent_type > 0' failed
(qt5ct:2053): GLib-CRITICAL **: g_once_init_leave: assertion 'result != 0' failed
(qt5ct:2053): GLib-GObject-CRITICAL **: g_object_new: assertion 'G_TYPE_IS_OBJECT (object_type)' failed
zsh: segmentation fault (core dumped)  qt5ct````

Any idea?
Cheers,

try

sudo pacman -Sy qt5-styleplugins qt5ct
sudo nano /etc/environment

add the line

QT_QPA_PLATFORMTHEME=qt5ct

save and reboot. Now you should be able to use qt5ct.

Refer to

Hi @badbodh.
This issue is actually after having implemented all that.

You might need libgnomeui

rm -r ~/.config/qt5ct/*

restart X and try again.

@nadb @badbodh
Tried both proposed methods, no luck so far.

Other (awful) styles work.

Which theme do you use and which application is crashing on your end?

Hi @philm,

For GTK+ I use Arc.
According to qt5ct, I use fusion for qt, although not exactly fusion since the top bar of the applications is the same as the gtk ones. The highlight (which is not of the same blue) or the main part of the window are fusion’s and differ from the gtk theme: the highlight is not of the same blue and the main part of the window is not of the same white/cream.

http://imgur.com/avXP0f8

Only qt5ct is crashing, when I select gtk2 style.

Thanks for the help!

On Plasma 5 I installed and configured qt5-styleplugins without error. Is it enough both it needed? qt5ct is only an alternative as I read. If only one is needed, then which is the preferred package?

I just rebooted and had an issue with gtk-window-decorator not finding libmetacity-private.so.3
I downgraded metacity from 3.20 to 3.18 and now the decorator works.

According to pacman.log, metacity was upgraded on the 28/06.
[2016-06-28 19:03] [ALPM] upgraded metacity (3.18.4-1 -> 3.20.1-1)

qt5-styleplugins is normally enough. However it my crash so you install qt5ct to prevent it. There is no 100% guidance with it as qt 5.7 seems to have some issues depending on the used gtk theme. Therefore it is best to use a theme which provides native qt4 and qt5 theming, which results to have five themes installed :frowning:

Thanks. I ám using only the styleplugins and there is no issue só far with breeze theme.

I solved Manjaro Setting Manager problem with philms solution but MSM looks not good I gues we will wait for bug fixes.

@mgundogdu, what do you mean it doesn’t look good? Please check also here for your solution.

Hi @philm
Thanks for the heads up! However, the qt5ct crashes with all themes I have tried, including vertex-maia.
Cheers,

Did you try to open it with sudo rights? Try:

sudo qt5ct

It indeed does not crash with sudo rights. However it does not solve the problem since I do not usually launch the applications with sudo rights. They do display correctly if I do.

qt4 apps also work perfectly well.

please also check my commits for this on manjaro-tools: 1, 2.

sed -i '/QT_STYLE_OVERRIDE=gtk/d' /etc/environment echo "QT_QPA_PLATFORMTHEME=qt5ct" >> /etc/environment

Thanks @philm
Unfortunately, it was already the case. /etc/environment reads:

LANG=en_GB.UTF-8 BROWSER=/usr/bin/xdg-open QT_QPA_PLATFORMTHEME=qt5ct

Cheers,

Forum kindly sponsored by