Testing Manjaro 18 Illyria KDE

kde

#1

After having changed the XFCE edition into a KDE, I now have installed the full KDE version to my laptop.
Installation and setup went fine and now I am starting each and every program to see if it functions. So far I have found 1 issue:
K-Menu --> System --> Manage printing
This does not want to start. When started from terminal I see this:

/usr/bin/xdg-open http://localhost:631/
kf5.kio.widgets: KRun(0x555b39a0b710) ERROR (stat): 123   "Could not connect to host localhost: Connection refused."

The same error appears in a window. When I close the window I see this:

QXcbConnection: XCB error: 3 (BadWindow), sequence: 730, resource id: 41984104, major code: 40 (TranslateCoords), minor code: 0

Eighteen is running fine, even on my 7 year old laptop with a simple 2-core Pentium processor, Intel graphics and 4GB of RAM. (http://www.samsung.com/us/computer/pcs/NP-R730-JB02US-specs)

WiFi connects automatically, I’m using a terminal, a browser with 3 TAB’s open and Spotify is playing. No delays, no interruptions, just smooth sailing.
Will continue.


#2

systemctl status org.cups.cupsd


#3

Thank you @eugen-b, it was loaded but inactive. I enabled and started it and now when I open Manage printing I get the CUPS website.
Yesterday I was too fast with my report. It seems Wifi is not started automatically at boot. I have to do it manually.
That’s all I found so far.


#4

I had some troubles with Virtual Box installation, but was able to install on real HW.
Conversation here:


#5

I had the same the very first install I did with Illyria in a VM. In the installer I could choose the language but clicking next was not possible.
On real hardware it works great, no problems at all, with the exception of the wifi which does not automatically connect at boot.


#6

Fired up my desktop, which is running Manjaro 17 Unstable, this morning and I didn’t have a notification from Octopi about available updates so I started my update.sh script. Found out there were plenty of updates. Installed them and it all seems fine.

Just fired up my laptop with Manjaro Ilyria KDE and here I also had plenty of updates.
Seems fine since everything is working again after the update.

Question I have is this: what is the difference between 17.x unstable and 18.0 alpha unstable? I can see I use a newer kernel (4.17.0 right now) but what else is newer?

Regarding the wifi connection at boot:
when I just let it be for some seconds it will start after all. First I get a message saying it is deactivated because of missing credentials, then suddenly it is activated and it’s working. It even starts the VPN connection as well.
Great job.

What is also great is the amount if used HD space. I have (for testing purposes only) a / partition with integrated /home folder. Together, including software I have installed, it uses 8.07GB. My 128GB SSD is more than enough for this.


#7

Did some more testing: hibernate and suspend.
They both work, as well on external power as on battery. At restart they both start again where they left off, even the wifi is connected automatically although a bit late. The forum website wants to refresh already before the network is up.
I am using Spotify and it is restarted in Pause-mode so it needs a click on the play button to hear music again.

On battery mode I get a warning at 10% capacity left. Great. The screen dims as it should. But when I connect the charger:

  • I remain at the lower intensity of the screen. Shouldn’t it be back at the level which is set when using external power?
  • I still see the battery icon in the panel. Before I started using the battery the icon was not visible. Maybe it will disappear at 100% charged. We’ll see.

Are there any more tests which need to be done? I am using the alpha on my laptop for the second day now (desktop is off) and what I can see it all runs fine. Programs start (and stop), swap kicks in when memory is almost full, battery mode works, wifi starts (was there an update cause when I started testing it did not start automatically), hibernation and suspend work.
This is a release which could well be the new unstable, if not the new testing already. I think I will put it on my desktop tomorrow, will use it here one more day, so I can also use it with my Nvidia card. See if that makes a difference.


Development branch, but after upgrade, it showed Stable version
#8

Just looked at my Conky and saw that I am back in Hakoila, although it is 17.1.8:
Screenshot_20180415_151533

It used to be:
Screenshot_20180415_151613

There was an update today, maybe something in there did not get the new name yet.

Contents of /etc/lsb-release:
DISTRIB_ID=ManjaroLinux
DISTRIB_RELEASE=17.1.8
DISTRIB_CODENAME=Hakoila
DISTRIB_DESCRIPTION=“Manjaro Linux”


#9

Laptop Samsung R730 with build in camera which does not work.
A Logitech 831511-0000 wireless mouse and keyboard receiver which works as it should.
But as soon as I switch on the camera the mouse is frozen and laptop needs to be rebooted. Touchpad keeps working.

Camera:
|4/16/18 8:53 PM|kernel|Linux video capture interface: v2.00|
|---|---|---|
|4/16/18 8:53 PM|kernel|uvcvideo: Found UVC 1.00 device USB 2.0 PC Camera (1210:25f4)|
|4/16/18 8:53 PM|kernel|uvcvideo 1-1.4:1.0: Entity type for entity Processing 2 was not initialized!|
|4/16/18 8:53 PM|kernel|uvcvideo 1-1.4:1.0: Entity type for entity Extension 6 was not initialized!|
|4/16/18 8:53 PM|kernel|uvcvideo 1-1.4:1.0: Entity type for entity Camera 1 was not initialized!|
|4/16/18 8:53 PM|kernel|input: USB 2.0 PC Camera: WebCam SCB-0 as /devices/pci0000:00/0000:00:1a.0/usb1/1-1/1-1.4/1-1.4:1.0/input/input10|
|4/16/18 8:53 PM|kernel|usbcore: registered new interface driver uvcvideo|
|4/16/18 8:53 PM|kernel|USB Video Class driver (1.1.1)|

Camera has worked with other Linux installs, but don’t ask me which one. Laptop is used as testing machine so it has seen many distro’s.


#10

Just installed Clementine (the music player) using KDE’s Discover. I could do that without having to type my password. I wasn’t asked to give my credentials at all. I thought I had seen that before but wasn’t sure if I really did not type the password, this time however I am 100% sure.
How is this possible?


#11

The Gnome Disks program lets you format disks without root permissions as well. Can’t see how this is a safe practice either, but I guess the devs felt it was more user freindly. Go figure?


#12

I saw this behavior in Open Suse as well and there they replied: the program you install is from a secure source so it is okay. Bye Bye Opensuse


#13

I set the switch on the laptop lid to switch to suspend whenever I close the computer when it’s running on external power, hibernation when it’s battery mode.
This morning I closed the lid, when downstairs to get a cup of coffee and when I returned I opened the lid and pressed the power button. The screen came up almost instantly but was flashing in an un regular way. Nothing worked anymore, there was no mouse cursor, I could not use the keyboard so I just pressed the power button for 5 seconds to switch of the computer.
Booted again and once more closed the lid to see if I could repeat the situation. No, this time it worked as it should. Only difference was: this time I did not have coffee.
Looked in the log files to see if I could find something but nothing indicating this behavior. Now I’m not exactly sure what I have to look for so there might just as well be something written which I missed.

One other thing which also came up yesterday: this window:
Screenshot_20180429_063845
Why can I mark a tick box to remember my password when I obviously need root privileges? It’s like in Windows where you have to click the left mouse-button to become administrator. What’s with:
Linux is NOT Windows?
Please take away this tickbox and let us type the password whenever we do something with/to the system.


#14

That’s a KDE window, not Manjaro’s. You need to ask it upstream. Anyway, you can not tick it and always write the password.


#15

Yes, I know that. But what do people who just come from Windows do? They see the tickbox, ha that’s conveniant, I never have to type my password again. It gives a bad signal. I will however write a bugreport for the KDE devs. Thanks.


#16

If by ticking the box the window doesn’t appear any more that’s bad. If still asks you for confirmation not so much.


#17

I use Chromium as webbrowser and sometimes when scrolling through a long page I get pretty large black boxes covering parts of the page. When I continue scrolling they disappear, just to appear at a different part of the screen again.

Graphics:
  Card-1: Intel Core Processor Integrated Graphics driver: i915 
  v: kernel bus ID: 00:02.0 
  Display: x11 server: X.Org 1.19.6 driver: intel 
  unloaded: fbdev,modesetting,vesa tty: N/A 
  OpenGL: renderer: Mesa DRI Intel Ironlake Mobile v: 2.1 Mesa 18.0.3 
  direct render: Yes 

I have not been able to create a screenshot with them being visible, they just disappear when I open the screenshot utility.
I can’t be completely sure but if memory serves me right, they have been there since the start of using Illyria, or how it is called cause Conky still reads Hakoila as can be seen on the blue screenshots in post 7. Version has gone up to 17.1.10 in the mean time.


#18

After a long time I wanted to use my touchpad again, I normally use a mouse which for me works easier.
But the touchpad didn’t work. I went into the KDE settings and saw a message: No touchpad found.
I googled and found Touchpad Not Working which helped me.
I’m just curious why suddenly I missed a driver and had to copy a file over to the /etc directory to make it work again. I has worked before, maybe some update wrecked it.
Anyone else seen this as well?


#19

Just to revive this thread: what’s going on with Illyria KDE? On the Manjaro download page I see it’s still at alpha-1 while Xfce is at beta-2 already?

I do have a problem with my network connections. At the moment I use the wired connection because of interruptions from my access point for the wifi.
When I suspend and the next morning want to start again I get a message I have no connection. Right-clicking the network icon in the panel and choosing Configure Network connections I can’t even connect manually cause that option does not exist. I can only delete the connection. I then rebooted and now it does work with a manual connect, it did not do that automatically.
Just did another reboot and still no automatic connection to my wired connection.


#20

There is definitely something wrong with the wired connection and starting it again after either a suspend or a hibernation action: it doesn’t.
I have now deleted the wired connection and am back to wifi and this one just starts up fine after suspend and hibernation. It also starts the VPN automatically in both cases.

I have Hakoila unstable on my desktop computer and in there the wired connection does start after suspend.
So what can be wrong in Illyria? Or in my setup, but I did install it again last week and I face the same problems as with the first install.