Terminal not opening after updating Manjaro 9th Feb, 2021

Hi all,
Like many of you, I was also facing the issue of terminal not opening after recent update. I tried the solutions mentioned in this forum. Nothing worked. So, after trying many things, this worked.

  1. Edit /etc/locale.gen with sudo/root privileges and uncomment “en_US.UTF-8 UTF-8”
  2. Edit /etc/locale.conf and add/correct “LANG=en_US.UTF-8”
  3. Most importantly, as per the instructions in the /etc/locale.gen file’s comment section at the top, run the command “locale-gen” as sudo/root privileges to generate all the locales and placing them in /usr/lib/locale. (install another terminal app from add/remove programs, I used XTerm)

Restart(may not be required), and check.

I suffered a lot due to this I had to reinstall manjaro twice(first time because it was stuck while booting, second time because of update not working). Thanks to all the members who commented on this issue and a bit of reading the comments :wink: , I could solve my problem and am posting this to help someone who has the same problem.


That’s Marvelous. Now you can probably mark this as Solved, by selecting your first post as the Solution. You can do this by clicking the following button at the end of your first post.


This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.