Terminal glitching and not displaying correctly

Hi community, I Just reinstalled Manjaro GNOME and now IDK why the terminal is glitched. Its not displaying correctly. I’m Including a picture shot from my phone. Screenshot not capturing this issue correctly. The screenshot :- https://paste.pics/d505c516d884ba11b3876a114f23ba91
I cant type any commands to the gnome terminal because of this. I some how managed to download terminator.

This is my inxi --admin --verbosity=7 --filter --no-host --width output

 Kernel: 5.13.11-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0 
 parameters: BOOT_IMAGE=/boot/vmlinuz-5.13-x86_64 
 root=UUID=fb88264c-bada-458a-8670-2d80303c4ac3 rw quiet splash apparmor=1 
 security=apparmor udev.log_priority=3 
 Desktop: GNOME 40.3 tk: GTK 3.24.30 wm: gnome-shell dm: GDM 40.1 
 Distro: Manjaro Linux base: Arch Linux 
 Type: Laptop System: HP product: HP Notebook v: Type1ProductConfigId 
 serial: <filter> Chassis: type: 10 serial: <filter> 
 Mobo: HP model: 80CB v: 99.53 serial: <filter> UEFI: Insyde v: F.28 
 date: 05/17/2019 
 ID-1: BAT1 charge: 32.6 Wh (93.9%) condition: 34.7/34.8 Wh (99.5%) 
 volts: 15.7 min: 14.6 model: 131-42-6E HS04041 type: Unknown 
 serial: <filter> status: Discharging 
 RAM: total: 6.73 GiB used: 1.75 GiB (25.9%) 
 RAM Report: permissions: Unable to run dmidecode. Root privileges required. 
 Info: Quad Core model: AMD A8-7410 APU with AMD Radeon R5 Graphics bits: 64 
 type: MCP arch: Puma family: 16 (22) model-id: 30 (48) stepping: 1 
 microcode: 7030106 cache: L2: 2 MiB bogomips: 17575 
 Speed: 1133 MHz min/max: 1000/2200 MHz boost: enabled Core speeds (MHz): 
 1: 1133 2: 1120 3: 2131 4: 1035 
 Flags: 3dnowprefetch abm acc_power aes aperfmperf apic arat avx bmi1 bpext 
 clflush cmov cmp_legacy constant_tsc cpb cpuid cr8_legacy cx16 cx8 de 
 decodeassists extapic extd_apicid f16c flushbyasid fpu fxsr fxsr_opt ht 
 hw_pstate ibpb ibs lahf_lm lbrv lm mca mce misalignsse mmx mmxext monitor 
 movbe msr mtrr nonstop_tsc nopl npt nrip_save nx osvw overflow_recov pae pat 
 pausefilter pclmulqdq pdpe1gb perfctr_llc perfctr_nb pfthreshold pge pni 
 popcnt pse pse36 ptsc rdtscp rep_good sep skinit ssbd sse sse2 sse4_1 sse4_2 
 sse4a ssse3 svm svm_lock syscall topoext tsc tsc_scale vme vmmcall wdt xsave 
 Vulnerabilities: Type: itlb_multihit status: Not affected 
 Type: l1tf status: Not affected 
 Type: mds status: Not affected 
 Type: meltdown status: Not affected 
 Type: spec_store_bypass 
 mitigation: Speculative Store Bypass disabled via prctl and seccomp 
 Type: spectre_v1 
 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
 Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, STIBP: 
 disabled, RSB filling 
 Type: srbds status: Not affected 
 Type: tsx_async_abort status: Not affected 
 Device-1: AMD Mullins [Radeon R4/R5 Graphics] vendor: Hewlett-Packard 
 driver: radeon v: kernel alternate: amdgpu bus-ID: 00:01.0 
 chip-ID: 1002:9851 class-ID: 0300 
 Device-2: Cheng Uei Precision Industry (Foxlink) HP Truevision HD type: USB 
 driver: uvcvideo bus-ID: 2-1.1:3 chip-ID: 05c8:0382 class-ID: 0e02 
 Display: wayland server: X.org 1.20.13 compositor: gnome-shell driver: 
 loaded: radeon note: n/a (using device driver) - try sudo/root display-ID: 0 
 resolution: <missing: xdpyinfo> 
 OpenGL: renderer: AMD KABINI (DRM 2.50.0 5.13.11-1-MANJARO LLVM 12.0.1) 
 v: 4.5 Mesa 21.1.6 direct render: Yes 
 Device-1: AMD Kabini HDMI/DP Audio vendor: Hewlett-Packard 
 driver: snd_hda_intel v: kernel bus-ID: 00:01.1 chip-ID: 1002:9840 
 class-ID: 0403 
 Device-2: AMD FCH Azalia vendor: Hewlett-Packard driver: snd_hda_intel 
 v: kernel bus-ID: 00:14.2 chip-ID: 1022:780d class-ID: 0403 
 Sound Server-1: ALSA v: k5.13.11-1-MANJARO running: yes 
 Sound Server-2: JACK v: 1.9.19 running: no 
 Sound Server-3: PulseAudio v: 15.0 running: yes 
 Sound Server-4: PipeWire v: 0.3.33 running: yes 
 Device-1: Broadcom BCM43142 802.11b/g/n vendor: Hewlett-Packard driver: wl 
 v: kernel modules: bcma port: 3100 bus-ID: 02:00.0 chip-ID: 14e4:4365 
 class-ID: 0280 
 IF: wlo1 state: up mac: <filter> 
 IP v4: <filter> type: dynamic noprefixroute scope: global 
 broadcast: <filter> 
 IP v6: <filter> type: noprefixroute scope: link 
 Device-2: Realtek RTL810xE PCI Express Fast Ethernet vendor: Hewlett-Packard 
 driver: r8169 v: kernel port: 2000 bus-ID: 03:00.0 chip-ID: 10ec:8136 
 class-ID: 0200 
 IF: enp3s0 state: down mac: <filter> 
 WAN IP: <filter> 
 Device-1: Broadcom BCM43142A0 Bluetooth 4.0 type: USB driver: btusb v: 0.8 
 bus-ID: 1-1.4:3 chip-ID: 0a5c:216d class-ID: fe01 serial: <filter> 
 Report: rfkill ID: hci0 rfk-id: 1 state: up address: see --recommends 
 Message: No logical block device data found. 
 Message: No RAID data found. 
 Local Storage: total: 931.51 GiB used: 10.07 GiB (1.1%) 
 SMART Message: Required tool smartctl not installed. Check --recommends 
 ID-1: /dev/sda maj-min: 8:0 vendor: Toshiba model: MQ01ABD100 
 size: 931.51 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s 
 type: HDD rpm: 5400 serial: <filter> rev: 2C scheme: GPT 
 Optical-1: /dev/sr0 vendor: hp model: DVDRW GUB0N rev: UB00 dev-links: cdrom 
 Features: speed: 24 multisession: yes audio: yes dvd: yes 
 rw: cd-r,cd-rw,dvd-r,dvd-ram state: running 
 ID-1: / raw-size: 40 GiB size: 39.08 GiB (97.69%) used: 9.45 GiB (24.2%) 
 fs: ext4 dev: /dev/sda8 maj-min: 8:8 label: N/A 
 uuid: fb88264c-bada-458a-8670-2d80303c4ac3 
 ID-2: /boot/efi raw-size: 1 GiB size: 1022.6 MiB (99.80%) 
 used: 716 KiB (0.1%) fs: vfat dev: /dev/sda7 maj-min: 8:7 label: LINUX BOOT 
 uuid: DDC2-1009 
 ID-3: /home raw-size: 55 GiB size: 53.83 GiB (97.88%) used: 638.9 MiB (1.2%) 
 fs: ext4 dev: /dev/sda10 maj-min: 8:10 label: N/A 
 uuid: baa24be4-b39f-4f75-a23e-20f038f0554b 
 Kernel: swappiness: 60 (default) cache-pressure: 100 (default) 
 ID-1: swap-1 type: partition size: 4 GiB used: 0 KiB (0.0%) priority: -2 
 dev: /dev/sda9 maj-min: 8:9 label: N/A 
 uuid: 609b3532-d196-41bc-8fbe-61eee3798317 
 ID-1: /dev/sda1 maj-min: 8:1 size: 100 MiB fs: vfat label: N/A 
 uuid: 849C-2EA9 
 ID-2: /dev/sda11 maj-min: 8:11 size: 30 GiB fs: btrfs label: N/A 
 uuid: 4ce2af81-c549-4816-b2ea-b81702e8faa6 
 ID-3: /dev/sda2 maj-min: 8:2 size: 16 MiB fs: <superuser required> 
 label: N/A uuid: N/A 
 ID-4: /dev/sda3 maj-min: 8:3 size: 146 GiB fs: ntfs label: N/A 
 uuid: 92F09F36F09F2011 
 ID-5: /dev/sda4 maj-min: 8:4 size: 508 MiB fs: ntfs label: N/A 
 uuid: 3C2AA7DB2AA79086 
 ID-6: /dev/sda5 maj-min: 8:5 size: 381 GiB fs: ntfs label: Gaming 
 uuid: 6C38EEE738EEAEF0 
 ID-7: /dev/sda6 maj-min: 8:6 size: 273.9 GiB fs: ntfs label: Others 
 uuid: B0CAF063CAF0276E 
 Hub-1: 1-0:1 info: Full speed (or root) Hub ports: 2 rev: 2.0 
 speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900 
 Hub-2: 1-1:2 info: Advanced Micro Devices Root Hub ports: 4 rev: 2.0 
 speed: 480 Mb/s power: 100mA chip-ID: 0438:7900 class-ID: 0900 
 Device-1: 1-1.4:3 info: Broadcom BCM43142A0 Bluetooth 4.0 type: Bluetooth 
 driver: btusb interfaces: 4 rev: 2.0 speed: 12 Mb/s chip-ID: 0a5c:216d 
 class-ID: fe01 serial: <filter> 
 Hub-3: 2-0:1 info: Full speed (or root) Hub ports: 2 rev: 2.0 
 speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900 
 Hub-4: 2-1:2 info: Advanced Micro Devices Root Hub ports: 4 rev: 2.0 
 speed: 480 Mb/s power: 100mA chip-ID: 0438:7900 class-ID: 0900 
 Device-1: 2-1.1:3 
 info: Cheng Uei Precision Industry (Foxlink) HP Truevision HD type: Video 
 driver: uvcvideo interfaces: 2 rev: 2.0 speed: 480 Mb/s power: 500mA 
 chip-ID: 05c8:0382 class-ID: 0e02 
 Hub-5: 3-0:1 info: Full speed (or root) Hub ports: 2 rev: 2.0 
 speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900 
 Device-1: 3-1:2 info: Logitech Unifying Receiver type: Keyboard,Mouse 
 driver: logitech-djreceiver,usbhid interfaces: 2 rev: 2.0 speed: 12 Mb/s 
 power: 98mA chip-ID: 046d:c534 class-ID: 0301 
 Device-2: 3-2:3 info: China Resource Semico Keyboard type: Keyboard,HID 
 driver: hid-generic,usbhid interfaces: 2 rev: 1.1 speed: 1.5 Mb/s 
 power: 98mA chip-ID: 1a2c:2124 class-ID: 0300 
 Hub-6: 4-0:1 info: Full speed (or root) Hub ports: 2 rev: 3.0 speed: 5 Gb/s 
 chip-ID: 1d6b:0003 class-ID: 0900 
 System Temperatures: cpu: 43.0 C mobo: 20.0 C gpu: radeon temp: 40.0 C 
 Fan Speeds (RPM): N/A 
 Processes: 224 Uptime: 7m wakeups: 2 Init: systemd v: 248 tool: systemctl 
 Compilers: gcc: N/A Packages: 1141 pacman: 1132 lib: 298 flatpak: 4 snap: 5 
 Shell: Zsh v: 5.8 running-in: terminator inxi: 3.3.06 ```
1 Like

:+1: Welcome to Manjaro! :+1:

  1. Please read this:
    How to provide good information
    and press the three dots below your post and press the :pencil2: to give us more information so we can see what’s really going on.
    Now we know the symptom of the disease, but we need some more probing to know where the origin lies… :grin:
  2. An inxi --admin --verbosity=7 --filter --no-host --width would be the minimum required information for us to be able to help you. (Personally Identifiable Information like serial numbers and MAC addresses will be filtered out by the above command)
    Also, please copy-paste that output in-between 3 backticks ``` at the beginning and end of the code/text.


Done editing :grin:. What should i do to fix this issue :slightly_smiling_face:.

1 Like
  1. Is there a compelling reason for you to be on 5.13?
  2. Firrmware looks rather old. Have you tries upgrading yet?
  3. Does this also happen when you create a new user and log in there? (E.G. shervin2)


1 Like

I’m new to linux :sweat_smile: .

  1. I don’t know what that means :slightly_smiling_face:
  2. I tried sudo pacman -Syu. But there is no updates available
  3. Ohh it worked. No probs in terminal if i use a new user account.
    I don’t know why terminal is like that in the main user. Is there any way to reset gnome terminal ? I tried pacman -R gnome-terminal. And reinstalling it through Terminator with sudo pacman -S gnome-terminal. But nothing changed

What the heck :joy:. I added a new user. Then signed out and signed in to the main user and opened terminal. Its working perfectly. I dont know whats going on :joy:.

So if everything works fine on a newly created user, you messed up your profile and if you don’t know what you did, we certainly don’t either :joy: and finding out which exact setting you changed is going to take weeks if not months, therefore, we’re going to do the following:

  • Verify that the new user has access to the same groups as your old one by executing groups and comparing the output of both users.

    groups twitty
    groups twitty2

    (Where obviously, twitty is your old user and twitty2 is your new one.)
    E.G. if twitty is a member of operator and twitty2 isn’t, execute:

    usermod --append --groups operator twitty2
  • Copy all data files from your old profile into your new one

    cp --verbose --recursive --preserve=timestamps /home/twitty/Documents/* /home/twitty2/Documents/

    If that worked and you had no errors, remove the documents from your old user:

    rm --recursive /home/twitty/Documents/*

    repeat for:

    • Pictures
    • Videos
    • Music
    • .thunderbird
    • .mozilla/firefox/
    • Templates, and everything else that is important to you.
    • Linux games like Battle of Wesnoth have their game data stored under ~/.local/share/ E.G. ~/.local/share/wesnoth/
  • After everything has been copied over, disable the old user so you cannot accidentally log on to it any more:

     usermod --lock twitty
  • If you would have theming or other customisations going on, don’t do everything in one day but do this at the rate of 1 application / theme / … per day and if the same issue crops up again, roll back your last change and thus you’ve now pinpointed the exact setting that made your old user misbehave. :thinking:

  • in 1 month delete the entire home directory of your old user, but don’t delete the user itself so that in 6 months time files still owned by that user will still show up under its username.

  • If you ever migrate to a new machine, just don’t migrate the old user: only the new one.

  • From now on, start making backups so you can roll back and never have to do this again:

  • also please read this as you seem to be new to Linux:


Result after running groups shervin

wheel audio input lp storage users network power shervin

Result after running groups shervinj

wheel shervinj

Result for usermod --append --groups operator shervinj

usermod: group 'operator' does not exist

I’ll copy those necessary data mentioned above from old user to new user one by one :grin: and backup so that i can roll back if i did anything stupid. WIll read that tutorial forum :grinning_face_with_smiling_eyes: . Thanks for helping me Fabby sir. Thankyou very much. :kissing_heart: .


  1. Never post screenshots of text!
  2. Even if screenshots of text are easier than posting text only rule #1 applies
  3. Taking a picture of your screen with a camera is by definition a screenshot so rule #1 applies as well!
  4. Post text instead of screenshots so the person responding to you can copy-paste that text.
  5. You have no operator group on your system!
  6. shervin is a member of other groups that shervinj is not a member of!
    (see your own screenshot)
  7. use these groups with usermod --append --groups


P.S. Can you notice I don’t like screenshots??? :grin:
If not, please read this:

1 Like

Sure waiting for your reply

1 Like

OK, go ahead now.

1 Like
  1. Oh sorry for that . I’ll never do that again
  2. I apologize for that
  3. Oh ok
  4. Sure
  5. :thinking:. oh
  6. Yes
  7. ok :grinning_face_with_smiling_eyes:.
1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.