Tearing prevention "off" option missing

There was an option in Compositor section to turn off Tearing prevention, but after the last update it is gone. Is there a way to bring it back?


That’s odd, I have the Tearing prevention (vsync) option, currently running Plasma v. 5.21.1 and have not ever noticed it disappear with any of my updates. I have an Intel HD 620 graphics with i915 driver. What graphics and driver are you using?

Yes, Tearing prevention feature is there, but what’s missing after the last update is the option of turning it off. Now there is only “Auto”, “Only when cheap” and other two options, but not “Off”.

Sorry, misunderstood your post. It looks like this option was removed due to the changes in compositing scheduling: platforms/x11: Always set swap interval to 1. You may be able to disable vsync in your driver, e.g. for Intel: Intel Graphics Arch Wiki (Disable Vsync). If there are issues you are facing with the compositor changes, it might be worth looking for an upstream bug report and add yourself to the list (or filing if not already present).

1 Like

The info on the Intel Graphics Arch Wiki (Disable Vsync) link is working for me. No problems anymore. Thanks!

(Side note: when a KDE developer –I presume– says something “doesn’t make sense now” on invent.kde.org page it’s a signal, at least for me, to change the desktop environment)

No problem, glad that helped!

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.