Tearing after updatinng today

I just did a system update today and now my screen is tearing a lot.
I have a Ryzen 3000 APU.

I’m using Manjaro with KDE Plasma.

Any one have anything I can try to solve the problem?

I noticed KDE removed the disable option of its internal Vsync setting. Maybe try to look into this if you can set other options for Vsync and reboot to see if it fixes anything. System Settings ->Display and Monitor → Compositor Also check if you have the proper refresh rate in → Display Configuration

Thanks omano.
In the compositor I changed “Latency” to “Prefer smoother animations” and that looks to have fixed the issue.

hrmm it seems that changing the settings only works as a temporary fix… after a while the problem seems to come back. I"m not sure if this is caused by screen saver or reboot or both.

Did you try the setting I suggested? the VSYNC.

Yeah I tried all the different vsync options, and none of them gave a working permanent solution

Maybe try a different kernel?

5.10 or 5.11, preferably 5.11 as it had a lot of AMD fixes.

There is a chance there there was regression in the current kernel version you’re using.

I upgraded to 5.11 and the problem still persists :frowning:

Try System Settings ->Display and Monitor → Compositor: XRender as engine. At least it helped me a bit with nvidia and nouveau.

thanks for the idea, but changing the render engine also didnt help. I tried all the options including xrender

You probably need to configure your video then in your xorg config file and add some Vsync/tearfree options there, as explained in the various wiki/forum pages about that.


I managed to get it working and put a script here:

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.