Teamviewer-beta 13, "Not ready, please check connection"


#1

I have searched and read the forum but im stuck.

Iv installed teamviewer-beta-13.0.6634-1 form AUR but when i run it it says
Screenshot_20180104_104146

I have tried TV 12 but that dont even start the GUI.

I removed everything teamviewer from the system and rebooted, re-installed TV13 but its the same.

Starting from terminal i get

greg@greg-pc ~/Downloads $ teamviewer 
Init...
CheckCPU: SSE2 support: yes
Checking setup...
Launching TeamViewer ...
Starting network process (no daemon)
Network process already started (or error)
Launching TeamViewer GUI ...

Not sure if that means the daemon is not running (and should be) or what it means really ?

Anyhow, Im aware they are going through a big change atm but what they have so far does work on all my other KDE distros on this laptop atm without messing about.

Any suggestions ?

Network:   Card-1: Intel Wireless 3165 driver: iwlwifi
           IF: wlp1s0 state: up mac: xxxxxxxx:b2:df:e5
System:    Host: greg-pc Kernel: 4.14.10-2-MANJARO x86_64 bits: 64 Desktop: KDE Plasma 5.11.4
           Distro: Manjaro Linux
Machine:   Device: laptop System: Dell product: Inspiron 5767 serial: N/A
           Mobo: Dell model: 03XWWJ v: A00 serial: N/A UEFI [Legacy]: Dell v: 1.0.0 date: 07/14/2016

TeamViewer can not connect internet
#2

This implies something went wrong. Did you run the setup part or start the teamviewerd service?


#3

setup part? teamviewerd service ? i have not had to deal with these things before , please explain. thx.


#4

Check the comments on AUR.

https://aur.archlinux.org/packages/teamviewer-beta/

“I finally got it all working. On one machine (Antergos) it said “No connection.” Settings refused to save. The tgz did work so I switched the PKGBUILD to rpm and fixed that one. On another (Arch) that didn’t show a GUI I found that a greeter is required. startx and startxfce4 from a text login does not work. systemctl enable --now lightdm also doesn’t work. The system must boot to the greeter.”


#6

ah found it (i think) https://www.randomhacks.co.uk/the-teamviewer-daemon-is-not-running-please-start-the-daemon-ubuntu/

sudo teamviewer --daemon enable

then run teamviewer

So far so good but will the daemon start at boot , i shall give it a go in a minute.

EDIT:- yep that works after a reboot, thx for the help people.


#7

If you check the PKGBUILD file you’ll see it installs a system service for you, so the “systemd” way would have been:

systemctl enable teamviewerd
systemctl start teamviewerd

or, if you want to run the daemon only when you need it, just

systemctl start teamviewerd

TeamViewer can not connect internet
#8

ye cheers i was just reading about the use of systemctl :slight_smile: , lots of learning.


#9

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.