Teamviewer 12 GUI not starting


#1

I’m using Manjaro 17.05 xfce.

Teamviewer used to work fine on my machine. Now, I’ve got the latest version 12 installed on 2 machines and neither of them startup or give any error messages at all.

terminal output when trying to start teamviewer from command line below.

Can anyone help?

Thanks


[test@test-pc etc]$ teamviewer

Init…
CheckCPU: SSE2 support: yes
Checking setup…
Launching TeamViewer …
Starting network process (no daemon)
terminate called without an active exception
/opt/teamviewer/tv_bin/script/tvw_exec: line 40: 25649 Aborted (core dumped) “$TV_BIN_DIR/teamviewerd” -n -f
Network process already started (or error)
Launching TeamViewer GUI …
**[test@test-pc etc]$ **
[test@test-pc etc]$ teamviewer -daemon start

systemctl start teamviewerd.service
Failed to start teamviewerd.service: Unit teamviewerd.service not found.
fail

Try with root / sudo ?

[test@test-pc etc]$ sudo teamviewer -daemon start
**[sudo] password for test: **

systemctl start teamviewerd.service
Failed to start teamviewerd.service: Unit teamviewerd.service not found.
fail

[test@test-pc etc]$


#2

This is worrying.
Can you see if you have the file /usr/lib/systemd/system/teamviewerd.service. If you don’t, try re-installing teamviewer.

PS: Remember that Teamviewer does not work with freetype2 2.8.1.


#3

I’ve resolved the daemon not starting by reloading the daemon. I had previously uninstalled and installed different versions, but none of them were working.

I’ve also searched for anything with teamviewer and deleted it, hoping this might reset things, but all its done is remove the menu icon for Teamviewer 12 (although Teamviewer 11 menu icon still shows).

The problem on both of my machines is that the ‘teamviewer’ command results in the output at the end below. Everything starts, then shuts off after GUI is attempted.

Regarding freetype2 2.8.1, I can see I have this installed. Is it the update of this that stopped teamviewer working? If so, how do I resolve? Just uninstall or replace?

Thanks

=================================

[test@test-pc etc]$ sudo teamviewer -daemon start

systemctl start teamviewerd.service
Failed to start teamviewerd.service: Unit teamviewerd.service not found.
fail

[test@test-pc etc]$ systemctl daemon-reload
[test@test-pc etc]$ sudo teamviewer -daemon start

systemctl start teamviewerd.service

[test@test-pc etc]$ teamviewer

Init…
CheckCPU: SSE2 support: yes
Checking setup…
Launching TeamViewer …
Launching TeamViewer GUI …
[test@test-pc etc]$


#4

Just downgrade freetype2 as it is instructed by the link @strit provided.
This solved it for me.
The easy way is with downgrade (if it is not installed use pamac or pacman to install it, I mean downgrade)


#5

The issue is that changes were made to freetype2 that required changes in wine (which allows running Windows programs in linux). The wine package was updated also, but Teamviewer comes with its own older version of wine, and this won’t work with the newer freetype2.

To get Teamviewer working again you should only need to downgrade lib32-freetype2 to version 2.8-2 (and reboot). Then add it to IgnorePkg in pacman.conf. I’m guessing that wouldn’t affect too many other applications, so it’s probably the easiest solution.

The package is available here: https://archive.archlinux.org/packages/l/lib32-freetype2/lib32-freetype2-2.8-2-x86_64.pkg.tar.xz. (For 32-bit, it’s probably the freetype2 package: https://archive.archlinux.org/packages/f/freetype2/freetype2-2.8-2-i686.pkg.tar.xz)

Another option is just to provide the lib32-freetype2 2.8-2 libs to Teamviewer by extracting them from the package and putting them in /opt/teamviewer/tv_bin/wine/lib.

EDIT: A commenter on the AUR page has provided a PKGBUILD that includes the proper freetype2 libs for Teamviewer, without requiring any other packages to be downgraded or held back. So it will probably get fixed properly soon. I tested the new PKGBUILD and it seems to work correctly. The package is available here if anyone wants it now and isn’t comfortable building it (64-bit): teamviewer-12.0.85001-7


Teamviewer 12 ne lance plus
Teamviewer package conflict
La problem update
#6

following error when I tried using downgrade. Still a newbie on linux, so pls spell out any solution. thanks.

[adminuser@adminuser-pc ~]$ sudo downgrade lib32-freetype2
**[sudo] password for adminuser: **
Branch = stable
Downgrading from A.L.A. is disabled on the stable branch. See https://wiki.archlinux.org/index.php/downgrading_packages for more details.


#7

You can’t use downgrade on Manjaro. You need to do it the manual way.


#8

it’s possible to use downgrade on manjaro… I just think that you need to change config file (or declare a environment variable I don’t remember as I’m on unstable) if you’re on stable branche…

And to be sure that the package originally come from arch if you have to use the arch archive server to downlad the package (“remote” in downgrade)


#9

Yes, you can’t use downgrade when on the stable branch. But you can download the package and install with sudo pacman -U [packagename] (or you might be able to simply right-click on the package and choose Software Install, depending on what desktop environment you’re using).


#10

downloaded package for 64bit linked above.
https://archive.archlinux.org/packages/l/lib32-freetype2/lib32-freetype2-2.8-2-x86_64.pkg.tar.xz

right clicked and installed in xfce manjaro 17.05

software installer confirmed it was downgrading

checked pamac and it shows lib32-freetype2 as v2.8-2
freetyp2 is still v2.8.1-1

same result below.

**[adminuser@adminuser-pc ~]$ teamviewer **

Init…
CheckCPU: SSE2 support: yes
Checking setup…
Launching TeamViewer …
Launching TeamViewer GUI …
[adminuser@adminuser-pc ~]$


#11

Did you reboot? I had the same problem and even restart teamviewerd did not helped. After a reboot everything worked.


#12

worked on reboot.

perfect.

thanks


#13

You’re going to need to add that package to pacman’s IgnorePkg, or it will update again the next time you update your other packages. You should be able to do this with Pamac (your package manager). In Preferences, under the General tab, there’s “Ignore upgrades for:”. Click the plus sign and choose the lib32-freetype2 package from the list.

This package is only used for 32-bit programs, so holding it back shouldn’t affect much on a 64-bit system.


#14

slightly off topic:
If your use case allows you to, you could consider using vnc instead of teamviewer.
I did that right now, cause teamviewer repeatedly gave me some troubles under manjaro, every few months.
For my none professional use case, vnc is totally fine.
Check it out. Maybe it works for you, too.


#15

cimarronline - thanks. done via pamac

maxf - I’ll check it out, especially if free. Which variant are you using. there’s so many out there. Just want a reliable free one for remote control, and sometimes file transfer - preferably with list of multiple pc’s I can connect to. thx


#16

This is not something VNC can do.
Unless the protocol got a huge update, and is now login based.


#17

I switched to vnc literally yesterday. So, I didn’t dive into it very deep yet.
Decided to use x11vnc and TigerVNC - both in the manjaro repo
The options seem to be very limited, as Strit mentioned already.
Good enough for me, though…


#18

For the record, you can use downgrade in Manjaro to easily downgrade to an older version you have in pacman’s cache.
The same way you return to the newer version if you had previously downgraded.


#19

Doesn’t the stable policies restrict you from downgrading? Thats the message I got when I tried to use downgrade. Although, I probably didn’t have any previous versions in the cache.

maxf - I just tried ‘anydesk’, which I’ll probably use from now on. Its just as easy to use as teamviewer and a bit faster I think. It also provides a fixed alias to work with, even with changing IP address of target. I think VNC requires you to update if the target IP changes.


#20

Thanks for your help!!!
Your’re amazing =)