Task manager pinned apps fly/gone off on next restart/resume/logout

Reproducing:

  • apply Pin to Task manager action on any app in taskbar. Until I’m in this session the app is pinned
  • make logout/suspend-resume/restart and see that the pinned apps are gone from the pinned list of the taskbar

$ inxi -GS
System:
  Host: roman-pc Kernel: 6.9.2-1-MANJARO arch: x86_64 bits: 64
  Desktop: KDE Plasma v: 6.0.5 Distro: Manjaro Linux
Graphics:
  Device-1: Intel CoffeeLake-H GT2 [UHD Graphics 630] driver: i915 v: kernel
  Device-2: NVIDIA GP106M [GeForce GTX 1060 Mobile] driver: nvidia v: 550.78
  Device-3: Realtek Integrated Webcam driver: uvcvideo type: USB
  Display: x11 server: X.Org v: 21.1.13 with: Xwayland v: 24.1.0 driver: X:
    loaded: modesetting,nvidia dri: iris gpu: i915,nvidia,nvidia-nvswitch
    resolution: 1: 1920x1080~60Hz 2: N/A
  API: EGL v: 1.5 drivers: iris,nvidia,swrast
    platforms: x11,surfaceless,device
  API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: intel mesa v: 24.0.8-manjaro1.1
    renderer: Mesa Intel UHD Graphics 630 (CFL GT2)
  API: Vulkan v: 1.3.279 drivers: nvidia,intel surfaces: xcb,xlib
1 Like

Go to System SettingsSessionDesktop Session and make sure that Session Restore: Start with an empty session is not selected.

I typically have When session was manually saved selected.

I got “On last logout” there

Well, I don’t know then. The session seemed the most likely.
Someone else might have some better insight.

Cheers.

do your Pin and then change to When session was manually saved and restart using the button shown

Cannot reproduce.

I also start with an empty session.

Are all the files in ~./config, ~/.local/share and ~/.cache owned by you and writable?

Yes

seems to have one file non-writable (among those 3 folders):

$ find ~/.local/share/ ! -perm /222
/home/roman/.local/share/mime/packages/Override.xml

Hmm, that’s a directory I do not have on my system. Probably related to something you’ve installed, so I don’t have any idea what it is, what it does, or whether it has anything to do with the phenomenon you’re seeing. :face_with_raised_eyebrow:

I guess it’s for mime-types description for different apps.
For the mentioned file the contents (typical part of it) looks as:

$ head -20 ~/.local/share/mime/packages/Override.xml 
<?xml version='1.0' encoding='utf-8'?>
<mime-info xmlns="http://www.freedesktop.org/standards/shared-mime-info">
        <mime-type type="application/wps-office.doc">
                <comment>Microsoft Word</comment>
                <sub-class-of type="application/msword"/>
                <sub-class-of type="application/vnd.ms-word"/>
                <sub-class-of type="application/vnd.openxmlformats-officedocument.wordprocessingml.document"/>
                <sub-class-of type="application/x-msword"/>
                <sub-class-of type="application/vnd.ms-word.document.macroenabled.12"/>
                <generic-icon name="wps-office-doc"/>
                <glob pattern="*.doc" weight="100"/>
                <glob pattern="*.docm" weight="100"/>
                <glob pattern="*.rtf" weight="100"/>
        </mime-type>
        <mime-type type="application/wps-office.dot">
                <comment>Microsoft Word Template</comment>
                <sub-class-of type="application/msword-template"/>
                <sub-class-of type="application/vnd.openxmlformats-officedocument.wordprocessingml.document"/>
                <sub-class-of type="application/vnd.ms-word.template.macroenabled.12"/>
                <sub-class-of type="application/msword"/>
...

Yesterday I’ve confirmed the recent update packages, but the issue with pinned apps is not gone.

I have this same issue. To reproduce it, every time:

  • apply Pin to Task Manager on any app in the icons-only task manager (or most other actions, such as rearranging apps, for that matter)
  • restart to find pinned apps are gone
$ inxi -GS
System:
  Host: pango Kernel: 6.9.3-3-MANJARO arch: x86_64 bits: 64
  Desktop: KDE Plasma v: 6.0.5 Distro: Manjaro Linux
Graphics:
  Device-1: AMD Phoenix1 driver: amdgpu v: kernel
  Device-2: Chicony ACER QHD User Facing driver: hid-generic,usbhid,uvcvideo
    type: USB
  Display: x11 server: X.Org v: 21.1.13 with: Xwayland v: 24.1.0 driver: X:
    loaded: modesetting dri: radeonsi gpu: amdgpu s-res: 2880x1800
    resolution: 2880x1800
  API: EGL v: 1.5 drivers: radeonsi,swrast platforms: x11,surfaceless,device
  API: OpenGL v: 4.6 compat-v: 4.5 vendor: amd mesa v: 24.0.9-manjaro1.1
    renderer: AMD Radeon Graphics (radeonsi gfx1103_r1 LLVM 17.0.6 DRM 3.57
    6.9.3-3-MANJARO)
  API: Vulkan Message: No Vulkan data available.

This has been a problem since updating to Plasma 6. My Desktop Setting is set to Start with empty session, but that was also never a problem before the update. (My understanding is that this should not be an issue, unless something has drastically changed since Plasma 5.)

The .config, .local/share/, and .cache folders and their contents are all writeable.

I did manage to pin a few applications that have since stuck when I was using a Wayland session. I can’t exactly remember what I did, but I will play around with that to see if it makes a difference. (I’m avoiding Wayland because it’s still buggy.) I will also check if logging out and in again does anything, as that was a workaround to KDE setting problems in the past. Is it possible there’s a file or folder missing in the X session that appears in Wayland? Could someone please point me to where I can look?

Thanks in advance for any help :smiling_face:

EDIT:

I tried logging out/in, and it worked! On a hunch, I thought the problem may have to do with my using the shutdown -r command to restart, so I also tried using the restart button in the launcher menu. That also worked! So as long as I restart the “normal” way it seems it will be find (I tested it twice).

Can anyone explain what’s going on there? I like to use the shutdown commands to restart and poweroff my laptop as it’s faster and gives me the option to delay the command. It was also never a problem in the past. I’m guessing restarting through the menu simply saves settings in a way that using the command doesn’t, but I don’t know how.

Anyway, hope this helps someone.

(Not going to bother testing the Wayland thing I mentioned as logging out/in was likely what happened there.)

It was a bug when a restart or shutdown is not managed by systemd or when you don’t have Plasma’s systemd session launch integration, fixed in 6.1.