Target not found: python-faust-cchardet....libpamac?

I cannot update anything, or add any software.

I have searched posts with similar problems. The solutions offered did not work.

From reading other posts, it appears that libpamac error causes target not found errors.

this is not related to python-faust-cchardet

But how do I work around libpamac? It seems to block changing

sudo pacman -Syu

If there are errors … then share them.

1 Like

You might be confusing some paid support channel of a big company with a forum run pretty much by volunteers in the free time. The main difference is, that here the “client” is not a client and not always right. That means, here, nobody will waste his time to ask you countless questions, because the current “i tried something and nothing worked” does not mean anything. Here, It is expected to provide at least a minimal information yourself. Let me paraphrase it for you:

Better still… :arrow_down:

sudo pacman-mirrors -f 5 && sudo pacman -Syyu


Debatable …
Why people insist on such a short mirrorlist query (possibly resulting in far mirrors), as well as the forced refresh unnecessarily is beyond me.

I might say what would be ‘better’ is to point directly at pamac-gtk and libpamac, thereby insuring they dont have a foreign version and it gets updated in sync with the repos …

… but with the little information provided, an initial ‘basic’ update to see what happens was more my intent.

It’s because most newbies don’t have the patience to wait for the whole mirror list to be polled.

It’s that genetic defect in homo sapiens computeriensis nubius, you know? :crazy_face:

Well, the “target not found” is usually — not always but usually — the result of a not yet synced mirror.

So let the OP first refresh their mirror list and use the vastly superior pacman over pamac, and then we’ll take it from there. :wink:

1 Like

OK, but we’ve also established that in modern pacman ‘yy’ being required is a far edge case, while the use of it is a burden on the servers that multiplies with the users employing it.
(IE - it probably shouldnt be the first common recommendation)

It is recommended in the man page after updating the mirrors.

what man page?
man pacman

       -y, --refresh
           Download a fresh copy of the master package database from the server(s) defined in pacman.conf(5). This should
           typically be used each time you use --sysupgrade or -u. Passing two --refresh or -y flags will force a refresh
           of all package databases, even if they appear to be up-to-date.

If you are instead referring to some wiki article then I would daresay it is simply dated.

… ah found it in the man pacman-mirrors, and what I said still applies.

I used to say the same thing … times change.
That man page and some perceptions apparently have not.

Thank you so much.

This solved the problem.

sudo pacman-mirrors -f 5 && sudo pacman -Syyu

Much appreciated.

Thank you very much.

This worked.

Really appreciate your help.

1 Like

And without you performing the first suggestion or providing any output we will still never know if it was actually a mirror or sync issue.
( which is somewhat applicable in the first case because you amorphously referred to ‘trying other things that didnt work’ … and we would probably expect a simple mirror sort and update to be among the basic steps of ‘trying things in other threads’ … while it is possible that simply using pacman [without aur support] alone was enough to skirt the problem … and blah … enjoy the spoons )

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.