Target not found: bazel024 while installing software

Hi All,

Suddenly, I am not able to install any application or run manjaro updates, when I do, I get installation error [ “target not found: bazel024” ] and installation stops.

I have tried research this error and found there is bazel024 software online, I downloaded and installed it (hoping its a needed dependency) via command prompt:
[sudo sh]
This installed version [community/bazel 4.2.0-2]

But still getting the same error. I am unable to install any application or update manjaro. My manjaro PC works fine with the exception of this issue.

Please any help to resolve this issue will be appreciated.

Manjaro version:
64-bit Version
Kernel Linux 5.12.19-1-MANJARO x86_64
MATE 1.26.0

Thank you

Hi All,

I decided to reboot my PC to see if any difference and indeed there were change. After restarting my PC, I was able to installation software without errors and my manjaro installation updates completed successfully without errors.

I will assume the installation of [sudo sh] resolved the problem.

Hope this helps someone else.

Thank you.

That’s a legacy unmaintained AUR (Arch User Repository) package. bazel is in the community repo and it’s only required for building software, not a runtime dependency.

No, it did not as Pacman does not know about it. Avoid installing things directly to the system as you will eventually have conflicting files when something is installed from Add/Remove Software or Pacman.


Please read this:

Especially the section How to install software on Manjaro? and then follow the author’s instructions to uninstall the software you just installed and install from the community repo’s instead.