Takes minutes to show desktop on startup

#1

Hi,
I'm more-or-less new in Linux and Manjaro, and I have slightly weird issue with Manjaro XFCE - it takes 2-3 minutes to startup (until it shows desktop).

It does not show any errors or notifications - only a blank screen until it fully boots up. After it boots up it works superb - everything's fast, no issues etc.

The laptop specs are fine - i5 520m, 4GB DDR3, SSD, Intel graphics card. Everything works fine with Manjaro after boot up. When I had Windows in this machine, it took less than 30 seconds for Windows 10 to startup, so it's not a hardware issue.

And it's not some third party software issue (I use Skype, Dropbox) - it takes the same time to boot on a clean install without any additional software.

Any ideas?

Here's what systemd-analyze blame shows:
944ms lvm2-monitor.service
858ms dev-sda1.device
833ms systemd-logind.service
753ms lightdm.service
482ms systemd-timesyncd.service
454ms systemd-udevd.service
448ms ModemManager.service
333ms systemd-journald.service
314ms tlp.service
295ms upower.service
294ms polkit.service
220ms systemd-journal-flush.service
190ms udisks2.service
151ms NetworkManager.service
131ms user@1000.service
112ms avahi-daemon.service
108ms systemd-udev-trigger.service
99ms systemd-rfkill.service
70ms bluetooth.service
43ms grub-boot-indeterminate.service
41ms systemd-tmpfiles-setup-dev.service
39ms systemd-tmpfiles-setup.service
36ms systemd-modules-load.service

inxi -Fxxxz
System:
Host: tomas-pc Kernel: 5.0.5-1-MANJARO x86_64 bits: 64 compiler: gcc
v: 8.2.1 Desktop: Xfce 4.13.3git-UNKNOWN tk: Gtk 3.24.7 info: xfce4-panel
wm: xfwm4 dm: LightDM 1.28.0 Distro: Manjaro Linux
Machine:
Type: Laptop System: FUJITSU product: LIFEBOOK S760 v: 10601155991
serial: Chassis: type: 10 v: LIFEBOOK S760 serial:
Mobo: FUJITSU model: FJNB20A v: C3 serial:
BIOS: FUJITSU // Phoenix v: Version 1.13 date: 05/06/2010
Battery:
ID-1: CMB1 charge: 62.6 Wh condition: 62.6/62.6 Wh (100%) volts: 12.0/10.8
model: Fujitsu CP293550-01 type: Li-ion serial:
status: Discharging
CPU:
Topology: Dual Core model: Intel Core i5 M 520 bits: 64 type: MT MCP
arch: Nehalem rev: 2 L2 cache: 3072 KiB
flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 19157
Speed: 1463 MHz min/max: 1199/2400 MHz boost: enabled Core speeds (MHz):
1: 1363 2: 1471 3: 1453 4: 1466
Graphics:
Device-1: Intel Core Processor Integrated Graphics
vendor: Fujitsu Limited. driver: i915 v: kernel bus ID: 00:02.0
chip ID: 8086:0046
Display: x11 server: X.Org 1.20.4 driver: intel unloaded: modesetting
alternate: fbdev,vesa resolution: 1366x768~60Hz
OpenGL: renderer: Mesa DRI Intel Ironlake Mobile v: 2.1 Mesa 19.0.1
direct render: Yes
Audio:
Device-1: Intel 5 Series/3400 Series High Definition Audio
vendor: Fujitsu Limited. driver: snd_hda_intel v: kernel bus ID: 00:1b.0
chip ID: 8086:3b56
Sound Server: ALSA v: k5.0.5-1-MANJARO
Network:
Device-1: Intel 82577LM Gigabit Network vendor: Fujitsu Limited.
driver: e1000e v: 3.2.6-k port: 1840 bus ID: 00:19.0 chip ID: 8086:10ea
IF: enp0s25 state: down mac:
Device-2: Qualcomm Atheros AR9287 Wireless Network Adapter
vendor: Fujitsu Limited. driver: ath9k v: kernel port: 18a0
bus ID: 10:00.0 chip ID: 168c:002e
IF: wlp16s0 state: up mac:
Drives:
Local Storage: total: 111.79 GiB used: 16.96 GiB (15.2%)
ID-1: /dev/sda vendor: A-Data model: SU700 size: 111.79 GiB
speed: 3.0 Gb/s serial: rev: 428a scheme: MBR
Partition:
ID-1: / size: 109.53 GiB used: 16.96 GiB (15.5%) fs: ext4 dev: /dev/sda1
Sensors:
System Temperatures: cpu: 52.0 C mobo: N/A
Fan Speeds (RPM): N/A
Info:
Processes: 193 Uptime: 1m Memory: 3.65 GiB used: 983.5 MiB (26.3%)
Init: systemd v: 241 Compilers: gcc: 8.2.1 Shell: bash v: 5.0.2
running in: xfce4-terminal inxi: 3.0.32

Thanks!

P.S. The stunning thing is that the same laptop works up to 2 hours on battery in Windows 10, but on Manjaro it runs for 3 hours with ease! Same workflow, same software.

1 Like

#2

Please use code tags for the inxi output (the </> icon).

On topic:
Maybe your computer has difficult in gathering enough entropy for the RNG.
You can try installing haveged and start it with systemctl enable haveged.

You can also look at the output of e.g. dmesg -HL | grep -i random which might show how much time it needed to initialise the RNG.

Also, you might want to use kernel 4.19. The newest kernel is not always the best, especially for older hardware.

3 Likes

#3

As addition to the above:

Maybe you can mask that service if you are not using LVM

sudo systemctl stop lvm2-monitor && sudo systemctl mask lvm2-monitor

also

sudo systemctl stop ModemManager && sudo systemctl mask ModemManager

Run those commands from terminal and reboot after that.

0 Likes

#4

Thanks, this made a trick!

0 Likes