T490 & Hybrid USB-C dock

Hi everyone,

I’m looking for a bit of guidance on how to get my dock working. I see that the dock itself is connecting and I am able to use it as a hub. However, it doesn’t seem to want to output to the secondary display via HDMI. I’m wondering if anyone has had this issue.

I’ve also tried to list the thunderbolt information through boltctl or tbtadm, neither of these display any information. I’m not sure what I’m doing wrong as I’ve followed the arch wiki on ThinkPad docks.

Any help or suggestions would be greatly appreciated. Also to note, I’ve tried Ubuntu as a test and could not seem to get it to work there either. I’m currently on Windows to test and can confirm there is no issue with the dock.


:+1: Welcome to Manjaro! :+1:

  1. Please read this:
    How to provide good information
    and post some more information so we can see what’s really going on. Now we know the symptom of the disease, but we need some more probing to know where the origin lies…
  2. An inxi --admin --verbosity=7 --filter --no-host --width would be the minimum required information… (Personally Identifiable Information like serial numbers and MAC addresses will be filtered out by the above command)
    Also, please copy-paste that output in-between 3 backticks ``` at the beginning and end of the code/text.


P.S. If you enter a bit more details in your profile, we can also see which Desktop Environment you’re using, which CPU/GPU or Kernel, … you have without typing it every time