T440s problems..i need help!

i have never learned anything about computers or anything of that sort. about a year ago my t440s thinkpad started acting weird and suddenly couldn’t find ‘/boot/vmlinuz-5.15-x86_64’. i’ve tried almost everything, typing the code back in, whatever sudo commands i found on a thread multiple times, and watching videos…nothing worked? i called customer support for not much help at all…someone please help!!

Welcome to the forum!

Usually this is the result of an incomplete/interrupted update procedure. During the update process, the old kernel images are removed, and only at the end of the update process are the new kernel images written to /boot and is the boot loader updated.

The other possibility, if you have not interrupted the update procedure, is that the internal drive has begun failing. Whether it’s an HDD or an SSD, this sort of thing does happen. But given the error message, I suspect we’re dealing with an interrupted update.

My advice would be to download the latest Manjaro .iso here, put it on a USB stick in the proper manner — Ventoy is a great way of creating bootable USB sticks, and it’s available for Windows too, if that is what you’re currently using — and to then boot up from it and repair your system.

The procedure is not difficult. Boot up from the USB stick in live mode, and once the desktop has loaded, open up a terminal window. In this window, issue the following commands… :arrow_down:

sudo su -
manjaro-chroot -a
[ -f /var/lib/pacman/db.lck ] && rm -f /var/lib/pacman/db.lck
pacman-mirrors -f
pacman -Syyu
update-grub
exit

Be sure to let all of the above commands take their time and finish. When prompted for the replacement of certain packages, answer Y.

After that, reboot your machine and remove the USB stick.