Systemupgrade von Manjaro 19.1.1 bleibt hängen

Hallo,
vielleicht kann mir jemand helfen. Das upgrade funktioniert nicht wegen ungültigem oder beschädigtem Paket: Was kann ich tun?

[hildegard@ManjaroGNOME ~]$ sudo pacman -Syu
:: Synchronisiere Paketdatenbanken...
core ist aktuell
extra ist aktuell
community ist aktuell
multilib ist aktuell
:: Starte vollständige Systemaktualisierung...
Warnung: fontconfig: Lokale Version (2:2.13.1+12+g5f5ec56-2) ist neuer als extra (2:2.13.1+12+g5f5ec56-1)
:: ilmbase durch extra/openexr ersetzen? [J/n] IgnorePkg=fontconfig
Löse Abhängigkeiten auf...
Suche nach in Konflikt stehenden Paketen...
:: openexr und ilmbase stehen miteinander in Konflikt. ilmbase entfernen? [j/N] j
Warnung: Abhängigkeits-Zyklus entdeckt:
Warnung: libglvnd wird vor seiner Abhängigkeit mesa installiert werden
Warnung: Abhängigkeits-Zyklus entdeckt:
Warnung: lib32-mesa wird vor seiner Abhängigkeit lib32-libglvnd installiert werden

Pakete (124) appstream-glib-0.7.16-2 archlinux-appstream-data-20191027-1
aspell-0.60.8-1 bleachbit-3.0-1 btrfs-progs-5.3.1-0
ca-certificates-mozilla-3.47-1 cronie-1.5.4-3 cups-2.3.0-4
expac-9-2 expat-2.2.9-1 filesystem-2019.10-3 firefox-70.0-1.1
gcr-3.34.0-1 ghostscript-9.50-1 glib2-2.62.2-1
gnome-notes-3.34.1-1 gnome-online-accounts-3.34.1-1
gnome-screenshot-3.34.0-1 gnome-shell-1:3.34.1+5+g072a9a484-1
gnome-shell-extension-appindicator-30-1
gnome-shell-extension-arc-menu-36.0+dev+2+gd687897-1
gnome-shell-extension-gsconnect-27-2 gst-plugins-bad-1.16.1-2
gtk-update-icon-cache-1:3.24.12+32+g39e28ab933-1
gtk3-1:3.24.12+32+g39e28ab933-1 gtkmm3-3.24.2-1 hexchat-2.14.2-4
hplip-1:3.19.8-2 ilmbase-2.3.0-1 [Entferne]
imagemagick-7.0.8.68-2 jbig2dec-0.17-1 jre8-openjdk-8.u232-1
jre8-openjdk-headless-8.u232-1 kauth-5.63.0-1
kcoreaddons-5.63.0-1 kitemmodels-5.63.0-1 kwindowsystem-5.63.0-1
lib32-glib2-2.62.2-1 lib32-libdrm-2.4.100-1
lib32-libglvnd-1.2.0-3 lib32-lm_sensors-3.6.0-1
lib32-mesa-19.2.2-1 lib32-mesa-vdpau-19.2.2-1 lib32-nspr-4.23-1
lib32-nss-3.47-1 lib32-pango-1:1.44.7-1 lib32-systemd-242.153-1
lib32-vulkan-intel-19.2.2-1 lib32-vulkan-radeon-19.2.2-1
libblockdev-2.23-1 libcups-2.3.0-4 libdrm-2.4.100-1
libglvnd-1.2.0-5 libinput-1.14.2-1 librsvg-2:2.46.3-1
libssh-0.9.1-1 libtommath-1.2.0-1 libva-mesa-driver-19.2.2-1
libxkbcommon-0.9.1-1 libxkbcommon-x11-0.9.1-1
licenses-20191011-1 linux-firmware-20191022.2b016af-1
linux419-4.19.80-1 linux419-r8168-8.047.04-6 linux53-5.3.7-2
linux53-r8168-8.047.04-7 lm_sensors-3.6.0-1 lollypop-1.2.2-1
lsb-release-1.4-13 man-db-2.9.0-1
manjaro-gdm-branding-20191024-1 manjaro-gnome-assets-20191025-1
manjaro-gnome-extension-settings-18.0-20191024-1
manjaro-gnome-settings-18.0-20191025-2 manjaro-icons-20191015-1
manjaro-release-18.1.2-1 mesa-19.2.2-1 mesa-vdpau-19.2.2-1
mhwd-db-0.6.3-13 mhwd-nvidia-440xx-440.26-1
mutter-3.34.1+26+gc0037305e-1 nspr-4.23-1 nss-3.47-1
openexr-2.4.0-4 pacman-5.2.0-2 pamac-cli-9.0.2-1
pamac-common-9.0.2-1 pamac-gtk-9.0.2-1 pango-1:1.44.7-1
python-cairo-1.18.2-1 python-pikepdf-1.6.5-1
python-pillow-6.2.0-1 python-urllib3-1.25.6-1 python2-2.7.17-1
python2-cairo-1.18.2-1 python2-gobject-3.34.0-1 qpdf-9.0.2-1
readline-8.0.001-1 steam-manjaro-1.0.0.61-7 sudo-1.8.28.p1-1
systemd-242.153-1 systemd-libs-242.153-1
systemd-sysvcompat-242.153-1 texinfo-6.7-1 thunderbird-68.2.0-1
thunderbird-i18n-de-68.2.0-1 thunderbird-i18n-en-us-68.2.0-1
tslib-1.21-1 twolame-0.4.0-1 unrar-1:5.8.3-1
vulkan-icd-loader-1.1.126-1 vulkan-intel-19.2.2-1
vulkan-radeon-19.2.2-1 wallpapers-2018-1.1-1
xdg-desktop-portal-1.5.1-1 xdg-utils-1.1.3+18+g0547886-2
xf86-video-amdgpu-19.1.0-1 xf86-video-ati-1:19.1.0-1
xkeyboard-config-2.28-1 xmlsec-1.2.29-1 xorg-server-1.20.5-4.1
xorg-server-common-1.20.5-4.1 xorg-server-xwayland-1.20.5-4.1
xorgproto-2019.2-1

Gesamtgröße der installierten Pakete: 2395,65 MiB
Größendifferenz der Aktualisierung: 512,41 MiB

:: Installation fortsetzen? [J/n] J
(123/123) Prüfe Schlüssel im Schlüsselring [######################] 100%
(123/123) Überprüfe Paket-Integrität [######################] 100%
Fehler: Konnte den Vorgang nicht durchführen (Ungültiges oder beschädigtes Paket)
Fehler sind aufgetreten, keine Pakete wurden aktualisiert.
[hildegard@ManjaroGNOME ~]$ IgnorePkg=openexr
[hildegard@ManjaroGNOME ~]$ sudo pacman -Syu
:: Synchronisiere Paketdatenbanken...
core ist aktuell
extra ist aktuell
community ist aktuell
multilib ist aktuell
:: Starte vollständige Systemaktualisierung...
Warnung: fontconfig: Lokale Version (2:2.13.1+12+g5f5ec56-2) ist neuer als extra (2:2.13.1+12+g5f5ec56-1)
:: ilmbase durch extra/openexr ersetzen? [J/n] n
Löse Abhängigkeiten auf...
Suche nach in Konflikt stehenden Paketen...
:: openexr und ilmbase stehen miteinander in Konflikt. ilmbase entfernen? [j/N] N
Fehler: Nicht auflösbare Paketkonflikte gefunden
Fehler: Konnte den Vorgang nicht vorbereiten (In Konflikt stehende Abhängigkeiten)
:: openexr und ilmbase stehen miteinander in Konflikt
[hildegard@ManjaroGNOME ~]$ IgnorePKg=extra/openexr
[hildegard@ManjaroGNOME ~]$ sudo pacman -Syu
:: Synchronisiere Paketdatenbanken...
core ist aktuell
extra ist aktuell
community ist aktuell
multilib ist aktuell
:: Starte vollständige Systemaktualisierung...
Warnung: fontconfig: Lokale Version (2:2.13.1+12+g5f5ec56-2) ist neuer als extra (2:2.13.1+12+g5f5ec56-1)
:: ilmbase durch extra/openexr ersetzen? [J/n] n
Löse Abhängigkeiten auf...
Suche nach in Konflikt stehenden Paketen...
:: openexr und ilmbase stehen miteinander in Konflikt. ilmbase entfernen? [j/N] N
Fehler: Nicht auflösbare Paketkonflikte gefunden
Fehler: Konnte den Vorgang nicht vorbereiten (In Konflikt stehende Abhängigkeiten)
:: openexr und ilmbase stehen miteinander in Konflikt
[hildegard@ManjaroGNOME ~]$ sudo pacman -Syu
:: Synchronisiere Paketdatenbanken...
core ist aktuell
extra ist aktuell
community ist aktuell
multilib ist aktuell
:: Starte vollständige Systemaktualisierung...
Warnung: fontconfig: Lokale Version (2:2.13.1+12+g5f5ec56-2) ist neuer als extra (2:2.13.1+12+g5f5ec56-1)
:: ilmbase durch extra/openexr ersetzen? [J/n] IgnorePkg=fontconfig
Löse Abhängigkeiten auf...
Suche nach in Konflikt stehenden Paketen...
:: openexr und ilmbase stehen miteinander in Konflikt. ilmbase entfernen? [j/N]
Fehler: Nicht auflösbare Paketkonflikte gefunden
Fehler: Konnte den Vorgang nicht vorbereiten (In Konflikt stehende Abhängigkeiten)
:: openexr und ilmbase stehen miteinander in Konflikt
[hildegard@ManjaroGNOME ~]$ IgnorePkg=openexr
[hildegard@ManjaroGNOME ~]$ sudo pacman -Syu

probiere es mal mit sudo pacman -Syyu . das liest die paketquellen komplett neu ein.

Hallo,
bitte formatier Terminalausgaben als Code. Dazu kannst du entweder den </> Button verwenden oder drei ``` in den Zeilen über und unter dem eingefügten Text schreiben.

Zu deinem Problem: Du musst einfach bestätigen, dass ilmbase durch extra/openexr ersetzt wird. Es gibt kein ilmbase Pakte mehr in den Repos

Zum einen funktioniert das mit IgnorePkg so nicht, zum anderen sollte man Pakete nur in begründeten Ausnahmenfällen zurückhalten. Ansonsten kommt es zu Teilupdates. Das wird nicht unterstützt und kann zu Problemen führen.

1 Like

Funktioniert leider auch nicht. Fehleranzeige ist unverändert.

[hildegard@ManjaroGNOME ~]$ sudo pacman -Syu
:: Synchronisiere Paketdatenbanken...
 core ist aktuell
 extra ist aktuell
 community ist aktuell
 multilib ist aktuell
:: Starte vollständige Systemaktualisierung...
Warnung: fontconfig: Lokale Version (2:2.13.1+12+g5f5ec56-2) ist neuer als extra (2:2.13.1+12+g5f5ec56-1)
:: ilmbase durch extra/openexr ersetzen? [J/n] IgnorePkg=fontconfig
Löse Abhängigkeiten auf...
Suche nach in Konflikt stehenden Paketen...
:: openexr und ilmbase stehen miteinander in Konflikt. ilmbase entfernen? [j/N] j
Warnung: Abhängigkeits-Zyklus entdeckt:
Warnung: libglvnd wird vor seiner Abhängigkeit mesa installiert werden
Warnung: Abhängigkeits-Zyklus entdeckt:
Warnung: lib32-mesa wird vor seiner Abhängigkeit lib32-libglvnd installiert werden

Pakete (124) appstream-glib-0.7.16-2  archlinux-appstream-data-20191027-1
             aspell-0.60.8-1  bleachbit-3.0-1  btrfs-progs-5.3.1-0
             ca-certificates-mozilla-3.47-1  cronie-1.5.4-3  cups-2.3.0-4
             expac-9-2  expat-2.2.9-1  filesystem-2019.10-3  firefox-70.0-1.1
             gcr-3.34.0-1  ghostscript-9.50-1  glib2-2.62.2-1
             gnome-notes-3.34.1-1  gnome-online-accounts-3.34.1-1
             gnome-screenshot-3.34.0-1  gnome-shell-1:3.34.1+5+g072a9a484-1
             gnome-shell-extension-appindicator-30-1
             gnome-shell-extension-arc-menu-36.0+dev+2+gd687897-1
             gnome-shell-extension-gsconnect-27-2  gst-plugins-bad-1.16.1-2
             gtk-update-icon-cache-1:3.24.12+32+g39e28ab933-1
             gtk3-1:3.24.12+32+g39e28ab933-1  gtkmm3-3.24.2-1  hexchat-2.14.2-4
             hplip-1:3.19.8-2  ilmbase-2.3.0-1 [Entferne]
             imagemagick-7.0.8.68-2  jbig2dec-0.17-1  jre8-openjdk-8.u232-1
             jre8-openjdk-headless-8.u232-1  kauth-5.63.0-1
             kcoreaddons-5.63.0-1  kitemmodels-5.63.0-1  kwindowsystem-5.63.0-1
             lib32-glib2-2.62.2-1  lib32-libdrm-2.4.100-1
             lib32-libglvnd-1.2.0-3  lib32-lm_sensors-3.6.0-1
             lib32-mesa-19.2.2-1  lib32-mesa-vdpau-19.2.2-1  lib32-nspr-4.23-1
             lib32-nss-3.47-1  lib32-pango-1:1.44.7-1  lib32-systemd-242.153-1
             lib32-vulkan-intel-19.2.2-1  lib32-vulkan-radeon-19.2.2-1
             libblockdev-2.23-1  libcups-2.3.0-4  libdrm-2.4.100-1
             libglvnd-1.2.0-5  libinput-1.14.2-1  librsvg-2:2.46.3-1
             libssh-0.9.1-1  libtommath-1.2.0-1  libva-mesa-driver-19.2.2-1
             libxkbcommon-0.9.1-1  libxkbcommon-x11-0.9.1-1
             licenses-20191011-1  linux-firmware-20191022.2b016af-1
             linux419-4.19.80-1  linux419-r8168-8.047.04-6  linux53-5.3.7-2
             linux53-r8168-8.047.04-7  lm_sensors-3.6.0-1  lollypop-1.2.2-1
             lsb-release-1.4-13  man-db-2.9.0-1
             manjaro-gdm-branding-20191024-1  manjaro-gnome-assets-20191025-1
             manjaro-gnome-extension-settings-18.0-20191024-1
             manjaro-gnome-settings-18.0-20191025-2  manjaro-icons-20191015-1
             manjaro-release-18.1.2-1  mesa-19.2.2-1  mesa-vdpau-19.2.2-1
             mhwd-db-0.6.3-13  mhwd-nvidia-440xx-440.26-1
             mutter-3.34.1+26+gc0037305e-1  nspr-4.23-1  nss-3.47-1
             openexr-2.4.0-4  pacman-5.2.0-2  pamac-cli-9.0.2-1
             pamac-common-9.0.2-1  pamac-gtk-9.0.2-1  pango-1:1.44.7-1
             python-cairo-1.18.2-1  python-pikepdf-1.6.5-1
             python-pillow-6.2.0-1  python-urllib3-1.25.6-1  python2-2.7.17-1
             python2-cairo-1.18.2-1  python2-gobject-3.34.0-1  qpdf-9.0.2-1
             readline-8.0.001-1  steam-manjaro-1.0.0.61-7  sudo-1.8.28.p1-1
             systemd-242.153-1  systemd-libs-242.153-1
             systemd-sysvcompat-242.153-1  texinfo-6.7-1  thunderbird-68.2.0-1
             thunderbird-i18n-de-68.2.0-1  thunderbird-i18n-en-us-68.2.0-1
             tslib-1.21-1  twolame-0.4.0-1  unrar-1:5.8.3-1
             vulkan-icd-loader-1.1.126-1  vulkan-intel-19.2.2-1
             vulkan-radeon-19.2.2-1  wallpapers-2018-1.1-1
             xdg-desktop-portal-1.5.1-1  xdg-utils-1.1.3+18+g0547886-2
             xf86-video-amdgpu-19.1.0-1  xf86-video-ati-1:19.1.0-1
             xkeyboard-config-2.28-1  xmlsec-1.2.29-1  xorg-server-1.20.5-4.1
             xorg-server-common-1.20.5-4.1  xorg-server-xwayland-1.20.5-4.1
             xorgproto-2019.2-1

Gesamtgröße der installierten Pakete:  2395,65 MiB
Größendifferenz der Aktualisierung:   512,41 MiB

:: Installation fortsetzen? [J/n] J
(123/123) Prüfe Schlüssel im Schlüsselring         [######################] 100%
(123/123) Überprüfe Paket-Integrität               [######################] 100%
Fehler: Konnte den Vorgang nicht durchführen (Ungültiges oder beschädigtes Paket)
Fehler sind aufgetreten, keine Pakete wurden aktualisiert.
[hildegard@ManjaroGNOME ~]$ IgnorePkg=openexr
[hildegard@ManjaroGNOME ~]$ sudo pacman -Syu
:: Synchronisiere Paketdatenbanken...
 core ist aktuell
 extra ist aktuell
 community ist aktuell
 multilib ist aktuell
:: Starte vollständige Systemaktualisierung...
Warnung: fontconfig: Lokale Version (2:2.13.1+12+g5f5ec56-2) ist neuer als extra (2:2.13.1+12+g5f5ec56-1)
:: ilmbase durch extra/openexr ersetzen? [J/n] n
Löse Abhängigkeiten auf...
Suche nach in Konflikt stehenden Paketen...
:: openexr und ilmbase stehen miteinander in Konflikt. ilmbase entfernen? [j/N] N
Fehler: Nicht auflösbare Paketkonflikte gefunden
Fehler: Konnte den Vorgang nicht vorbereiten (In Konflikt stehende Abhängigkeiten)
:: openexr und ilmbase stehen miteinander in Konflikt
[hildegard@ManjaroGNOME ~]$ IgnorePKg=extra/openexr
[hildegard@ManjaroGNOME ~]$ sudo pacman -Syu
:: Synchronisiere Paketdatenbanken...
 core ist aktuell
 extra ist aktuell
 community ist aktuell
 multilib ist aktuell
:: Starte vollständige Systemaktualisierung...
Warnung: fontconfig: Lokale Version (2:2.13.1+12+g5f5ec56-2) ist neuer als extra (2:2.13.1+12+g5f5ec56-1)
:: ilmbase durch extra/openexr ersetzen? [J/n] n
Löse Abhängigkeiten auf...
Suche nach in Konflikt stehenden Paketen...
:: openexr und ilmbase stehen miteinander in Konflikt. ilmbase entfernen? [j/N] N
Fehler: Nicht auflösbare Paketkonflikte gefunden
Fehler: Konnte den Vorgang nicht vorbereiten (In Konflikt stehende Abhängigkeiten)
:: openexr und ilmbase stehen miteinander in Konflikt
[hildegard@ManjaroGNOME ~]$ sudo pacman -Syu
:: Synchronisiere Paketdatenbanken...
 core ist aktuell
 extra ist aktuell
 community ist aktuell
 multilib ist aktuell
:: Starte vollständige Systemaktualisierung...
Warnung: fontconfig: Lokale Version (2:2.13.1+12+g5f5ec56-2) ist neuer als extra (2:2.13.1+12+g5f5ec56-1)
:: ilmbase durch extra/openexr ersetzen? [J/n] IgnorePkg=fontconfig  
Löse Abhängigkeiten auf...
Suche nach in Konflikt stehenden Paketen...
:: openexr und ilmbase stehen miteinander in Konflikt. ilmbase entfernen? [j/N] 
Fehler: Nicht auflösbare Paketkonflikte gefunden
Fehler: Konnte den Vorgang nicht vorbereiten (In Konflikt stehende Abhängigkeiten)
:: openexr und ilmbase stehen miteinander in Konflikt
[hildegard@ManjaroGNOME ~]$ IgnorePkg=openexr
[hildegard@ManjaroGNOME ~]$ sudo pacman -Syu

Leider unverändert. Ich habe es mit deinem Tipp probiert.
[hildegard@ManjaroGNOME ~]$ sudo pacman -Syu
:: Synchronisiere Paketdatenbanken...
 core ist aktuell
 extra ist aktuell
 community ist aktuell
 multilib ist aktuell
:: Starte vollständige Systemaktualisierung...
Warnung: fontconfig: Lokale Version (2:2.13.1+12+g5f5ec56-2) ist neuer als extra (2:2.13.1+12+g5f5ec56-1)
:: ilmbase durch extra/openexr ersetzen? [J/n] IgnorePkg=fontconfig
Löse Abhängigkeiten auf...
Suche nach in Konflikt stehenden Paketen...
:: openexr und ilmbase stehen miteinander in Konflikt. ilmbase entfernen? [j/N] j
Warnung: Abhängigkeits-Zyklus entdeckt:
Warnung: libglvnd wird vor seiner Abhängigkeit mesa installiert werden
Warnung: Abhängigkeits-Zyklus entdeckt:
Warnung: lib32-mesa wird vor seiner Abhängigkeit lib32-libglvnd installiert werden

Pakete (124) appstream-glib-0.7.16-2  archlinux-appstream-data-20191027-1
             aspell-0.60.8-1  bleachbit-3.0-1  btrfs-progs-5.3.1-0
             ca-certificates-mozilla-3.47-1  cronie-1.5.4-3  cups-2.3.0-4
             expac-9-2  expat-2.2.9-1  filesystem-2019.10-3  firefox-70.0-1.1
             gcr-3.34.0-1  ghostscript-9.50-1  glib2-2.62.2-1
             gnome-notes-3.34.1-1  gnome-online-accounts-3.34.1-1
             gnome-screenshot-3.34.0-1  gnome-shell-1:3.34.1+5+g072a9a484-1
             gnome-shell-extension-appindicator-30-1
             gnome-shell-extension-arc-menu-36.0+dev+2+gd687897-1
             gnome-shell-extension-gsconnect-27-2  gst-plugins-bad-1.16.1-2
             gtk-update-icon-cache-1:3.24.12+32+g39e28ab933-1
             gtk3-1:3.24.12+32+g39e28ab933-1  gtkmm3-3.24.2-1  hexchat-2.14.2-4
             hplip-1:3.19.8-2  ilmbase-2.3.0-1 [Entferne]
             imagemagick-7.0.8.68-2  jbig2dec-0.17-1  jre8-openjdk-8.u232-1
             jre8-openjdk-headless-8.u232-1  kauth-5.63.0-1
             kcoreaddons-5.63.0-1  kitemmodels-5.63.0-1  kwindowsystem-5.63.0-1
             lib32-glib2-2.62.2-1  lib32-libdrm-2.4.100-1
             lib32-libglvnd-1.2.0-3  lib32-lm_sensors-3.6.0-1
             lib32-mesa-19.2.2-1  lib32-mesa-vdpau-19.2.2-1  lib32-nspr-4.23-1
             lib32-nss-3.47-1  lib32-pango-1:1.44.7-1  lib32-systemd-242.153-1
             lib32-vulkan-intel-19.2.2-1  lib32-vulkan-radeon-19.2.2-1
             libblockdev-2.23-1  libcups-2.3.0-4  libdrm-2.4.100-1
             libglvnd-1.2.0-5  libinput-1.14.2-1  librsvg-2:2.46.3-1
             libssh-0.9.1-1  libtommath-1.2.0-1  libva-mesa-driver-19.2.2-1
             libxkbcommon-0.9.1-1  libxkbcommon-x11-0.9.1-1
             licenses-20191011-1  linux-firmware-20191022.2b016af-1
             linux419-4.19.80-1  linux419-r8168-8.047.04-6  linux53-5.3.7-2
             linux53-r8168-8.047.04-7  lm_sensors-3.6.0-1  lollypop-1.2.2-1
             lsb-release-1.4-13  man-db-2.9.0-1
             manjaro-gdm-branding-20191024-1  manjaro-gnome-assets-20191025-1
             manjaro-gnome-extension-settings-18.0-20191024-1
             manjaro-gnome-settings-18.0-20191025-2  manjaro-icons-20191015-1
             manjaro-release-18.1.2-1  mesa-19.2.2-1  mesa-vdpau-19.2.2-1
             mhwd-db-0.6.3-13  mhwd-nvidia-440xx-440.26-1
             mutter-3.34.1+26+gc0037305e-1  nspr-4.23-1  nss-3.47-1
             openexr-2.4.0-4  pacman-5.2.0-2  pamac-cli-9.0.2-1
             pamac-common-9.0.2-1  pamac-gtk-9.0.2-1  pango-1:1.44.7-1
             python-cairo-1.18.2-1  python-pikepdf-1.6.5-1
             python-pillow-6.2.0-1  python-urllib3-1.25.6-1  python2-2.7.17-1
             python2-cairo-1.18.2-1  python2-gobject-3.34.0-1  qpdf-9.0.2-1
             readline-8.0.001-1  steam-manjaro-1.0.0.61-7  sudo-1.8.28.p1-1
             systemd-242.153-1  systemd-libs-242.153-1
             systemd-sysvcompat-242.153-1  texinfo-6.7-1  thunderbird-68.2.0-1
             thunderbird-i18n-de-68.2.0-1  thunderbird-i18n-en-us-68.2.0-1
             tslib-1.21-1  twolame-0.4.0-1  unrar-1:5.8.3-1
             vulkan-icd-loader-1.1.126-1  vulkan-intel-19.2.2-1
             vulkan-radeon-19.2.2-1  wallpapers-2018-1.1-1
             xdg-desktop-portal-1.5.1-1  xdg-utils-1.1.3+18+g0547886-2
             xf86-video-amdgpu-19.1.0-1  xf86-video-ati-1:19.1.0-1
             xkeyboard-config-2.28-1  xmlsec-1.2.29-1  xorg-server-1.20.5-4.1
             xorg-server-common-1.20.5-4.1  xorg-server-xwayland-1.20.5-4.1
             xorgproto-2019.2-1

Gesamtgröße der installierten Pakete:  2395,65 MiB
Größendifferenz der Aktualisierung:   512,41 MiB

:: Installation fortsetzen? [J/n] J
(123/123) Prüfe Schlüssel im Schlüsselring         [######################] 100%
(123/123) Überprüfe Paket-Integrität               [######################] 100%
Fehler: Konnte den Vorgang nicht durchführen (Ungültiges oder beschädigtes Paket)
Fehler sind aufgetreten, keine Pakete wurden aktualisiert.
[hildegard@ManjaroGNOME ~]$ IgnorePkg=openexr
[hildegard@ManjaroGNOME ~]$ sudo pacman -Syu
:: Synchronisiere Paketdatenbanken...
 core ist aktuell
 extra ist aktuell
 community ist aktuell
 multilib ist aktuell
:: Starte vollständige Systemaktualisierung...
Warnung: fontconfig: Lokale Version (2:2.13.1+12+g5f5ec56-2) ist neuer als extra (2:2.13.1+12+g5f5ec56-1)
:: ilmbase durch extra/openexr ersetzen? [J/n] n
Löse Abhängigkeiten auf...
Suche nach in Konflikt stehenden Paketen...
:: openexr und ilmbase stehen miteinander in Konflikt. ilmbase entfernen? [j/N] N
Fehler: Nicht auflösbare Paketkonflikte gefunden
Fehler: Konnte den Vorgang nicht vorbereiten (In Konflikt stehende Abhängigkeiten)
:: openexr und ilmbase stehen miteinander in Konflikt
[hildegard@ManjaroGNOME ~]$ IgnorePKg=extra/openexr
[hildegard@ManjaroGNOME ~]$ sudo pacman -Syu
:: Synchronisiere Paketdatenbanken...
 core ist aktuell
 extra ist aktuell
 community ist aktuell
 multilib ist aktuell
:: Starte vollständige Systemaktualisierung...
Warnung: fontconfig: Lokale Version (2:2.13.1+12+g5f5ec56-2) ist neuer als extra (2:2.13.1+12+g5f5ec56-1)
:: ilmbase durch extra/openexr ersetzen? [J/n] n
Löse Abhängigkeiten auf...
Suche nach in Konflikt stehenden Paketen...
:: openexr und ilmbase stehen miteinander in Konflikt. ilmbase entfernen? [j/N] N
Fehler: Nicht auflösbare Paketkonflikte gefunden
Fehler: Konnte den Vorgang nicht vorbereiten (In Konflikt stehende Abhängigkeiten)
:: openexr und ilmbase stehen miteinander in Konflikt
[hildegard@ManjaroGNOME ~]$ sudo pacman -Syu
:: Synchronisiere Paketdatenbanken...
 core ist aktuell
 extra ist aktuell
 community ist aktuell
 multilib ist aktuell
:: Starte vollständige Systemaktualisierung...
Warnung: fontconfig: Lokale Version (2:2.13.1+12+g5f5ec56-2) ist neuer als extra (2:2.13.1+12+g5f5ec56-1)
:: ilmbase durch extra/openexr ersetzen? [J/n] IgnorePkg=fontconfig  
Löse Abhängigkeiten auf...
Suche nach in Konflikt stehenden Paketen...
:: openexr und ilmbase stehen miteinander in Konflikt. ilmbase entfernen? [j/N] 
Fehler: Nicht auflösbare Paketkonflikte gefunden
Fehler: Konnte den Vorgang nicht vorbereiten (In Konflikt stehende Abhängigkeiten)
:: openexr und ilmbase stehen miteinander in Konflikt
[hildegard@ManjaroGNOME ~]$ IgnorePkg=openexr
[hildegard@ManjaroGNOME ~]$ sudo pacman -Syu

Nein, hast du nicht:

Hier musst du mit j bestätigen oder einfach Enter drücken. Aber nicht mit n ablehnen

Edit: Sorry, ich habe nur deine zweite Ausführung gesehen (bin ans Ende gesprungen um die Fehler zu lesen)

Ich habe mit j bestätigt, bleibt trotzdem hängen.

Und was zeigt dir pacman dann an? Der selbe Error kann es normalerweise nicht sein, da beim Ersetzen der Konflikt nicht auftreten sollte.

[hildegard@ManjaroGNOME ~]$ pacman -Syu
Fehler: Sie benötigen Root-Rechte, um diese Operation auszuführen.
[hildegard@ManjaroGNOME ~]$ sudo pacman -Syu
[sudo] Passwort für hildegard: 
:: Synchronisiere Paketdatenbanken...
 core ist aktuell
 extra ist aktuell
 community ist aktuell
 multilib ist aktuell
:: Starte vollständige Systemaktualisierung...
Warnung: fontconfig: Lokale Version (2:2.13.1+12+g5f5ec56-2) ist neuer als extra (2:2.13.1+12+g5f5ec56-1)
:: ilmbase durch extra/openexr ersetzen? [J/n] J
Löse Abhängigkeiten auf...
Suche nach in Konflikt stehenden Paketen...
Warnung: Abhängigkeits-Zyklus entdeckt:
Warnung: libglvnd wird vor seiner Abhängigkeit mesa installiert werden
Warnung: Abhängigkeits-Zyklus entdeckt:
Warnung: lib32-mesa wird vor seiner Abhängigkeit lib32-libglvnd installiert werden

Pakete (124) appstream-glib-0.7.16-2  archlinux-appstream-data-20191027-1
             aspell-0.60.8-1  bleachbit-3.0-1  btrfs-progs-5.3.1-0
             ca-certificates-mozilla-3.47-1  cronie-1.5.4-3  cups-2.3.0-4
             expac-9-2  expat-2.2.9-1  filesystem-2019.10-3  firefox-70.0-1.1
             gcr-3.34.0-1  ghostscript-9.50-1  glib2-2.62.2-1
             gnome-notes-3.34.1-1  gnome-online-accounts-3.34.1-1
             gnome-screenshot-3.34.0-1  gnome-shell-1:3.34.1+5+g072a9a484-1
             gnome-shell-extension-appindicator-30-1
             gnome-shell-extension-arc-menu-36.0+dev+2+gd687897-1
             gnome-shell-extension-gsconnect-27-2  gst-plugins-bad-1.16.1-2
             gtk-update-icon-cache-1:3.24.12+32+g39e28ab933-1
             gtk3-1:3.24.12+32+g39e28ab933-1  gtkmm3-3.24.2-1
             hexchat-2.14.2-4  hplip-1:3.19.8-2  ilmbase-2.3.0-1 [Entferne]
             imagemagick-7.0.8.68-2  jbig2dec-0.17-1  jre8-openjdk-8.u232-1
             jre8-openjdk-headless-8.u232-1  kauth-5.63.0-1
             kcoreaddons-5.63.0-1  kitemmodels-5.63.0-1
             kwindowsystem-5.63.0-1  lib32-glib2-2.62.2-1
             lib32-libdrm-2.4.100-1  lib32-libglvnd-1.2.0-3
             lib32-lm_sensors-3.6.0-1  lib32-mesa-19.2.2-1
             lib32-mesa-vdpau-19.2.2-1  lib32-nspr-4.23-1  lib32-nss-3.47-1
             lib32-pango-1:1.44.7-1  lib32-systemd-242.153-1
             lib32-vulkan-intel-19.2.2-1  lib32-vulkan-radeon-19.2.2-1
             libblockdev-2.23-1  libcups-2.3.0-4  libdrm-2.4.100-1
             libglvnd-1.2.0-5  libinput-1.14.2-1  librsvg-2:2.46.3-1
             libssh-0.9.1-1  libtommath-1.2.0-1  libva-mesa-driver-19.2.2-1
             libxkbcommon-0.9.1-1  libxkbcommon-x11-0.9.1-1
             licenses-20191011-1  linux-firmware-20191022.2b016af-1
             linux419-4.19.80-1  linux419-r8168-8.047.04-6  linux53-5.3.7-2
             linux53-r8168-8.047.04-7  lm_sensors-3.6.0-1  lollypop-1.2.2-1
             lsb-release-1.4-13  man-db-2.9.0-1
             manjaro-gdm-branding-20191024-1  manjaro-gnome-assets-20191025-1
             manjaro-gnome-extension-settings-18.0-20191024-1
             manjaro-gnome-settings-18.0-20191025-2  manjaro-icons-20191015-1
             manjaro-release-18.1.2-1  mesa-19.2.2-1  mesa-vdpau-19.2.2-1
             mhwd-db-0.6.3-13  mhwd-nvidia-440xx-440.26-1
             mutter-3.34.1+26+gc0037305e-1  nspr-4.23-1  nss-3.47-1
             openexr-2.4.0-4  pacman-5.2.0-2  pamac-cli-9.0.2-1
             pamac-common-9.0.2-1  pamac-gtk-9.0.2-1  pango-1:1.44.7-1
             python-cairo-1.18.2-1  python-pikepdf-1.6.5-1
             python-pillow-6.2.0-1  python-urllib3-1.25.6-1  python2-2.7.17-1
             python2-cairo-1.18.2-1  python2-gobject-3.34.0-1  qpdf-9.0.2-1
             readline-8.0.001-1  steam-manjaro-1.0.0.61-7  sudo-1.8.28.p1-1
             systemd-242.153-1  systemd-libs-242.153-1
             systemd-sysvcompat-242.153-1  texinfo-6.7-1  thunderbird-68.2.0-1
             thunderbird-i18n-de-68.2.0-1  thunderbird-i18n-en-us-68.2.0-1
             tslib-1.21-1  twolame-0.4.0-1  unrar-1:5.8.3-1
             vulkan-icd-loader-1.1.126-1  vulkan-intel-19.2.2-1
             vulkan-radeon-19.2.2-1  wallpapers-2018-1.1-1
             xdg-desktop-portal-1.5.1-1  xdg-utils-1.1.3+18+g0547886-2
             xf86-video-amdgpu-19.1.0-1  xf86-video-ati-1:19.1.0-1
             xkeyboard-config-2.28-1  xmlsec-1.2.29-1  xorg-server-1.20.5-4.1
             xorg-server-common-1.20.5-4.1  xorg-server-xwayland-1.20.5-4.1
             xorgproto-2019.2-1

Gesamtgröße der installierten Pakete:  2395,65 MiB
Größendifferenz der Aktualisierung:   512,41 MiB

:: Installation fortsetzen? [J/n] J
(123/123) Prüfe Schlüssel im Schlüsselring         [#####################] 100%
(123/123) Überprüfe Paket-Integrität               [#####################] 100%
Fehler: Konnte den Vorgang nicht durchführen (Ungültiges oder beschädigtes Paket)
Fehler sind aufgetreten, keine Pakete wurden aktualisiert.
[hildegard@ManjaroGNOME ~]$ 

Die Meldung bleibt gleich.

Was kann ich noch tun? Bisher gingen alle upgrades problemlos.

Ich würde folgendes nach einem Reboot versuchen:

sudo pacman -Scc
sudo pacman-mirrors -f 5
sudo pacman -Syyu

Fragen stets mit 'j' beantworten und anschließend rebooten.

1 Like

Danke. Was gebe ich bei der zweiten Frage ein?

[hildegard@ManjaroGNOME ~]$ sudo pacman -Scc
[sudo] Passwort für hildegard: 

Puffer-Verzeichnis: /var/cache/pacman/pkg/
:: Möchten Sie ALLE Dateien aus dem Puffer entfernen? [j/N] j
Entferne alle Dateien aus dem Puffer...

Datenbank-Verzeichnis: /var/lib/pacman/
:: Möchten Sie ungenutzte Repositorien entfernen? [J/n] 

Wie gesagt, Ja (d.h. 'j') eingeben.

Sorry, hab gerade vorhin nicht gesehen, dass du erst ja dann Nein verwendet hast. Ich gehe davon aus, dass ein unvollständig heruntergeladenes Paket oder ein kaputtes im Cache liegt/lag. Das Löschen des Cache und das Erzeugen der Mirrorliste (die Kommandos von @Wollie) sollten da helfen. Der Netzspielplatzmirror macht in letzter Zeit Probleme

@Wollie Danke fürs Einspringen.

1 Like

Das hat jetzt geklappt. Vielen Dank, Wollie. Es funzt wieder.

1 Like

Es hat geklappt mit dem Wechsel der Mirrors. Vielen Dank.

Zwischendurch war ein y zu wenig, nur mal so am Rande.

Hätte also schon nach dem zweiten Post erledigt sein können.
Was lange währt wird ...

Forum kindly sponsored by