Systemd mount suddently asks for password to mount drive at boot

suddenly today I got a prompt at boot for my password to mount one of my internal drives.
Until today they were automatically mounted but if IIRC I had an entries in fstab.

Now, I see I have entries in systemd to mount the drives and in the settings manager I have them selected to be mounted at login.
I have 2 sata drives, I only get asked the password for one, the other stays unmounted.

What I did yesterday was to click on “forget device” on a bunch of removable drives in the system settings in the “not connected” section of the ui; I think this removed the entries from fstab.

I don’t understand how to make the system mount the drives at login using the gui and systemd (without the need to write the password).
Could someone point me in the right direction?
I could just go back to use fstab but if there’s a new system in place that should be more user frindly I feel it should be used instead.


Search before posting.

System mount units is executed using root privileges.

The deprecation of manjaro-hotfix doesn’t change that.

I did uninstall that package but didn’t think nothing of it.
I’ve put the rule back as in the thread zbe linked (it didn’t see it before posting) and now it works again but it doesn’t seem logical that that file was removed if it was still very useful.

A behaviour I would expect in an user-friendly OS is that when in the settings gui I’m given the option to mount a drive at boot/login I would be asked one time for my root password and then it is set forever, how it’s done it’s not the user business, I tough we were at this point, apparently not.

I’m marking zbe’s post as solution, ty.

1 Like
  1. edit the file /usr/share/polkit-1/actions/org.freedesktop.UDisks2.policy
  2. in the excerpt < action id=“org.freedesktop.udisks2.filesystem-mount-system”> in the defaults tag replace the information: “auth_admin” with “yes”
  3. enjoy

This topic was automatically closed 3 hours after the last reply. New replies are no longer allowed.