Systemd-fsck gives "fsck failed with exit status 8" for root in kernel 6.8

Naturally, we’d prefer you didn’t. :smile_cat:

It’s not the kernel - it is either the version of e2fsprogs that was present and used to initially create the file system
or the default settings that where used when creating the file system

The feature that is causing this issue is called: orphan_file

cat /etc/mke2fs.conf lists the file with the current defaults when a file system is created
That feature is present in Manjaro defaults - but not (yet) in Ubuntu.

Older versions of e2fsprogs do not know this feature and cannot support it.
That is why disabling the feature on the file system will then enable the older e2fsck program to work.

sudo dumpe2fs /dev/sdaX | grep features to find out
sudo tune2fs -O ^orphan_file /dev/sdaX to disable

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.