Systemd-boot automatic update with systemd-boot-manager

It is mounted at /efi and /boot has all .img files.

I think you have misunderstood how systemd-boot works.

For systemd-boot to be functional you need your kernel img on the efi partition.

First unmount your /boot/efi - mount your $esp temporarily on /mnt and copy only the kernel files to the temporary mount.

Then rename your /boot to /boot.bak and create a new folder /boot

unmount the temporary mount at /mnt and mount it at /boot

modify your /etc/fstab to mount at /boot instead of /boot/efi

that should be it


Actually there’s another option. What @garvitjoshi9 tries to achieve is to mount $esp to /efi and mount boot to /boot but he missed that he needs a separate VFAT-formatted XBOOTLDR partition according to systemd-boot specs in order to have this working.

Thank You for the instructions but I am new to systemd-boot and mount as I have not used these things before. So Sorry, I cannot understand fully what you are trying to say. The problem i was having with grub was that it was not working with secure boot after signing the .efi files. So i had to move to systemd-boot and it was difficult to configure so i reinstalled grub with: sudo grub-install --target=x86_64-efi --efi-directory=/efi --bootloader-id=Manjaro --modules="normal test efi_gop efi_uga search echo linux all_video gfxmenu gfxterm_background gfxterm_menu gfxterm loadenv configfile tpm" --disable-shim-lock and again signed the .efi file and everything works now with secure boot. I will have to learn more new things before starting with systemd-boot. The original issue is here.

I Hope systemd-boot becomes easy to configure in coming years. Unlit then I will have to work with GRUB.

Ha, it’s wasy once you read this:
Also, there’s no much sense of having Secure Boot with default Grub configuration using separate vmlinuz and initrds, no encryption and no TPM verification. Note, no much sense, not saying no at all.

1 Like

It works now, then uninstall GRUB. thanks!