[systemd 243.0-1] Errors (from journalctl)

Got these errors, not present in 242. Didn't test if they mean anything - VM works fine over ssh. Just heads up.

Sep 03 15:47:08 zbeVM systemd-udevd[244]: /usr/lib/udev/rules.d/84-nm-drivers.rules:10 Invalid value "/bin/sh -c 'ethtool -i $1 | sed -n s/^driver:\ //p' -- $env{INTERFACE}" for PROGRAM (char 24: inval>
Sep 03 15:47:08 zbeVM systemd-udevd[248]: sdv_gpio: /usr/lib/udev/rules.d/60-block-scheduler.rules:3 Failed to write ATTR{/sys/bus/pci/drivers/sdv_gpio/queue/scheduler}, ignoring: No such file or direc>
Sep 03 15:47:08 zbeVM systemd-udevd[255]: sd_mod: /usr/lib/udev/rules.d/60-block-scheduler.rules:3 Failed to write ATTR{/sys/module/sd_mod/queue/scheduler}, ignoring: No such file or directory
Sep 03 15:47:08 zbeVM systemd-udevd[255]: srcutree: /usr/lib/udev/rules.d/60-block-scheduler.rules:3 Failed to write ATTR{/sys/module/srcutree/queue/scheduler}, ignoring: No such file or directory
1 Like

Please show contents of these files, the 1st one doesn't exist here.

/usr/lib/udev/rules.d/60-block-scheduler.rules

# do not edit this file, it will be overwritten on update
ACTION=="add|change", KERNEL=="sd*[!0-9]|sr*", ATTR{queue/scheduler}="bfq"

/usr/lib/udev/rules.d/84-nm-drivers.rules

# Do not modify this file, it will get overwritten on updates.
# To override or extend the rules place a file in /etc/udev/rules.d
SUBSYSTEM!="net", GOTO="nm_drivers_end"
ACTION!="add|change", GOTO="nm_drivers_end"
# Determine ID_NET_DRIVER if there's no ID_NET_DRIVER or DRIVERS (old udev?)
ENV{ID_NET_DRIVER}=="?*", GOTO="nm_drivers_end"
DRIVERS=="?*", GOTO="nm_drivers_end"
PROGRAM="/bin/sh -c 'ethtool -i $1 | sed -n s/^driver:\ //p' -- $env{INTERFACE}", RESULT=="?*", ENV{ID_NET_DRIVER}="%c"
LABEL="nm_drivers_end"

Edit: This si in Virtualbox with 5.3 kernel

Thanks.
They look fine to me.

Why does systemd-udevd try to apply the scheduler settings to the wrong sysfs directory/file?

I'm still on systemd 242 btw.

No idea or understanding here. :stuck_out_tongue: Can't say anything is broken. Just informing the forum. :smiley:

Here's the systemd changelog:

We tried this patch. Maybe I've to recheck it. See also here and here. What is the output of:
grep . /sys/class/block/*/queue/scheduler

Same issue. Here are results

/sys/class/block/fd0/queue/scheduler:[mq-deadline] kyber bfq none
/sys/class/block/sda/queue/scheduler:mq-deadline kyber [bfq] none
/sys/class/block/sdb/queue/scheduler:mq-deadline kyber [bfq] none
/sys/class/block/sdc/queue/scheduler:mq-deadline kyber [bfq] none
/sys/class/block/sr0/queue/scheduler:mq-deadline kyber [bfq] none

I think it's a problem with the glob pattern

  • sd*[!0-9] will match all words starting with sd that don't end with a number, such as sdv_gpio, sd_mod shown in the systemd log.
  • The same thing with sr*, srcutree will be matched as shown in the log.

To fix it, use sd[a-z] and sr[0-9] instead. Maybe ??

patch got updated. On my end I have those errors not anymore.

Sounds like this. Have to see what needs to be updated on Networkmanager to fix this.

Now I am getting the following in the journalctl:

Sep 03 18:52:40 john-pc systemd-udevd[389]: sdb: /etc/udev/rules.d/60-schedulers.rules:2 Failed to write ATTR{/sys/devices/pci0000:00/0000:00:11.0/ata6/host5/target5:0:0/5:0>

Do you have "ethtool" installed?

I don't believe it is installed by default on some Manjaro editions.

1 Like

I have the same issue with systemd 243.0-2

Still have this:

$ journalctl --no-pager --no-hostname -xb -p3
-- Logs begin at Sun 2019-09-01 00:19:14 +10, end at Wed 2019-09-04 18:05:54 +10. --
Sep 04 17:58:37 systemd-udevd[565]: /usr/lib/udev/rules.d/84-nm-drivers.rules:10 Invalid value "/bin/sh -c 'ethtool -i $1 | sed -n s/^driver:\ //p' -- $env{INTERFACE}" for PROGRAM (char 24: invalid substitution type), ignoring, but please fix it.
Sep 04 17:58:38 systemd-udevd[582]: sda: /etc/udev/rules.d/60-schedulers.rules:2 Failed to write ATTR{/sys/devices/pci0000:00/0000:00:17.0/ata2/host1/target1:0:0/1:0:0:0/block/sda/queue/scheduler}, ignoring: Invalid argument
Sep 04 17:58:38 systemd-udevd[590]: sdc: /etc/udev/rules.d/60-schedulers.rules:4 Failed to write ATTR{/sys/devices/pci0000:00/0000:00:14.0/usb2/2-4/2-4.2/2-4.2:1.0/host2/target2:0:0/2:0:0:1/block/sdc/queue/scheduler}, ignoring: Invalid argument
Sep 04 17:58:38 systemd-udevd[602]: sdb: /etc/udev/rules.d/60-schedulers.rules:4 Failed to write ATTR{/sys/devices/pci0000:00/0000:00:14.0/usb2/2-4/2-4.2/2-4.2:1.0/host2/target2:0:0/2:0:0:0/block/sdb/queue/scheduler}, ignoring: Invalid argument
...
Sep 04 17:59:57 NetworkManager[1272]: <error> [1567583997.7734] audit: failed to open auditd socket: Protocol not supported

Systemd 243.0-2

Output of grep . /sys/class/block/*/queue/scheduler ?

pacman -Qo /etc/udev/rules.d/60-schedulers.rules
error: No package owns /etc/udev/rules.d/60-schedulers.rules
phil@development /var/lib/manjaro-tools/buildiso/xfce/x86_64 $ ls /etc/udev/rules.d/60-schedulers.rules
ls: cannot access '/etc/udev/rules.d/60-schedulers.rules': No such file or directory

The rules are located here with systemd 243.0-2

pacman -Ql systemd | grep sched
systemd /usr/lib/udev/rules.d/60-block-scheduler.rules

Network manager needs an update to avoid that warning. See here.

2 Likes

Solved

[2019-09-04 11:03] [ALPM] upgraded networkmanager (1.20.0-1 -> 1.20.0-1.1)
[2019-09-04 11:03] [ALPM] upgraded libnm (1.20.0-1 -> 1.20.0-1.1)
[2019-09-04 10:41] [ALPM] installed ethtool (1:5.2-1)
1 Like
$ grep . /sys/class/block/*/queue/scheduler
/sys/class/block/dm-0/queue/scheduler:none
/sys/class/block/dm-1/queue/scheduler:none
/sys/class/block/nvme0n1/queue/scheduler:[none] mq-deadline kyber bfq 
/sys/class/block/sda/queue/scheduler:mq-deadline kyber [bfq] none
/sys/class/block/sdb/queue/scheduler:mq-deadline kyber [bfq] none
/sys/class/block/sdc/queue/scheduler:mq-deadline kyber [bfq] none

Looks like I have to remove /etc/udev/rules.d/60-schedulers.rules? I don't remember how this file appeared in my system.
UPD: Moved it to %filename%.bak, seems like it worked.

UPD2: Found new error after the update of networkmanager:

avahi-daemon[1293]: chroot.c: open() failed: No such file or directory

So I added After=network-online.target to [Unit] section of avahi-daemon.service.

1 Like

Indeed, solved with networkmanager 1.20.0-1.1. :slight_smile:

2 Likes

Forum kindly sponsored by Bytemark