Systemd 240 update breaks graphical login

systemd
gnome
update
xfce
xfce4-gtk3

#61

Same as what?


#62

Same as the title of the post. The poster confirmed their platform, desktop and version of systemd, then confirmed they were experiencing the same issue as the original poster.

Was there something else that was supposed to have been provided?


#63

The thread has moved on significantly since the topic title, e.g. there have been (at least?) four updated systemd packages since then.

Popping up with an ambiguous “same here” means very little at that point.


#64

Reports ala same here never cut it, especially when we try to fix the issue. Always specify the exact package versions you have issues with. We also recommend to update to the latest, to see if those are already resolved by now.


#65

Sorry… I’m experiencing exactly the same issue posted in the OP. It started upgrading systemd 240 in [testing] repo (Archlinux official). Founded this thread looking at google, so I quickly expressed my “me too”. Sorry to not be specific.

It happened in 2 different laptops, so it doesn’t seem to me a coincidence.

If you guys already solved the problem, I can port the patches to Archlinux official package.

Cheers

Edit: Tried to apply all these patches:
11244.patch
11244.patch
11265.patch
11265.patch
11266.patch
11266.patch
11270.patch
11270.patch
to Archlinux [testing] systemd, but unfortunately XFCE keeps crashing… I’ll give it away (holidays are coming).


#66

Fixed for me since Systemd 240.1-4.
No issues with the next versions : 240.1-5 & 240.1-6


#67

Cos you simply forgot the reverts:

_reverts=(
  # https://src.fedoraproject.org/cgit/rpms/systemd.git/log/
  '64d7f7b4a15f1534fb19fda6b601fec50783bee4'
  # https://forum.manjaro.org/t/69396
  '2b2b7228bffef626fe8e9f131095995f3d50ee3b'
)

[Testing Update i686] 2018-12-19 to 2019-01-15 - Systemd, Kernels, LibreOffice Fresh, Readline
#68

Thanks both, that’s useful to know.


#69

Indeed. Thanks for pointing it out. It’s working now.


#70

I love this last comment due to the graphical session breakage by not setting a variable :wink: