Systemctl: Refusing to operate on linked unit file bumblebeed.service

Hello, I’ve been using my laptop with the open intel driver for not having time to explore the nvidia private and optirun, every time I use the hardware installer manjaro gui after restart the screen was freezing in the registry start, so I try installing bumblebee again, and I have some problems like systemd refuse load the bumblebeed.service.

mhwd

0000:01:00.0 (0302:10de:1c8d) Display controller nVidia Corporation:


              NAME               VERSION          FREEDRIVER           TYPE

video-hybrid-intel-nvidia-bumblebee 2018.05.04 false PCI
video-hybrid-intel-nvidia-390xx-bumblebee 2018.05.04 false PCI
video-nvidia 2018.05.04 false PCI
video-nvidia-390xx 2018.05.04 false PCI
video-linux 2018.05.04 true PCI

0000:03:00.1 (0200:10ec:8168) Network controller Realtek Semiconductor Co., Ltd.:


              NAME               VERSION          FREEDRIVER           TYPE

     network-r8168            2016.04.20                true            PCI

0000:00:02.0 (0300:8086:591b) Display controller Intel Corporation:


              NAME               VERSION          FREEDRIVER           TYPE

video-hybrid-intel-nvidia-bumblebee 2018.05.04 false PCI
video-hybrid-intel-nvidia-390xx-bumblebee 2018.05.04 false PCI
video-linux 2018.05.04 true PCI
video-vesa 2017.03.12 true PCI

mhwd -li

Installed PCI configs:


              NAME               VERSION          FREEDRIVER           TYPE

     network-r8168            2016.04.20                true            PCI

video-hybrid-intel-nvidia-bumblebee 2018.05.04 false PCI

systemctl enable bumblebeed.service
Failed to enable unit: Refusing to operate on linked unit file bumblebeed.service

Please read this systemd issue and investigate if and on which unit bumblebeed is linked.


I didn’t know this case until now.

Sorry, i don’t mentioned in the install i see this but i don’t interpretively what means

and I check the links /etc/systemd/system/multi-user.target.wants/bumblebeed.service , /usr/lib/systemd/system/bumblebeed.service
and there are empty.

i actually have resolve the problems, installing from pacman bbswitch, before video-hybrid-intel-nvidia-bumblebee via mhwd and then install bumblebee from pacman in that order.
Thanks @petsam
Well it’s work to the point of screen froze, and bofro reboot screenfroze again

Try starting from TTY (Ctrl+Alt+F2 , login and run startx or exec startkde)

frozen, i have to run manjaro architect and enter in chroot

Then you can check for errors in journal and Xorg logs

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.