System76 Galago Pro LED lights

Hello,

So my problem is no big deal nor is it urgent, but I'm curious.

The issue:
When I turn on airplane mode, the led at the front of my Galago Pro does not react.

Notes:
There are four leds on the front of my laptop:

  • power
  • battery
  • airplane mode
  • disk activity

All but the airplane mode LEDS work as intended.

My inxi fxzc0 output if it helps.

Where I've looked:

So this is the output of cat /sys/class/leds/phy0-led/trigger:

none kbd-scrolllock kbd-numlock kbd-capslock kbd-kanalock kbd-shiftlock kbd-altgrlock
kbd-ctrllock kbd-altlock kbd-shiftllock kbd-shiftrlock kbd-ctrlllock kbd-ctrlrlock usb-gadget
usb-host disk-activity disk-read disk-write ide-disk mtd nand-disk cpu cpu0 cpu1 cpu2 cpu3
cpu4 cpu5 cpu6 cpu7 panic mmc0 AC-online BAT0-charging-or-full BAT0-charging BAT0-full
BAT0-charging-blink-full-solid rfkill-any rfkill-none bluetooth-power hci0-power rfkill0 rfkill1
phy0rx phy0tx phy0assoc [phy0radio] r8169-3a01:00:link r8169-3a01:00:1Gbps 
r8169-3a01:00:100Mbps r8169-3a01:00:10Mbps

(I added the line breaks to try to make it readable)

So to summarize I'm not sure if this is something that's sorted at OS level, and if so how, or if it's at a firmware level?

I've also asked System 76 and will post their answer when I get it so I don't become a DenverCoder9.

Thanks for reading this far, and for any help or pointers your could provide.

So this is the reply I received from system76:

The airplane mode light is controlled via the system76-dkms driver.

The source code for that driver is here: [https://github.com/pop-os/system76-dkms)
It is available in the AUR here (this is a community-maintained repository, not officially supported): [https://aur.archlinux.org/packages/system76-dkms/]
Do you have that package installed, along with the rest of the System76 Driver? If they are installed, you should be able to manually control the lights by writing to some of the files in this directory:

/sys/devices/platform/system76

That's assuming the functionality doesn't work automatically once the dkms driver is installed.

So I did not have that package installed, nor do I knowingly have system76 drivers installed as I installed manjaro on a fresh hardrive using the proprietary drivers during install.

I tried installing the driver with:
yay -S system76-dkms
but this returned a kernel header error. At this point, not knowing what to do, I uninstalled the driver, updated my system and --aur packages and rebooted. So my system is working, but I still don't have the drivers.

As I told system76, this is not massively important, as this is my work laptop, I can't afford to break it if I don't know how to fix it.

Still, someone more used to the AUR and linux kernels might know what this is about.

So some more info:

When I run:
yay -S system76-dkms
I get the following message:
==> Unable to install module system76/1.0.6 for kernel 4.19.80-1-MANJARO: Missing kernel headers.
So the friendly people at System76 said that:

That looks like it could be an issue with the AUR package that was packaged though it is odd that you are on an older kernel as well. You may need the linux header though I don't see that version in the Arch archives any longer:

https://www.archlinux.org/packages/core/x86_64/linux-headers/

And indeed, when I run:
uname -a
I get:
Linux geomanjaro 4.19.80-1-MANJARO #1 SMP PREEMPT Fri Oct 18 12:28:02 UTC 2019 x86_64 GNU/Linux

So then when I search for those linux headers on the AUR I found only this:
https://www.archlinux.org/packages/core/x86_64/linux-lts/
where the version is: linux-lts 4.19.81-1

So, does this mean we can't find the headers for the LTS/Recommended manjaro version?

I'll keep searching and post a solution if I find one.

So since the last stable update, the output of uname - is now:
Linux geomanjaro 4.19.81-1-MANJARO

so after running yay -S system76-dkmsI used to get the header error I mentioned earlier. I now ran:

sudo pacman -S linux419-headers

and now all is working just fine :+1:

So thanks to the kind people at system76 but also of course to the Manjaro team for the update to the kernel.

I realise I may be the only person who had this issue, but I just wanted to post this answer in case anyone needs it in future.

Forum kindly sponsored by