System wont boot with quiet splash after latest updates


I have a strange issue, after todays (feb 21) updates my system will hang on a black screen after grub if quiet splash is present in the params, but boots fine and everything works if i remove those 2.
Quite new to Linux when it comes to diagnosing boot problems, does anyone have any pointers i could look at/try?

dmesg log here: ██████████████████ ████████ judit@judit-z87hd3██████████████████ ████████ -


Have a look here:

Thank you, i looked at the arch wiki and didnt find anything that would be of help sadly. I checked and mkinitcpio has the plymouth hook, i tried a different theme, same issue, guess i’ll just disable it in the meantime.

Plymouth has always been garbage, and always created random issues.
Even if it was working perfectly … its bloat.

Anyhoo … since it apparently bit an even larger number of people this round of updates I threw together a guide from one of my previous ‘remove plymouth because it breaks things’ threads.

Bonus points…
For those that want a decently ‘seamless’ experience and/or the fastest booting speed
(forget forced minimum animation times and rendering graphics … if your system is quick enough even displaying boot messages in text can be a bottleneck!)
aim for any variation of this:

1 Like

Thanks for ur input, i solved it by removing and reinstalling plymouth (thanks to Boot after update fails - #12 by Humpleupagus)

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.