System wide stuttering

drivers
hardware
xfce
nvidia

#21

You have all this installed and the same user for them?


#22

It actually doesn’t happen on the live install. No I didn’t, I install them one by one. If it didn’t work, I just moved to another distro.


#23

This is a good starting point to trace the issue.

I understand, but are all on the same system or on separate partitions? Same user with the same /home is a mix that i always avoid when comes to multiple DE’s.


#24

I installed them on the same system (Same hardware). I had them on the same hard drive, but if I had the issue I would wipe the hard drive and install the next distro. Just to be on the safe side.


#25

I found there’re something odd in your xorg.0.log. First some nvidia options in your config are not used (at least not mentioned in xorg log), and second as quoted above is the mode changed to “nvidia-auto-select”. Here’s my config, you can try to set mode explicitly and move nvidia options to “Device” section. Good luck!

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 396.51  (buildmeister@swio-display-x64-rhel04-14)  Tue Jul 31 16:04:54 PDT 2018

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0"
    Inactive	   "intel"
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    Option         "DPMS"
    Option         "PreferredMode"  "1366x768"
    Option	   "Primary" "true"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    BusID	   "PCI:1:0:0"
    VendorName     "NVIDIA Corporation"
    Option "NoLogo" "1"
    Option      "metamodes" "eDP-1-1: 1366x768_60 +0+0 { ForceCompositionPipeline=On, ForceFullCompositionPipeline=On }"
    Option	"InitialPixmapPlacement" "0"
    Option	"DPI" "96 x 96"   
    Option         "AllowIndirectGLXProtocol" "off"
    Option         "TripleBuffer" "on"
    Option 	   "UseNvKmsCompositionPipeline" "false"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
	Modes      "1366x768"
    EndSubSection
EndSection

Section "Device"
    Identifier     "intel"
    Driver 	   "modesetting"
    BusID 	   "PCI:0:2:0"
    Option 	   "AccelMethod" "sna"
    Option 	   "DRI" "3"
EndSection

Section "Screen"
    Identifier     "intel"
    Device         "intel"
EndSection

Section "Extensions"
    Option         "Composite" "Enable"
EndSection

 
Section "InputClass"
    Identifier          "Keyboard Defaults"
    MatchIsKeyboard        "yes"
    Option              "XkbOptions" "terminate:ctrl_alt_bksp"
EndSection

if xorg loads config correctly, in xorg log there will be some hints about options, like below:

[     7.372] (II) Applying OutputClass "nvidia" options to /dev/dri/card0
[     7.372] (**) NVIDIA(0): Option "DPI" "96 x 96"
[     7.372] (**) NVIDIA(0): Option "TripleBuffer" "on"
[     7.373] (**) NVIDIA(0): Option "AllowIndirectGLXProtocol" "off"
[     7.373] (**) NVIDIA(0): Option "AllowEmptyInitialConfiguration"
[     7.373] (**) NVIDIA(0): Option "UseNvKmsCompositionPipeline" "false"
[     7.373] (**) NVIDIA(0): Option "MetaModes" "eDP-1-1: 1366x768_60 +0+0 { ForceCompositionPipeline=On, ForceFullCompositionPipeline=On }"
[     7.373] (**) NVIDIA(0): Enabling 2D acceleration
[     7.390] (II) NVIDIA(0): NVIDIA GPU GeForce GT 620M (GF117) at PCI:1:0:0 (GPU-0)
[     7.391] (--) NVIDIA(0): Memory: 1048576 kBytes
[     7.391] (--) NVIDIA(0): VideoBIOS: 75.17.34.00.02
[     7.391] (II) NVIDIA(0): Detected PCI Express Link width: 8X
[     7.391] (II) NVIDIA(0): Validated MetaModes:
[     7.391] (II) NVIDIA(0):     "NULL"
[     7.391] (II) NVIDIA(0): Virtual screen size determined to be 640 x 480
[     7.391] (**) NVIDIA(0): DPI set to (96, 96); computed from "DPI" X config option
[     7.391] (**) modeset(G0): Depth 24, (--) framebuffer bpp 32
[     7.391] (**) modeset(G0): Option "AccelMethod" "sna"
[     7.391] (==) modeset(G0): RGB weight 888
[     7.391] (==) modeset(G0): Default visual is TrueColor
[     7.391] (**) modeset(G0): glamor disabled
[     7.391] (II) modeset(G0): ShadowFB: preferred YES, enabled YES
[     7.391] (II) modeset(G0): Double-buffered shadow updates: off
[     7.392] (II) modeset(G0): Output eDP-1-1 using monitor section Monitor0
[     7.392] (**) modeset(G0): Option "PreferredMode" "1366x768"
[     7.392] (**) modeset(G0): Option "Primary" "true"

#26

I added those into my config and it’s still doing it. I have a pcie error when booting but it says it has been corrected. If that’s any help.


#27

Update your BIOS that might be messing with things https://www.asus.com/us/Motherboards/TUF-Z370-PRO-GAMING/HelpDesk_BIOS/


#28

Thanks for the tip. I updated and it’s still messing up. It seems to be doing it less often now.


#29

Next question, why are you using the 4.9 kernel on an 8th gen processor. Add the 4.14 and 4.19 kernel. Test them both. Then check your BIOS settings and make sure you don’t have an overclock, undervolt setting tha tmight be messing with things. If you do drop it to stock settings for freq and voltage.


#30

I also noticed that you have two outputs (displays) connected, and DPI is set to

(--) NVIDIA(0): DPI set to (110, 114); computed from "UseEdidDpi" X config

I’m not sure if you use multiple monitors or single one. Can you try to use one output and set DPI to 96?Then test and check if come back normal.


#31

I’m using two. I set it back to 96 and still nothing, I can’t seem to fix this.


#32

The reason why I was using those kernels is because I was trying to use as many as I can. I have also used the 4.19 kernel and it doesn’t help. 4.14 doesn’t even boot.


#33

when you say stuttering/low fps, do you mean this happens in video playback or video games, or just the desktop environment/browser?

heres something you may want to consider:


#34

No low fps, it’s at a constant 60. This happens in everything, games, browser and desktop. So I assumed it was the system. Also, the cpu thread didn’t help. I can’t find a good way to show this to you, my obs will not pick it up and my phone cam is to slow.


#35

so your fps reads 60, certain things seem like they are running much slower/skipping frames?
can you open nvidia-settings > PowerMizer > set mode to “prefer maximum performance” and see if the issue still occurs


#36

Yep it still does it. I’m probably just going to give up and go back to Windows.


#37

nobody likes a quitter :roll_eyes:
you tried the options from the post i linked?
another thing you might try is disable tlp.
sudo systemctl stop tlp
sudo systemctl disable tlp
reboot and test again, if theres no change you can easily enable and start it. this at least rules out any tlp settings that may be causing problems


#38

I’ve seen cases where the default compositor has micro-stutters, sometimes a “smooth” stutter (maybe this is the issue you’re having?).

Can you see if you still have the issue after installing compiz-manjaro? (Log out and back in for changes to take effect).

If that fixes it, you can either stick with that, or you can give compton a try as well (compiz is seen by some as being overkill and/or “heavy”, though I personally use it without issue).