System tray doesn't show the language detector and running apps

hello there, my system stopped showing the current language, I tried to turn it on with “always show” in the system tray setting but nothing showed yet and other apps that show in the system tray are disappear is any way to restore or repair the system tray insisted of reinstalling manjaro
It causes a new update for me.

It’s the first time I ask question here and I don’t know which information you need to help
So accept my apology


You rebooted the system after update? Have you cleaned the ~/.cache folder too before that? Have you tried to add a new Panel and see if that is showing everything correct?

yeah i do this steps more than one but nothing change yet :smiling_face_with_tear:

@amir_v Could it be that you are running a Wayland session? What does the following command output?


the result is


Ok that is fine then, because what you were describing is what I experience with Wayland.

Have you tried to remove the system tray widget completely and add it new to the panel. I guess you know how to edit the panel: right click on desktop > Enter Edit Mode and the right click on tray widget and > delete. Afterwards you need to re-add the standard widget again.

It’s a user settings, so a rollback will not help, although you said the issue came with an update.

Yeah, I do this work too, but language detector not show in panel