System stops before login

Today I received six updates regarding, Linux61, Linux62 with respective Nvidia and Vbox modules. After updating and rebooting, the system halts before SDDM. Tried to reboot several times, got the same result. Rolled back with Timeshift and all is ok, this hasn’t happened to me in a long while though.

Generated on 2023-03-13 21:21:1678738890

#################### inxi -Fxzc0 ########################

  Kernel: 6.2.5-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.2.1 Desktop: KDE Plasma
    v: 5.27.2 Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: LENOVO product: 82NL v: Legion 5 15IMH6 serial: <superuser required>
  Mobo: LENOVO model: LNVNB161216 v: SDK0J40700 WIN serial: <superuser required> UEFI: LENOVO
    v: G8CN19WW date: 01/06/2022
  ID-1: BAT0 charge: 56.5 Wh (100.0%) condition: 56.5/60.0 Wh (94.2%) volts: 17.2 min: 15.4
    model: Celxpert L19C4PC0 status: full
  Device-1: hidpp_battery_0 model: Logitech G305 Lightspeed Wireless Gaming Mouse charge: 100%
    (should be ignored) status: discharging
  Info: 6-core model: Intel Core i5-10500H bits: 64 type: MT MCP arch: Comet Lake rev: 2 cache:
    L1: 384 KiB L2: 1.5 MiB L3: 12 MiB
  Speed (MHz): avg: 3356 high: 4288 min/max: 800/4500 cores: 1: 4114 2: 3833 3: 3858 4: 4288
    5: 1698 6: 2500 7: 4122 8: 4227 9: 1241 10: 2500 11: 3692 12: 4203 bogomips: 60014
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Device-1: Intel CometLake-H GT2 [UHD Graphics] vendor: Lenovo driver: i915 v: kernel
    arch: Gen-9.5 bus-ID: 00:02.0
  Device-2: NVIDIA GA107BM [GeForce RTX 3050 Ti Mobile] vendor: Lenovo driver: nvidia
    v: 525.89.02 arch: Ampere bus-ID: 01:00.0
  Device-3: Bison Integrated Camera type: USB driver: uvcvideo bus-ID: 1-6:2
  Display: x11 server: X.Org v: 21.1.7 with: Xwayland v: 22.1.8 driver: X: loaded: modesetting
    unloaded: nouveau failed: nvidia dri: iris gpu: i915 resolution: 1920x1080~165Hz
  API: OpenGL v: 4.6 Mesa 22.3.7 renderer: Mesa Intel UHD Graphics (CML GT2) direct-render: Yes
  Device-1: Intel Comet Lake PCH cAVS vendor: Lenovo driver: snd_hda_intel v: kernel
    bus-ID: 00:1f.3
  Device-2: NVIDIA driver: snd_hda_intel v: kernel bus-ID: 01:00.1
  Sound API: ALSA v: k6.2.5-1-MANJARO running: yes
  Sound Server-1: PulseAudio v: 16.1 running: no
  Sound Server-2: PipeWire v: 0.3.66 running: yes
  Device-1: Intel Comet Lake PCH CNVi WiFi driver: iwlwifi v: kernel bus-ID: 00:14.3
  IF: wlp0s20f3 state: up mac: <filter>
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Lenovo driver: r8169
    v: kernel port: 3000 bus-ID: 07:00.0
  IF: enp7s0 state: down mac: <filter>
  Device-1: Intel AX201 Bluetooth type: USB driver: btusb v: 0.8 bus-ID: 1-14:5
  Report: rfkill ID: hci0 rfk-id: 2 state: up address: see --recommends
  Local Storage: total: 1.38 TiB used: 270.97 GiB (19.2%)
  ID-1: /dev/nvme0n1 vendor: Micron model: MTFDHBA512TDV size: 476.94 GiB temp: 46.9 C
  ID-2: /dev/sda vendor: Samsung model: ST1000LM024 HN-M101MBB size: 931.51 GiB
  ID-1: / size: 437.58 GiB used: 114.32 GiB (26.1%) fs: btrfs dev: /dev/nvme0n1p2
  ID-2: /boot/efi size: 299.4 MiB used: 28.1 MiB (9.4%) fs: vfat dev: /dev/nvme0n1p1
  ID-3: /home size: 437.58 GiB used: 114.32 GiB (26.1%) fs: btrfs dev: /dev/nvme0n1p2
  ID-4: /var/log size: 437.58 GiB used: 114.32 GiB (26.1%) fs: btrfs dev: /dev/nvme0n1p2
  ID-1: swap-1 type: file size: 2 GiB used: 0 KiB (0.0%) file: /swap/swapfile
  System Temperatures: cpu: 44.0 C pch: 43.0 C mobo: N/A
  Fan Speeds (RPM): N/A
  Processes: 342 Uptime: 9m Memory: 15.49 GiB used: 3.94 GiB (25.5%) Init: systemd Compilers:
  gcc: 12.2.1 clang: 15.0.7 Packages: 1692 Client: KDE Plasma v: 5.27.2 inxi: 3.3.25

Edit: Downloaded the update again and now I magically managed to get to the login screen. Guess it was just some kind of temporary glitch.