System sounds not-muted, even though I have them set to muted

I’ve set the System Sounds to be muted. I type some times too fast and mistypes can lead to the alert sound; which is annoying for me.

Is there other way to make the system actually mute the system sounds?

Disable pcspkr kernel module that creates error beep alerts

sudo rmmod pcspkr

And create a blacklist entry to prevent udev loading it at boot

sudo tee /etc/modprobe.d/nobeep.conf <<< 'blacklist pcspkr'

Disable PC speaker - ArchWiki

I think I didn’t explain correctly. The alert sounds doesn’t seem to this beeper; but instead the “alert” sounds configured in the Sound settings; which I think goes through the “standard” sound output instead.

Anyways, I included that module in the blacklist.

To disable error alert sounds: Open dconf-editor and use search function to find the setting for audible-bell and change this setting to false

If you also want to disable other sound notifications use dconf-editor search to find the setting for event-sounds and change setting to false

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.