System settings wont launch after I changed the theme of the system

I just barely changed my theme in Manjaro linux. When I hit apply it kicked me out of settings. When I tried launch system settings again it just shows the loading circle and thats it. I have restarted my system multiple times and it still wont work. I tried the command systemsettings5 and that didn’t work either. All other apps launch perfectly.

1 Like

Welcome to the forum! :slight_smile:

It could be an incompatible theme. You either way haven’t told us what desktop environment you’re using, and what theme. Without that information, nobody’s going to be able to help you. :man_shrugging:

1 Like

In kde “~/.config/kdeglobals” file “[KDE]” section change “widgetStyle=breeze” or delete kdeglobals file.
In Qt with qt5ct “~/.config/qt5ct/qt5ct.conf” file in “[Appearance]” chage “style=breeze” or delete file.
In Qt without qt5ct remove “~/.config/qt5ct/Trolltech.conf” file
In gtk2 remove “~/.gtkrc-2.0” file.
In gtk3 remove “~/.config/gtk3” folder.

1 Like

Hello, I am using KDE Plasma 20.1.2. I don’t know what theme I used, I think it was called ‘Gently’. I would check which one i’m using but I can’t get into settings.

Try in konsole "cat ~/.config/kdeglobals |grep -i ‘widgetstyle=’ " command.

1 Like

Hello, I tried that command and I don’t exactly understand what it did. I still can’t access my system settings though.( I’m still new to linux and I don’t know a lot about it yet.)

Here is what it popped up when I tried that command. I don’t know if I did it right. I tried to do the command without putting sudo first and nothing happened.

I did this exactly this sudo "cat ~/.config/kdeglobals |grep -i ‘widgetstyle=’ "

It popped this out.

usage: sudo -h | -K | -k | -V
usage: sudo -v [-AknS] [-g group] [-h host] [-p prompt] [-u user]
usage: sudo -l [-AknS] [-g group] [-h host] [-p prompt] [-U user] [-u user] [command]
usage: sudo [-AbEHknPS] [-C num] [-D directory] [-g group] [-h host] [-p prompt] [-R directory] [-T timeout]
[-u user] [VAR=value] [-i|-s] []
usage: sudo -e [-AknS] [-C num] [-D directory] [-g group] [-h host] [-p prompt] [-R directory] [-T timeout]
[-u user] file …

I don’t know what it means. I wish you could upload screenshots, it would make things easier.

You don’t need sudo, only type :
cat ~/.config/kdeglobals |grep -i ‘widgetstyle=’

and press ENTER.

I did that command and it gave me this.

widgetStyle=chameleon

Run this, then be careful about applying compatible themes in the future :wink:

[note - this will select and apply the ‘global theme’ - so desktop and color themes etc will change]

lookandfeeltool -a org.kde.breeze.desktop

(breeze is just the plasma default … so its virtually guaranteed to be ‘working/good’)

1 Like

Thank you, that seemed to work. I’ll be careful which themes I use from now on.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.