System not booting (maybe after manjaro-release update)


Out of nowhere my Manjaro Linux is not starting.

I have dual boot with Windows that didn’t make any update or setting change.

When I select Manjaro Linux in boot menu it only shows a Manjaro logo for a while and then empty screen instead of login screen.

Then I tried to boot using Manjaro Linux fallback initramfs under options for Manjaro Linux it worked only once, then it does not work as well.

I noticed that before last system shut down I updated manjaro-release packge with a bunch of other packages.

I have USB with live Manjaro so I can rescue the system, but I don’t know why.

(please, I really do not want to reinstall the system, for me Manjaro Linux installation does mean at least entire week of pain and errors in the installers and managing dual boot edge cases…)


Have you tried using the option to look for EFI bootloaders from the USB live grub menu? Maybe you can access your installation and troubleshoot it that way.

I don’t know how to look for EFI bootloaders. How to do it?

Last option here “Detect EFI boot loaders”, then try the options it gives you. It’s perfectly safe and it will let you boot up your OS if it works.

Thanks for the advice, however there is no change in manjaro system booting.

There was a change in how we use gdm. Either install gdm-plymouth or remove splash from /etc/default/grub and issue sudo update-grub


Variant no. 1: not working (installed from live Manjaro Linux invoking pacman in my Manjaro Linux system’s mounted root partition)

Variant no. 2: /etc/default/grub - no splash, only in my Manjaro system’s mounted root partition. However both live Manjaro Linux (I am here when trying to fix the boot issue) and my Manjaro Linux system’s update-grub bin file outputs an error: grub-probe - cannot get cannonical path of 'overlay'.

What I have to do?

What is the current of this “splash”?
I saw a few places that were mentioned to clear
Does it have a negative effect on the boot?

My solution was to boot into a live USB and edit /boot/grub/grub.cfg to remove splash option from manjaro installed on hard disk

Made changes in my Manjaro Linux system’s mounted root partition via live Manjaro Linux (actually installer) - deleted all splash occurencies in /boot/grub/grub.cfg (there were three or four), now booting.
Thank you very much!

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.