System mess up. Can't make clean install

So I guess I F**** my system messing around because of my COD on cleanings things.

I followed a wiki here and on Arch wiki on how to clean your system.
I deleted all files in the home cache folder and config folder ( I guess this what is at messed it up).

Now Manjaro boots to plain pure standard XFCE with no Manjaro theming…

Is there a way to restore it back?
I don’t have timeshift backup because of my HDD is very small.

Also I attempted to make a clean install of Manjaro using my Ventoy USB pen.
I go through Calamares installer and after “Install now” nothing happens.
It just goes to back to desktop.
I tried manual partition and replace Manjaro partition with no success.

I’m dual booting Zorin Lite sda1 and Manjaro XFCE sda2.
Bootloader is Manjaro GRUB.
If there’s no chance of restoring,
I’m willing to make a clean install but Calamares it acting up.

Any help appreciated.

Like any other dedicated ISO for a DE or WM - such as KDE Plasma, Gnome, i3wm - the manjaro XFCE has the manjaro-xfce-settings that will have inside /etc/skel/ all the files (hidden files or so called dot files) that have the custom configs manjaro did for it.

Just copy them over back to your home directory and all should be the same as when you installed it first time.

As for why you can’t proceed with a new install, well … without some log files from calamares installer there is no way to know what goes wrong on your side.


I did what you said.
And I was able to get settings like first install…
Thank you

Anything I should do to keep the system running well?

Usually this will suffice

but also following this wiki is a way to keep the system in optimal conditions

1 Like

Can you point out where you were told to delete the .config files and why?

Hello, I followed some of this steps:

Old configuration files

Old configuration files may conflict with newer software versions, or corrupt over time. Remove unneeded configurations periodically, particularly in your home directory and ~/.config. For similar reasons, be careful when sharing home directories between installations."

Well I thought that “remove” means delete files from the config folder.
Maybe there a command line to do this safely with messing the system.

I also followed some steps of this guide:

But deleting the config files is what messed it up.
I ended up with stock XFCE super ugly.

@bogdancovaciu Pointed me in the right way with his solution.

English is not my mother language.

Consider clean install (via usb boot disk) by doing a wipe drive. And select BTRFS as filesystem. Then you can use Timeshift because the snapshots will only contain changed files. Doesn’t consume much space.
Also you can put all personal folders like Documents, Desktop, Pictures on a seperate BTRFS subvolume. That way Timeshift snapshots will automatically exclude those folders.

When this happened I attempted a clean install.
For some reason Calamares was not doing it’s job.

I went ahead with @bogdancovaciu advice and it worked fine.
I’m doing a Timeshift on a USB pen because this ancient laptop’s HDD is very small.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.