System frequently crashing after GPU drivers update

Update: linux-firmware 20210511.7685cf4 solved the amggpu-related crashes for me.

However, I am facing problems with my lenovo usb-c dockingstation. It crashes/ hangs from time to time. But this is another issue and could be related to other system components.

1 Like

I’m glad the upgrade solved it both for you and @AkhIL!! I’ll try performing it soon. Still, what evidence are you basing on to state that it has solved the freezing problem? I don’t mean to sound pessimistic, but I’ve already experience week-long spans without crashing, hoping that it meant a final solution for the problem, just to have another random crash again :confused:

I’m just asking this because you may have noticed some microcode/code change on such update that could be handling the (still unknown) culprit of this issues. If you’re stating it from the growing crash-less spans, then all my hopes are with you to have found a definitive solution :pray:

worked for me too, on other os though.
It was hard crashing every ~3-6 hours, backed off the firmware version to something from november, now sitting on a day uptime with fairly heavy load.

should probably file a bug with the firmware upstream.

1 Like

I got freeze in less then ten minutes with linux-firmware 20210512.r1926.55d9649-1. I had multiple days uptime with 20201124.r1786.b362fd4-1. Trying 20210211.r1830.f7915a0-1 right now.

linux-firmware-20210315.r1846.3568f96-1 should work. I have this version in fully functional snapshot.

1 Like

@poynting_factor your guess seems correct. I agree with you and @AkhIL: The update just reduced the frequency of crashes for me. Only downgrading fixed the problem for me. I am currently using : 20201218.646f159.
I will start testing linux-firmware-20210315.r1846.3568f96-1 as suggested by @AkhIL.


Slightly offtopic: I upgraded to kernel 5.13 rc1 and this is the first time I am actually getting 4k 60 Hz (instead of only 30 Hz) with my Lenovo E585. So far, this seems stable with 20210315.3568f96.

well I think the problem is somewhere buried deep inside the linux-firmware.
I do use now 20201218.646f159 for about 4 days and round about 30h of uptime. NOT ONCE did my system freeze…

Quite considering the upgrade to 5.13, did you allow the linux-firmware / amd-ucode to update with the kernel or are you still on above mentioned version?

Update on my side: I’ve been running smoothly since at least a week, no crashes or unexpected freezes. Just ran the last stable upgrade (from May 19th) a couple of days ago, and as of now nothing seems to have broken. Here are my current package versions:

  • linux-firmware: 20210511.r1922.7685cf4-1.
  • Kernel: 5.12.2-1.
  • mesa and its dependencies: 21.0.3-3.

Not using any special kernel parameters, either. Honestly, I don’t know what may have fixed it; I’m betting that a combination of the firmware and kernel updates solved it (or at least reduced the crashes frequency to the point I can’t get too frustrated on it :sweat_smile:); my guess is still about that line casting a uint to a bigger architecture when performing pagination at AMD devices, the commit was linked earlier here: System frequently crashing after GPU drivers update - #30 by fkfd (I’m not marking it as a solution since I can’t think of anyway to prove it was what really fixed the issue, but I hope I can do so in the future).

1 Like


I’m using the same packages and at first it seemed to have solved the issue. Yesterday I’ve had a freeze again with the same logs in journalctl but unexpectedly it recovered instead of freezing permanently. Before the upgrade and after a freeze there was the need to restart LightDm via CRTL-ALT-F* or if I wasn’t fast enough with a reboot.

I’m using a Lenovo ThinkPad E595 with Cinnamon.

Hope it helps.

Kind regards

I have to correct myself: Sadly it happened again. So the above mentioned packages didn’t solve it for me…

I am on a Ryzen 5 3400G:

Latest stable-upgrades but a downgraded linux-firmware version (20210315.3568f96). It seems that this is the way to go


Hi @Grimmzz ! What kernel and mesa versions are you using?

The same as you:
Kernel 5.12.2-1
mesa 21.0.3-3

how can i downgrade my linux-firmware if just did fresh install?

i do get freezes randomly since last month after month…in starting force shutdown using power button was the only solution for me…but now i am using log out keyboard shortcut to log out session and login again to start new session…it works most of time but it is not a solution…i just switched my kernel to 512…idk it will work or not…i am just frustrated with this problem…we even do not know which line of code is causing problem…maybe kernel from my side…i am searching every post related to this issue …i will let you know if i find anything

1 Like

can you upload this firmware version?

Have you tried using the downgrade package? You can install it right from the AUR with a package manager like yay, and then just call downgrade <package> to try an downgrade such package’s version.

On the other hand, the Arch wiki has a guide on downgrading packages: Downgrading packages - ArchWiki

i have fresh install right now…downgrade only works when you have older packages already in the system.

PLEASE ANYONE UPLOAD linux-firmware …manajro is still freezing even on kernel 512…last option is firmware one…