System freezes when opening certain games

My system consistently freezes when I open certain games, so far the games this happens on are Hearts of Iron 4 and Superhot, other games work just fine. Both open up then freeze, the mouse and keyboard input nothing and the only way to get out of it is doing ctrl+alt+backspace to shut down the X server. I have tried switching kernels and drivers aswell as changing to the unstable branch and even reinstalling Manjaro but nothing has fixed this. I’d appreciate any help on this as I have no idea why this is happening
Output of inxi -Fazy:

  Kernel: 5.13.2-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.13-x86_64 
  root=UUID=29f7dd24-e2ce-41ba-97c4-9b2cd2a783ef rw 
  resume=UUID=387435ef-d4c8-4771-82a1-746d4e103605 udev.log_priority=3 
  Desktop: Cinnamon 5.0.5 tk: GTK 3.24.30 vt: 1 dm: LightDM 1.30.0 
  Distro: Manjaro Linux base: Arch Linux 
  Type: Desktop System: Dell product: G5 5090 v: N/A serial: <filter> Chassis: 
  type: 3 serial: <filter> 
  Mobo: Dell model: 0DXJD9 v: A00 serial: <filter> UEFI: Dell v: 1.4.0 
  date: 10/20/2020 
  Info: 6-Core model: Intel Core i5-9400 bits: 64 type: MCP arch: Kaby Lake 
  note: check family: 6 model-id: 9E (158) stepping: D (13) microcode: EA 
  cache: L2: 9 MiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 34814 
  Speed: 801 MHz min/max: 800/4100 MHz Core speeds (MHz): 1: 801 2: 800 
  3: 1597 4: 900 5: 840 6: 864 
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
  Type: l1tf status: Not affected 
  Type: mds status: Not affected 
  Type: meltdown status: Not affected 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB filling 
  Type: srbds mitigation: TSX disabled 
  Type: tsx_async_abort status: Not affected 
  Device-1: NVIDIA TU117 [GeForce GTX 1650] vendor: Dell driver: nvidia 
  v: 470.42.01 alternate: nouveau,nvidia_drm bus-ID: 01:00.0 
  chip-ID: 10de:1f82 class-ID: 0300 
  Display: server: X.Org 1.20.11 driver: loaded: nvidia display-ID: :0 
  screens: 1 
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x286mm (20.0x11.3") 
  s-diag: 583mm (23") 
  Monitor-1: HDMI-0 res: 1920x1080 hz: 60 dpi: 96 size: 509x286mm (20.0x11.3") 
  diag: 584mm (23") 
  OpenGL: renderer: NVIDIA GeForce GTX 1650/PCIe/SSE2 
  v: 4.6.0 NVIDIA 470.42.01 direct render: Yes 
  Device-1: Intel Cannon Lake PCH cAVS vendor: Dell driver: snd_hda_intel 
  v: kernel alternate: snd_soc_skl,snd_sof_pci_intel_cnl bus-ID: 00:1f.3 
  chip-ID: 8086:a348 class-ID: 0403 
  Device-2: NVIDIA vendor: Dell driver: snd_hda_intel v: kernel 
  bus-ID: 01:00.1 chip-ID: 10de:10fa class-ID: 0403 
  Sound Server-1: ALSA v: k5.13.2-1-MANJARO running: yes 
  Sound Server-2: JACK v: 0.125.0 running: no 
  Sound Server-3: PulseAudio v: 14.2 running: yes 
  Sound Server-4: PipeWire v: 0.3.31 running: no 
  Device-1: Realtek vendor: Dell driver: r8169 v: kernel port: 3000 
  bus-ID: 03:00.0 chip-ID: 10ec:2502 class-ID: 0200 
  IF: enp3s0 state: down mac: <filter> 
  Device-2: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter 
  vendor: Dell driver: ath10k_pci v: kernel port: 3000 bus-ID: 04:00.0 
  chip-ID: 168c:0042 class-ID: 0280 
  IF: wlp4s0 state: up mac: <filter> 
  Device-1: Qualcomm Atheros type: USB driver: btusb v: 0.8 bus-ID: 1-14:5 
  chip-ID: 0cf3:e009 class-ID: e001 
  Report: rfkill ID: hci0 rfk-id: 1 state: up address: see --recommends 
  Local Storage: total: 3.19 TiB used: 352.23 GiB (10.8%) 
  SMART Message: Required tool smartctl not installed. Check --recommends 
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Toshiba 
  model: KBG40ZNS256G NVMe 256GB size: 238.47 GiB block-size: physical: 512 B 
  logical: 512 B speed: 31.6 Gb/s lanes: 4 rotation: SSD serial: <filter> 
  rev: 10410104 scheme: GPT 
  ID-2: /dev/sda maj-min: 8:0 vendor: Seagate model: ST1000DM010-2EP102 
  size: 931.51 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s 
  rotation: 7200 rpm serial: <filter> rev: CC45 scheme: GPT 
  ID-3: /dev/sdb maj-min: 8:16 vendor: Seagate model: ST2000LM015-2E8174 
  size: 1.82 TiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s 
  rotation: 5400 rpm serial: <filter> rev: 0001 scheme: GPT 
  ID-4: /dev/sdc maj-min: 8:32 type: USB vendor: HP model: x900w 
  size: 231.6 GiB block-size: physical: 512 B logical: 512 B serial: <filter> 
  rev: PMAP scheme: MBR 
  ID-1: / raw-size: 230.09 GiB size: 225.42 GiB (97.97%) used: 10.6 GiB (4.7%) 
  fs: ext4 dev: /dev/nvme0n1p3 maj-min: 259:3 
  ID-2: /boot/efi raw-size: 953 MiB size: 951.1 MiB (99.80%) 
  used: 296 KiB (0.0%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1 
  ID-3: /home raw-size: 931.51 GiB size: 915.81 GiB (98.31%) 
  used: 26.51 GiB (2.9%) fs: ext4 dev: /dev/dm-0 maj-min: 254:0 
  mapped: luks-aa82af9d-e24b-4334-9919-b20959c49550 
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default) 
  ID-1: swap-1 type: partition size: 7.45 GiB used: 0 KiB (0.0%) priority: -2 
  dev: /dev/nvme0n1p2 maj-min: 259:2 
  System Temperatures: cpu: 52.0 C mobo: N/A gpu: nvidia temp: 39 C 
  Fan Speeds (RPM): N/A gpu: nvidia fan: 20% 
  Processes: 266 Uptime: 10m wakeups: 0 Memory: 23.34 GiB 
  used: 2.95 GiB (12.6%) Init: systemd v: 249 target: 
  tool: systemctl Compilers: gcc: 11.1.0 Packages: pacman: 1169 lib: 400 
  flatpak: 0 Shell: Bash v: 5.1.8 running-in: gnome-terminal inxi: 3.3.05 ```

Tip: When pasting terminal output on Discourse forums, one can either…

  • Highlight it and use the Preformatted text </> toolbar button.

  • Add three backticks ` above and below the text (Markdown):


  • Use HTML:


Please edit your post accordingly.

1 Like

Since update one of my games(grim dawn) has been freezing(in exact same spot every time) as well, with that error in journal:
NVRM: Xid (PCI:0000:01:00): 31,

Deleting wine prefix and then launching game with latest glorious eggroll proton solved the issue

Update: after some time grim dawn started to crash again, just not as often as before :frowning_face:

1 Like

Doesn’t seem to fix it for me, both games just don’t launch now(though that’s definitely better than the computer freezing)

have you deleted wine prefix first? It’s in the home/yourprofile/.steam/steam/steamapps/compatdata/ and then game id, which you can find in steam library > game properties > updates
Don’t forget to back up saves first though if you care

1 Like

No folder is there, btw both of the games are native to Linux

well i am sorry, i checked superhot on steam and scrolled all the way down and there weren’t linux requirements so i assumed it wasn’t native, i can see it being native now though.

1 Like

It’s fine, hopefully this will help someone else

Probably the same bug from this bug report.

If it’s the same bug, the workarounds I know are downgrading cinnamon or playing the game in lower resolution windowed mode, at least until they update the fix.