System feels slow - on a new laptop

100% CPU usage for watching youtube doesn’t sound normal. Anyway, can you safely disable your laptop camera and/or microphone on your laptop? I don’t have the same hardware so I can’t tell you how to do that.

No, I wouldn’t know how to do that.

Hmm, that’s too bad. I’ve seen recent pulseaudio causing buffer overflow when the mic is on. I thought that what might causing the slow down. Or perhaps firmware issue as it’s the most common problem with laptops. You can keep watching your system monitor (or you can use htop from console). Somehow I doubt that Xorg is taking your CPU that much like you posted before. You can post your laptop model and manufacture here. Maybe someone else here with the same hardware can help you. You can also switch to other distro too if you want. :slight_smile:

Interesting, well I’m using System 76’s Serval WS, for anyone who also uses this. I’m pretty sure it’s Xorg using my CPU as htop says it is, but I can’t be sure I guess. Thank’s for all the help, I guess I’ll switch back for now.

I don’t know if you use grub, but in that case you could change your grub config cmf_line_linux_default from:

GRUB_CMDLINE_LINUX_DEFAULT="quiet udev.log_priority=3"


GRUB_CMDLINE_LINUX_DEFAULT="quiet pci=assign-busses apicmaintimer idle=poll reboot=cold,hard udev.log_priority=3"

To do so.

open a terminal

sudo nano -w /etc/default/grub

edit the line as stated above

save with Ctrl + o

close nano with Ctrl + x

rebuild the config with

sudo grub-mkconfig -o /boot/grub/grub.cfg


There’s an extra quotation mark, what should i do with that? remove it, or did you miss an opening one

Following the conversation in the thread, it seems like he is not using hardware acceleration for his video card, i have no idea how to check or enable that but wanted to throw in my $0.01 observation :handshake: :wink:

was a typo, edited it

You’re correct you should remove the one between hard" udev :wink:
Edit he already corrected his post while i was writing :rofl:

OpenGL: renderer: GeForce GTX 1660 Ti/PCIe/SSE2 v: 4.6.0 NVIDIA 455.45.01

tells it is

Didn’t fix the problem, sadly. It is possible I’m not using hardware acceleration, I wouldn’t know.

edit: suppose i am then

Ahh ok, i didn’t know if that was displayed for both modes or only when hardware acceleration is enabled…

You can type “glxinfo | grep render” (or just glxinfo in general) in console to see if you’re using gpu direct rendering or not. :slight_smile:

For Nvidia I surely would not advice to set hardware acceleration in the browser.

SInce I understand you also have it with other things not browser related. but just incase

what is the output of

glxinfo | grep "direct rendering"

why o why :crazy_face:

direct rendering: Yes

Not completely, your right in that, it shows OpenGL is active on Nvidia and most of the time this means direct rendering is also set correctly. But to be sure a glxinfo is asked already.

thought so.

could you humor me and just let gears run for 3 outputs and show them.

so in a terminal


let is come up with 3 outputs and close gears (not the terminal) and paste the output.

708 frames in  5.001 seconds = 141.572 FPS
720 frames in  5.000 seconds = 144.000 FPS
721 frames in  5.006 seconds = 144.027 FPS

Seems al okay to me.

So it does not seem to be related to your GPU at first sight.