System doesn't Sleep

I recently installed Manjaro 20.2 on my ThinkPad P50 and decided to go on a week of using Linux exclusively. I’ve been very happy with my setup except one thing – the laptop sometimes refuses to go to sleep and just freezes and forces me to manually turn off the system by holding the power button.

I’ve tried to see how best I can replicate this behaviour. On a fresh boot, the laptop goes to sleep without any issues. I’ve noticed that the laptop fails to go to sleep on the second attempt to go to sleep after I have been using the laptop for a couple of hours. Let me list the steps. (1) Boot into Manjaro. (2) Use it for a couple of hours. (3) Sleep. The laptop goes to sleep without any issues. (4) Return from sleep and use for a couple of hours. (5) Go to sleep again. The laptop fails to go to sleep. In fact, instead of going to sleep, it takes me to the user log in screen as if I resuming from sleep. If I attempt to sleep again or reboot, it just freezes. This has been the only issue so far and would really love to get some feedback on how to fix it.

In case this is relevant: I’m on kernel 5.8. I have Nvidia Proprietary drivers (450) installed so I can use an external monitor since external monitors are connected directly to the Nvidia GPU. Also, I’m not doing anything fancy. I am just browsing the web with Chrome and have a couple of Jupyter notebooks open.

5.8 kernel is EOL … switch to 5.9 and also install video-nvidia instead; the latest driver 455.
Make sure you update your system first.

Multiple “sleeps” is a tricky thing, maybe someone will pass by and give some thoughts …

I had an issue with the brightness control not working on 5.9. That’s why I switched to 5.8.

Have you tried 5.4.80 LTS?