System doesn't show login screen after booting up


I installed Manjaro for the first time yesterday. After a smooth installation process I used it for a few hours last night. As I recall I installed vim and zsh, not much more than that. I did run pacman -Syu to update existing packages.

This morning I’m unable to log in after a reboot. I just see the attached screen indefinitely. This is before I ever have any opportunity to type in a username or password. (I did type in the master password to decrypt the disk partition.)

zsh is already there and the default shell. So probably not.

Maybe you meant to share an image?
There is none - probably because you are a new user. Images are discouraged anyways.

So … can you better describe your error?
What do you see?

Also these:

I’m not able to either attach a short video or include a link to it elsewhere.

I see just 3 dots animating indefinitely. This has been going on for over an hour. I can reboot by Ctrl-alt-del but end up back here. I don’t have access to any text mode consoles using C-M-F1, etc.

So you just see plymouth.
(graphical splash screen during boot)

That doesnt tell us anything.
Try booting into runlevel 3 as described in the link above.
It should at least give us more information … if not allow you to login to a nongraphical session.

I tried editing into the default boot option and appending a 3 to the line that started with linux (it was a lot longer than the example shown your first tutorial above.) However it didn’t seem to have any effect. After I hit F10 I still end up at the Plymouth screen.

Thanks for helping me here!

If you cannot boot into it using the available system or some fallback option … then you will need to use a live media (like a manjaro usb) to chroot into the system.

It’s somehow started working again!

I experimented with runlevel 2 and then 1. At runlevel 1 I was able to log on as root. I spent a couple of minutes staring at dmesg and /var/log/boot.log. I then typed exit, and… was surprised to get to the graphical login dialog. After a reboot things seem cleared up… :thinking:

Its possible what you were experiencing was fsck - trying to fix the filesystem if corrupted, such as after a forced shutdown. The operation would take some time … thanks to plymouth you wouldnt see it … and if you kept force restarting during that operation then the problem would compound. During your attempts to boot into a lower runlevel the operation was able to succeed.

…Maybe. I cant know … but its a story that could fit.

You could maybe check the journal or other logs to see what was going on.

Anyhoo … glad its working again.

1 Like

Now the problem is back :frowning:

And runlevel 1 no longer helps. Just goes to Plymouth without giving me a text mode login.

I might leave it open overnight. But I’ve always shut it down carefully…

FWIW I didn’t see any sign of fsck in dmesg or boot.log

Minor follow-up: I double checked my .bash_history, and I did perform a pacman -S zsh after installing Manjaro xfce. At least, I had to chsh to it even if I missed a message about it being already installed.

You have not provided any system information - but judging from your profile you are using Xfce desktop on a AMD system with AMD gpu using linux 6.1.

Since the greeter provides a graphical login - it is dependend on the GPU drivers - provided by the kernel.

Then you will have synced the latest LTS kernel - which appears to bring with it a regression which causes some AMD GPUs to fail.

On several occasions the solution was to use runlevel 3 and sync the latest stable kernel

Perhaps your system is affected by this

sudo mhwd-kernel -i linux64

Thank you @linux-aarhus!

Before your message I switched to Manjaro Plasma and the problem hasn’t recurred. I might still be exposed to the issue though. I’m still on the 6.1 LTS here just as I was before.

When I look at the stable version seems to be 6.4.11. However the organization into rows suggests the entire 6.4.y line is considered the current stable.

When I look in the Kernels screen of Manjaro Settings Manager I see two options for the 6.4.y line. One of them is tagged ‘Real-time’. Could you advise which of these I should use, best guess?

For future reference, would the workaround for this issue have been to go into Advanced options and select a different kernel? I’m reluctant to actually reboot to check :smile:

linux64 can be considered stabel - unless you have superspecific requirements - such as music production or highend video - you should just go with the default 6.4.x kernel.

Just for the experimentaion I am building linux-next and on my system it works quite well

Could you elaborate on what you mean by ‘default’? I hadn’t made any changes to the kernel before I ran into the problem. And neither of the 6.4 kernels is listed as ‘recommended’. I’m on the ‘recommended’ LTS release by default, it seems.

mhwd -i linux64 doesn’t quite work for me. Ohh, it’s mhwd-kernel based on Manjaro Hardware Detection Overview - Manjaro. I’ll try that and forget the Kernels list in the UI.

Actually, before I try that: my previous comment was about contingency plans. Is there a way to choose between the kernels listed in mhwd-kernel -l from the GRUB boot screen?

Hello from linux64! I am hopeful that this issue is now resolved. Thank you for teaching me some tools for reasoning about what kernel I’m currently using and what options I’ll have on a reboot. One trick I leaned on is to go look at /boot/grub/grub.cfg and try to imagine the boot screen when I reboot.

I think you mean mhwd-kernel -li

And yes … grub should allow you to select a kernel at boot.
If you dont see it … then grub may be hidden … try hitting Esc to make it appear.
You may also look at options in /etc/default/grub like GRUB_TIMEOUT
(and run sudo update-grub after edting that file to apply changes)

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.