System doesn't mount my phone

I connected my phone in my computer and i can’t acess anything in my phone, i don’t know if the problem is exactly that isn’t mounted, i tried some tutorials and didn’t worked.
I’ll be glad if someone could help me, i’m pretty much new to Manjaro and Linux.

1 Like

What phone is this? iOS? Android? Different OS?

For android, you might need to instal libmtp if it isn’t already installed. And gvfs-mtp if using file managers that uses GVFS, or kio-extras for dolphin.

It’s android, it worked, but, sometimes just don’t transfer archives but seems like if i unplug and plug again it works

(I would make a new thread, but I don’t see how.)

Dolphin and android-file-transfer say my device does not exist. This is happening with multiple Android phones running both stock ROMs and LineageOS, Android versions 9, 10 and 11, with and without USB Debugging enabled.

I’m using Manjaro KDE with the 5.4 kernel. I have kio-extras installed. I do not have jmtpfs nor mtpfs installed. I have tried all the troubleshooting options listed in the Arch wiki post mentioned in the cant-mount-mtp post on this forum. The error continues. I can access the phones vis KDEConnect or FTP. I would really like to access them via USB.

had the same problem for years and have yet to find an answer. The phone will randomly connect but most times it fails. Still no clue what is wrong. The computer sees the correct phone but can’t seem to open up the files in dolphin.

Same problem.

I have tried to connect my Galaxy S8 and Note 9 and the connection is hit or miss, most often miss.

Dolphin sees the devices as Android Device but when clicking there is a message at the top of the window saying something about unable to access the device and to enable MTP which is already enabled.

I hope this issue is fixed in the future, it’s very annoying to deal with.

On Android you likely also need to react to a pulldown notification alerting you that a USB connection has been made and to explicitly select data transfer. Not sure how long you have to do this before the opportunity is lost, but move reasonably quickly after plugging it into your USB jack of the computer running your Linux/Manjaro installation.

The phone has operating system protections against simply being “taken” by outside forces. :wink:

To piggy-back on @SomeGuy when you plug in the phone, you have to then unlock the device (fingerprint or whatever), then respond to a permission prompt on the phone before the filesystem can be mounted. You folks able to mount sometimes but not others are perhaps plugging in the phone when it is already unlocked in your hand and getting different results.

My current workaround for getting my computer to read my phone is using Nemo file manager. I’ve plugged and unplugged my phone from my computer 4 consecutive times each being a success. When my phone shows up in Nemo as “ANDROID” I click it, then while my phone is unlocked on the home screen I tell it to Allow data to be sent and received and then the “ANDROID” label disappears and reappears after a moment, then I can click it and access the contents of both my phone and its SD card.